1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Haldex not working?

Discussion in 'A3/S3 Forum (8L Chassis)' started by s3 Hoggy, Nov 11, 2010.

  1. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 11, 2010]
    Everything with my car has been working sweet as a nut until yesterday. Basicly I put my foot down and get a lot of wheelspin with no signs of the haldex helping out?
    It's always been serviced on time (the haldex) with the last oil and filter change 4,000 miles ago. I don't experience any other symptoms like others have with thee point turns ect, also my car has only done 52,000 miles.

    Anybody have Ideas as to why this might be happening?
    Thanks for reading,
    Matt
    #1
  2. Ads

    Ads

    [Sep 21, 2014]

  3. alijames
    Offline

    alijames Active Member

    Joined:
    Feb 10, 2008
    Messages:
    1,024
    Likes Received:
    0
    [Nov 11, 2010]
    Matt, The obvious one is the fuse. Failing that, best way forward would be a Vag-com start to the investigation.

    I've got an eBay serial one which works fine on 409.1 on my laptop. Sadly I'm away from tonight, otherwise could have brought it into Oxford this morning...

    Cheers,
    #2
  4. finesse
    Offline

    finesse Active Member VCDS Map User

    Joined:
    Aug 15, 2006
    Messages:
    2,811
    Likes Received:
    10
    [Nov 11, 2010]
    best to scan
    #3
  5. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 11, 2010]
    Ah well mate no worries, I'll hopefully be getting it plugged in tonite if the garage round the corner will fit me in,
    #4
  6. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 11, 2010]
    Just phoned the garage and they can't fit me in for two weeks! Even for a diagnostics check! Think I'm going to buy an EBay lead and see if any thing shows up?
    #5
  7. finesse
    Offline

    finesse Active Member VCDS Map User

    Joined:
    Aug 15, 2006
    Messages:
    2,811
    Likes Received:
    10
    [Nov 11, 2010]
    eBay cable will do
    #6
  8. colicabcadam
    Online

    colicabcadam Guest

    [Nov 11, 2010]
    could also be the hand brake switch, if this is fooked, it'll stop the haldex working
    #7
  9. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 11, 2010]
    Would this not cause the handbrake light to be on all the time mate?
    #8
  10. colicabcadam
    Online

    colicabcadam Guest

    [Nov 11, 2010]
    in THEORY yes
    #9
  11. alijames
    Offline

    alijames Active Member

    Joined:
    Feb 10, 2008
    Messages:
    1,024
    Likes Received:
    0
    [Nov 11, 2010]
    Matt. if you are getting an eBay lead, I would advise getting a serial one, rather than a USB one. I tried 3 USB ones and none of them worked. 1st Serial one worked perfectly and still does..

    Cheers,
    #10
  12. Nilz
    Offline

    Nilz Defo worth the wait :)

    Joined:
    Apr 9, 2006
    Messages:
    10,255
    Likes Received:
    403
    [Nov 11, 2010]
    Dude, is there nobody else nearby that can do a scan for you??
    #11
  13. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Nov 11, 2010]
    Dude, check the fuse as mentioned as first port of call. It's fuse 31. Top fuse in the middle column. Will be orange IIRC.

    Next, have a look at the plug on the diff. I've seen 2 separate S3s where this has become corroded inside and needed repair.

    If you are not getting any Haldex, then expect an error code along these lines:


    Controller: 8N0 907 379 E
    Component: ESP 20 CAN V005
    Coding: 18448
    Shop #: WSC 01236
    1 Fault Found:
    01324 - Control Module for All Wheel Drive (J492)
    49-00 - No Communications
    #12
  14. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 11, 2010]
    Thanks for your help guys,
    Checked the fuse, looked fine but I still replaced it. That didn't sort it worth a try.
    Next I will be checking the plug on the diff as Welly said (will have t wait till Saturday now as no light)
    I will be ordering a lead tonight

    Thanks for everyones help so far,
    Matt
    #13
  15. colicabcadam
    Online

    colicabcadam Guest

    [Nov 11, 2010]
    get the wheels off the ground, see if they all spin when you put it in gear, if thye do, i'd say it's a sensor problem (ie 5% of power is going to the wheels, so the heldex isnt broke)
    #14
  16. pj123
    Offline

    pj123 Member

    Joined:
    Oct 5, 2010
    Messages:
    295
    Likes Received:
    9
    [Nov 11, 2010]
    Isn't there an earth strap that corrodes back there? Vaguely remember reading about it but may have not been onto the haldex...
    #15
  17. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 11, 2010]
    Where abouts is this mate? I had a quick look in the dark with a torch but its bloody cold and windy so I've come back inside! also where abouts is the earth strap?
    #16
  18. The Doctor
    Offline

    The Doctor Well-Known Member

    Joined:
    Jul 25, 2009
    Messages:
    1,285
    Likes Received:
    112
    [Nov 11, 2010]
    Keep us posted with this one Hoggy, hope you get it sorted.
    #17
  19. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 11, 2010]
    Will do pal
    #18
  20. SamiG
    Offline

    SamiG On Boost, ish.

    Joined:
    Feb 25, 2010
    Messages:
    231
    Likes Received:
    2
  21. mhr1972
    Offline

    mhr1972 Member

    Joined:
    Nov 24, 2004
    Messages:
    37
    Likes Received:
    0
    [Nov 12, 2010]
    I had this last year and it was down to my earthing strap from body to rear diff/haldex.
    #20
  22. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    729
    [Nov 12, 2010]
    yes worth a check....
    #21
  23. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 12, 2010]
    Cheers guys I'll have a look hopefully tonite if It's still light, can any body confirm which side the earth strap is on?
    #22
  24. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 12, 2010]
    I have found this, could it be the Earth strap? It's bolted from the drive shaft to the underside of the spare wheel well. As you can see it's pretty fecked! Snapped in half

    [​IMG]
    #23
  25. alijames
    Offline

    alijames Active Member

    Joined:
    Feb 10, 2008
    Messages:
    1,024
    Likes Received:
    0
    [Nov 12, 2010]
    Yup. That'd do it...

    Cheers,
    #24
  26. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 12, 2010]
    Right I fixed the strap, I'll be taking her for a test drive in the morning, Fingers crossed it's sorted!
    #25
  27. Duktor
    Offline

    Duktor Member

    Joined:
    Oct 3, 2010
    Messages:
    282
    Likes Received:
    0
  28. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 13, 2010]
    bad news the strap doesnt seem to have fixed the problem,

    I have found a fault code though, does anybody know what this might be? my repair on the strap wasnt fantastic as I was rushing so might have another look at that in the morning?


    VCDS-Lite Version: Release 1.0
    Saturday, 13 November 2010, 17:09:28:0
    Control Module Part Number: 02D 900 554 C
    Component and/or Version: HALDEX LSC ECC 0009
    Software Coding:
    Work Shop Code:
    1 Fault Found:
    65535 - Internal Control Module Memory Error
    00-00 - -

    Any help would be great,
    Cheers Matt
    #27
  29. pj123
    Offline

    pj123 Member

    Joined:
    Oct 5, 2010
    Messages:
    295
    Likes Received:
    9
    [Nov 13, 2010]
    I thought I'd check the earth strap today while I was changing my oils. I have a pre facelift model 1999 and it does not have an earth strap at all...
    #28
  30. JS1500
    Offline

    JS1500 Howdy

    Joined:
    Sep 28, 2009
    Messages:
    1,168
    Likes Received:
    8
    [Nov 13, 2010]
    New strap is only summin like £13, IIRC.
    #29
  31. SamiG
    Offline

    SamiG On Boost, ish.

    Joined:
    Feb 25, 2010
    Messages:
    231
    Likes Received:
    2
  32. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 14, 2010]
    Does anyone know if the earth souls be bolted to the chasis and the spare wheel well? As I've only bolted it back to the wheel well
    Last edited: Nov 14, 2010
    #31
  33. dantheman1986
    Offline

    dantheman1986 Member

    Joined:
    Mar 27, 2006
    Messages:
    255
    Likes Received:
    0
    [Nov 26, 2010]
    did you find the problem in the end s3?
    #32
  34. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Nov 26, 2010]
    Not yet mate but everything seems to be pointing towards the haldex controller, havnt got s lot of time to get it sorted at the moment, as soon as anything changes I'll update this thread
    #33
  35. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Mar 19, 2011]
    WooooooooooooooHooooooooooooo! Fitted a second hand haldex controller this morning and now I have my 4wd back! Big thankyou to Rob (aka Cecilthesausage) for the part
    #34
  36. karls s3
    Offline

    karls s3 Member

    Joined:
    Feb 5, 2011
    Messages:
    226
    Likes Received:
    1
    [Mar 19, 2011]
    Hi mate was this easy to fit..
    #35
  37. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,657
    Likes Received:
    98
    [Mar 19, 2011]
    It wasn't that hard as such, I done it on ramps as you are best off with as much room as possible. It's just a case of removing the cover plate that protects the haldex plug, then unplug it there and also unplug the haldex at the controller itself, two Allen bolts hold the controller on undo these and your away! You loose a spoon full of oil. Then just repeat in reverse to fit the new one, holding the gasket in place is the biggest pain in the arse! I would reccomend getting the top screw in first a couple of turns then the bottom ensuring you still have the gasket it the right place. Tighten it all up and reconnect the plugs and your there.
    So yeah it's not a difficult job just fiddly and I kept getting **** in my eyes!
    #36
  38. karls s3
    Offline

    karls s3 Member

    Joined:
    Feb 5, 2011
    Messages:
    226
    Likes Received:
    1
    [Mar 19, 2011]
    Cool cheers mate as I will need to get hold of one soon and fit it..
    #37
  39. cecilthesausage
    Offline

    cecilthesausage ...It's Never Finished...

    Joined:
    Jul 20, 2010
    Messages:
    933
    Likes Received:
    111
    [Mar 19, 2011]
    No bother mate glad to help nothing worse than a sick S3:crying:
    #38
  40. s3ben19
    Offline

    s3ben19 New Member

    Joined:
    Jan 13, 2011
    Messages:
    6
    Likes Received:
    0
    [Mar 24, 2011]
    how much and where do you find these contol units
    #39
  41. cecilthesausage
    Offline

    cecilthesausage ...It's Never Finished...

    Joined:
    Jul 20, 2010
    Messages:
    933
    Likes Received:
    111
    [Mar 24, 2011]
    I sold mine to Hoggy for £100 pound which I think is about the going rate.... Dont know how often they come up though bud:think:
    #40

Share This Page