1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Haldex not working, lots of wheel spin.

Discussion in 'A3/S3/Sportback (8P Chassis)' started by MattS3, Jun 22, 2014.

  1. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 22, 2014]
    Noticed the car is struggling to get the power down this last week.
    Initially thoughtit might be tyres but it's actually the rear wheels are not being driven .

    A quick Google search reveals a possible pre pump issue might be to blame.

    No lights are on the dash so it's off to the garage this week for an investigation.

    Has anybody had similar issues with an 8P?
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. Alex_Wil
    Online

    Alex_Wil Stage 2+

    Joined:
    Feb 17, 2014
    Messages:
    349
    Likes Received:
    161
    [Jun 22, 2014]
    Hi Matt .

    I just had a problem with haldex clutch pump and had to get that replaced . are your front wheels spinning and traction light flashing ?
    #2
    RedDejavu likes this.
  4. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 22, 2014]
    Hi Alex.
    Yep, if I plant my foot, the wheels will spin and flash the ESP light.
    Was yours a warranty job? I'm out warranty by 4 months.
    #3
  5. Alex_Wil
    Online

    Alex_Wil Stage 2+

    Joined:
    Feb 17, 2014
    Messages:
    349
    Likes Received:
    161
    [Jun 22, 2014]
    Could be exactly same as mine .. With regards to warranty it's a tricky one .. my car was still under warranty and I've had a remap and they said no but after I had it done I found out it should of been under warranty because it was an electrical fault which wouldn't of been caused by the power from the map! If it's mechanical they could argue it's down to the power in the car if you've had a remap ?

    Has your car had anything done to it ?
    #4
    MattS3 likes this.
  6. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 22, 2014]
    Had a remap.
    My thinking was around a goodwill gesture, even 50% would be a result.
    Like you're saying, a remap could put more stress I the drivetrain, but a pump would be electrical, so can't reallysee why they would fight too much over it .
    But, I'm 4 months out of warranty so could well end up paying.
    Any idea what the cost/time was for yours?

    Cheers.
    #5
  7. Alex_Wil
    Online

    Alex_Wil Stage 2+

    Joined:
    Feb 17, 2014
    Messages:
    349
    Likes Received:
    161
    [Jun 22, 2014]
    It's definitely worth asking , Depends on the dealer aswell I suppose !

    Audi charged around 500 Inc vat fitted and I got mine done for around 300 Inc vat fitted from AMD for a whole pump replacement ... not sure if it's most audi garages but some just used a repair kit to fix it but could be better to change whole pump ?
    #6
    MattS3 likes this.
  8. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 22, 2014]
    £300 doesn't seem so bad.
    I should imagine the part itself is quite an easy swap, but the pump is the biggest expense.

    Many thanks for your replies, that's at least given me some idea of what it might be.

    Cheers.
    #7
  9. Alex_Wil
    Online

    Alex_Wil Stage 2+

    Joined:
    Feb 17, 2014
    Messages:
    349
    Likes Received:
    161
    [Jun 22, 2014]
    No problem . try and see if audi will do it under good will and if not and you can't get to some were like AMD ,audi do price match work on audi genuine parts so you should be able to get a cheaper job from them anyway !

    Alex
    #8
    MattS3 likes this.
  10. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 23, 2014]
    Checked with AMD to see if they used genuine parts or if they had a supplier of refurbished units.
    They confirmed they use new genuine parts, so I called Audi today.
    The part itself is £200, so I'm guessing my local independent will be able to fit in an hour plus the cost of some Haldex oil, for about a £100
    If I had any idea how easy the oil is, I'd tackle it myself as my Dad has a pit in his garage which makes this stuff pretty simple.
    My only concern is that I might need special tools or process for the oil removal and top up.

    For the sake of the hassle, I'll get it fitted by my independent.
    Audi "might" give me some goodwill on the part, but if it's double the labour charge, I'll end up paying more.
    #9
  11. s3_trev
    Offline

    s3_trev 3 door or no door!

    Joined:
    Nov 29, 2013
    Messages:
    736
    Likes Received:
    159
    [Jun 23, 2014]
    How many miles are on it?
    #10
  12. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 23, 2014]
    It's done 56k in 3 and half years.
    #11
  13. s3_trev
    Offline

    s3_trev 3 door or no door!

    Joined:
    Nov 29, 2013
    Messages:
    736
    Likes Received:
    159
    [Jun 24, 2014]
    Did it get its haldex service at 38k?
    #12
  14. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 24, 2014]
    Yep, sure did, bang on the mileage. (DSG was done at the same time).
    It feels more likely to be pump (electrical) related other than oil/mechanical as it literally stopped working with no other noise etc.
    #13
    s3_trev likes this.
  15. Statler
    Offline

    Statler Old enough to know better

    Joined:
    Mar 31, 2014
    Messages:
    275
    Likes Received:
    220
    [Jun 24, 2014]
    I read somewhere else here that the guy pulled the haldex fuse to make the car run on the front wheels.
    Assume you've checked the fuses?
    #14
    Alex_Wil likes this.
  16. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 24, 2014]
    When I looked at the fuses and relative roles performed, the Haldex was run from the same fuse as the DSG gearbox.
    The DSG box is running fine, so I never even bothered pulling the fuse, if you see what I mean?
    #15
  17. jaygemson
    Offline

    jaygemson Member

    Joined:
    Dec 15, 2013
    Messages:
    37
    Likes Received:
    20
    [Jun 24, 2014]
    Are there any fault codes stored?

    Just thinking out loud, my TT reverted to front-wheel drive only and that turned out to be a corroded electrical connector to the Haldex unit right at the back of the car. Audi wanted to replace the whole Haldex unit before I found the problem and fixed it myself for pennies.
    #16
    ron burgandy likes this.
  18. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 24, 2014]
    It's in the garage on Friday, I have no way of checking fault codes unfortunately.
    I'm sceptical that its the connector, I read its a possibility with the 8L version of these cars, but they would be getting older so was kinda thinking that at just over 3 years, the connector would still be good (but also cause the issue to be more intermittent if a dodgy connection maybe?)
    I'll mention it to the garage when I drop it off on Friday, that's for sure, but might pop over to my parents and check the connection over my dads garage pit in the meantime if I get chance.
    #17
  19. s3_trev
    Offline

    s3_trev 3 door or no door!

    Joined:
    Nov 29, 2013
    Messages:
    736
    Likes Received:
    159
    [Jun 24, 2014]
    God that's worrying then. Keep us updated, id be very interested to find out whats causing your problem.
    #18
  20. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 24, 2014]
    Audi UK had 38 pumps in stock.
    That tells me it's a relatively common issue.
    #19
  21. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 27, 2014]
    Yep, had it confirmed today as the pre pump for the haldex. It's gone open circuit.
    New one ordered and being fitted next week, which will include a haldex oil change too whilst it's being fitted.
    #20
  22. RedDejavu
    Offline

    RedDejavu Well-Known Member

    Joined:
    Feb 16, 2011
    Messages:
    1,533
    Likes Received:
    179
    [Jun 27, 2014]
    funny how many pumps have gone within last few months just around this forum.
    #21
    Alex_Wil likes this.
  23. s3_trev
    Offline

    s3_trev 3 door or no door!

    Joined:
    Nov 29, 2013
    Messages:
    736
    Likes Received:
    159
    [Jun 27, 2014]
    Flip. Thanks for keeping us up to date. Will keep this in mind if I ever have issues. How much was the part?
    #22
  24. Alex_Wil
    Online

    Alex_Wil Stage 2+

    Joined:
    Feb 17, 2014
    Messages:
    349
    Likes Received:
    161
    [Jun 27, 2014]
    What year is your car matt ? - do think it could be affecting the newer 8p?
    #23
  25. RedDejavu
    Offline

    RedDejavu Well-Known Member

    Joined:
    Feb 16, 2011
    Messages:
    1,533
    Likes Received:
    179
    [Jun 27, 2014]
    61 plate buddy have bought it dec 11
    #24
  26. Alex_Wil
    Online

    Alex_Wil Stage 2+

    Joined:
    Feb 17, 2014
    Messages:
    349
    Likes Received:
    161
    [Jun 28, 2014]
    Seems more common for 08- cars? That's three people in a 2 months its happened!
    #25
  27. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 28, 2014]
    2011 61 Plate.
    It seems more common on cars around 2010 - 2011 by the looks of the replies on here.
    I'll be glad to get it fixed, the car is a bit of a handful with just the front wheels being driven, you really notice it when pressing on, especially overtaking.

    The part is £200 for whoever was asking. Fitting is relatively straight forward but makes sense to change the oil at the same time which pushes the price up to over £300 .
    Not that bad really.
    #26
    S. and Alex_Wil like this.
  28. RedDejavu
    Offline

    RedDejavu Well-Known Member

    Joined:
    Feb 16, 2011
    Messages:
    1,533
    Likes Received:
    179
    [Jun 28, 2014]
    Yet dearer than swapping the exhaust and taking back to audi on the warranty isnt it:D. Thats the only reason I swapped my milltek however this pushed me to buy a new exhaust now as I always wanted the powervalve system! :(. So it's ended up as a very expensie repair!
    #27
  29. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jun 28, 2014]
    Prefect example of man maths in operation there! Very much the way I'd go about things normally....car's, men and money, what a financially ruinous combination.
    (Not men in a relationship type of way, just to clarify!)
    #28
  30. veeeight
    Online

    veeeight Well-Known Member

    Joined:
    Jul 14, 2012
    Messages:
    1,851
    Likes Received:
    801
    [Jun 28, 2014]
    ^ we don't judge on here! what you do in the evenings and weekends is up to you :p
    #29
    RS3dan and S. like this.
  31. S.
    Offline

    S. Well-Known Member

    Joined:
    Mar 5, 2009
    Messages:
    1,442
    Likes Received:
    217
    [Jun 30, 2014]
    i guess you ended up with a better sistem so it's still a win!
    i'm tired of milltek on highways but can't afford new sistem now :D
    #30
  32. RedDejavu
    Offline

    RedDejavu Well-Known Member

    Joined:
    Feb 16, 2011
    Messages:
    1,533
    Likes Received:
    179
    [Jun 30, 2014]
    is your resonated or no? If not maybe a resonator could help out with this? I dont really know what to expect from this powervalve system but people say its good. Took me few good months to decide on buying though...
    #31
  33. westtra
    Offline

    westtra New Member

    Joined:
    Mar 12, 2008
    Messages:
    16
    Likes Received:
    1
    [Jul 4, 2014]
    What's the best way to diagnose the fault? As my S3 has been doing it since purchase just under a month ago. Put it down the the winter tyres that previous owner had on the car but still doing it with eagle f1 asymmetric tyres on. Will take it back to the dealer for a check aswell sometime next week.
    #32
  34. MattS3
    Offline

    MattS3 Member

    Joined:
    Jul 27, 2005
    Messages:
    543
    Likes Received:
    21
    [Jul 5, 2014]
    Pretty much wheelspins whenever floored out of a junction or in 2nd and 3rd gear plus torque steer. All the time the esp light flashes whilst the wheels spin.
    #33
  35. westtra
    Offline

    westtra New Member

    Joined:
    Mar 12, 2008
    Messages:
    16
    Likes Received:
    1
    [Jul 5, 2014]
    That's what I am getting. Wheel spin in 2nd under hard acceleration on a nice dry road.
    #34
  36. westtra
    Offline

    westtra New Member

    Joined:
    Mar 12, 2008
    Messages:
    16
    Likes Received:
    1
    [Jul 8, 2014]
    Little update car was plugged into audi diagnostic comp today and its thrown up a fault with the haldex controller so booked in for repair.
    #35
  37. Alex_Wil
    Online

    Alex_Wil Stage 2+

    Joined:
    Feb 17, 2014
    Messages:
    349
    Likes Received:
    161
    [Jul 8, 2014]
    Might be silly question but ill ask anyway. Is the controller different from pump ?
    #36
  38. westtra
    Offline

    westtra New Member

    Joined:
    Mar 12, 2008
    Messages:
    16
    Likes Received:
    1
    [Jul 8, 2014]
    I am assuming so going by a little bit of googling. The haldex controller is the electronic gubbings on the side http://img-2013.tapatalk.com/d/13/02/18/uqugu7ad.jpg that you change out if you upgrade the controller.

    Cars in for 2 days to diagnose fully, order parts and repair.
    #37
    Alex_Wil likes this.
  39. westtra
    Offline

    westtra New Member

    Joined:
    Mar 12, 2008
    Messages:
    16
    Likes Received:
    1
    [Aug 8, 2014]
    Car fixed today. New haldex pump and car now accelerates without traction control cutting in.
    #38
  40. 83jmh83
    Online

    83jmh83 New Member

    Joined:
    Aug 3, 2014
    Messages:
    21
    Likes Received:
    4
    [Aug 9, 2014]
    Wish I hadn't read this, mine appears to have this issue when pulling away from lights. Glad I got it from dealer now not private. Looks like that warranty is going to come in useful!
    #39
    Alex_Wil likes this.

Share This Page