1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Haldex Controller question

Discussion in 'A3/S3 Forum (8L Chassis)' started by RobW, Mar 5, 2010.

  1. RobW
    Offline

    RobW Run Rob Run

    Joined:
    Oct 27, 2009
    Messages:
    30
    Likes Received:
    0
    [Mar 5, 2010]
    Had a VAGCOM check on my 2001 S3 at a local garage. Garage came back and said that, amongst other things, the "Haldex controller is faulty and needs replacing". My heart sank a bit when I was told that this equates to approx £750 inc VAT fitted for a new one.

    So I ran a quick check through some threads on here and found that if I put my car on a ramp, start it, engage 1st gear (or any gear) and accelerate then all 4 wheels should rotate. I did this and all 4 wheels did indeed rotate.

    Am I missing something or is the Haldex controller working completely fine?

    Additionally, I checked my Vagcom report for a "Haldex controller is faulty" code and found this code.
    "65535 - Internal Control Module Memory Error" Is this the Haldex Controller or somehting else? (searches seem to suggest either controller or airbags.

    Any help gratefully received as I dont want to spend £750 if the Haldex is fine.
    #1
  2. Ads

    Ads

    [Oct 2, 2014]

  3. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Mar 5, 2010]
    #2
  4. RobW
    Offline

    RobW Run Rob Run

    Joined:
    Oct 27, 2009
    Messages:
    30
    Likes Received:
    0
    [Mar 5, 2010]
    Welly, The thread you link to is EXACTLY how my car is behaving. However, the answer to the thread is simply "get a new controller". But why? There is no real explanantion to suggest that the haldex controller is faulty (apart from the VAGCOM code, which still doesn't tell me much).
    Anyone any thoughts?
    #3
  5. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Mar 5, 2010]
    #4
  6. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Mar 5, 2010]
    #5
  7. RobW
    Offline

    RobW Run Rob Run

    Joined:
    Oct 27, 2009
    Messages:
    30
    Likes Received:
    0
    [Mar 5, 2010]
    Hmmm, having read the second link, it would seem that the "Haldex controller is faulty". It is interesting that lots of people have had this problem and that it might be caused by a faulty ecu. If indeed the ecu is faulty then I would point back to the manufacturer.
    My soltuion to this is to first ask the local dealer and gauge their thoughts. I imagine this will involve a short conversation about replacing the haldex controller.
    Secondly I will go back to Haldex (the original Swedish company) and see what they say.

    I'll post an update when I have one.

    ps - cheers Welly for the good finds.

    Rob
    #6
  8. Andrew@A.L.D
    Offline

    Andrew@A.L.D May add NOS to 600+bhp?

    Joined:
    Jun 19, 2009
    Messages:
    3,516
    Likes Received:
    361
    [Mar 5, 2010]
    For that price get a performance one and fit yourself or get a garage to fit it for a hours labour ( 1 hour = about £40 )
    #7
  9. RobW
    Offline

    RobW Run Rob Run

    Joined:
    Oct 27, 2009
    Messages:
    30
    Likes Received:
    0
    [Mar 5, 2010]
    Hmmm, how much money should I be looking at if it is the haldex controller then? Either oem or aftermarket one?
    #8
  10. S3KO4
    Offline

    S3KO4 Member

    Joined:
    Aug 15, 2009
    Messages:
    850
    Likes Received:
    2
    [Mar 5, 2010]
    Are you spining in wet/dry? does the car shake under hard accelerations? if the answers were all no, then I would leave it until you spin. in the mean time keep an eye on ebay, you could get them from r32 and v6 4motions mk4 or TTs should be able to pick one up for around 150
    #9
  11. S3KO4
    Offline

    S3KO4 Member

    Joined:
    Aug 15, 2009
    Messages:
    850
    Likes Received:
    2
    [Mar 5, 2010]
    They are all OEM, you can get uprated ones, painted blue or orange, offer 50/50 really good for big power. but extra load on the rear diff.

    Audi: 647
    Ebay Blue/Orange uprated: 650
    Ebay OEM: 100-250
    #10
  12. Andrew@A.L.D
    Offline

    Andrew@A.L.D May add NOS to 600+bhp?

    Joined:
    Jun 19, 2009
    Messages:
    3,516
    Likes Received:
    361
    [Mar 5, 2010]
    Blue ones are for the early S3's and the Orange ones are for the later S3's
    #11
  13. RobW
    Offline

    RobW Run Rob Run

    Joined:
    Oct 27, 2009
    Messages:
    30
    Likes Received:
    0
    [Mar 6, 2010]
    Thanks for the prices. All good stuff.
    In response to S3KO4 - No the car does not spin any wheels (in the wet or dry). No the car does not shake under hard acceleration. I have tried a few hard launches on dry tarmac (it has not rained here in a while) and the car seems fine. I am looking to conduct some hard launches on some wet grass to see what happens then.

    So far, the car seems fine to my untrained eye. I am frustrated that I cant sem to explain the fault code as diagnosed through VAGCOM (Haldex error 65535 internal control module memory error - see link in earlier reply from Welly). I have emailed "vagtech.co.uk" to see if they have any more information on the fault code and to see if they can shed any more light. I am hoping that the error code is an internal software glitch with the ecu and that everything in the real world is actually fine and working as it should.

    Updates as I get them.
    #12
  14. mattyboy199
    Offline

    mattyboy199 Active Member

    Joined:
    Nov 13, 2005
    Messages:
    1,707
    Likes Received:
    11
    [Mar 6, 2010]
    seems like theres nothing wrong with it, wait for the rain turn the esp off & lauch it when turning onto a new road. You should instantly be able to tell if its working or not.
    #13
  15. s3ollie
    Offline

    s3ollie Member

    Joined:
    Jan 2, 2007
    Messages:
    762
    Likes Received:
    7
    [Mar 6, 2010]
    i had the 65535 code on my old s3 and that was related to the air bag module what section did you get that code from on your scan?

    do you have an airbag light on the dash on?
    #14
  16. jojo
    Offline

    jojo S3 Drift King! Staff Member Moderator

    Joined:
    Sep 4, 2003
    Messages:
    26,300
    Likes Received:
    1,693
    [Mar 6, 2010]
    Do the later 8P Haldex controllers fit the 8L, and does it do the same job as a performance haldex controller?
    #15
  17. s3ollie
    Offline

    s3ollie Member

    Joined:
    Jan 2, 2007
    Messages:
    762
    Likes Received:
    7
    [Mar 6, 2010]
    i thought the color was like this
    silver- standard.
    blue- uprated.
    orange- race.
    all for the 8L

    i believe the orange one keeps the rear engaged under braking also to help slow the car down
    #16
  18. s3ollie
    Offline

    s3ollie Member

    Joined:
    Jan 2, 2007
    Messages:
    762
    Likes Received:
    7
  19. RobW
    Offline

    RobW Run Rob Run

    Joined:
    Oct 27, 2009
    Messages:
    30
    Likes Received:
    0
    [Mar 6, 2010]
    Ollie,

    The fault code is in the AWD section. It looks like this on the report

    Address 22: AWD Labels @ 02D-900-554.1B1
    Part No. 02D 900 554 B
    Component: HALDEX LSC ECC

    2 Faults found
    065535 - Internal contorl module error
    00526 - Brake light switch


    Again, as stated, I am awaiting replies from VAGTECH and HALDEX themselves

    Rob
    #18
  20. Andrew@A.L.D
    Offline

    Andrew@A.L.D May add NOS to 600+bhp?

    Joined:
    Jun 19, 2009
    Messages:
    3,516
    Likes Received:
    361
    [Mar 6, 2010]
    No

    Different inside and out
    #19
  21. jojo
    Offline

    jojo S3 Drift King! Staff Member Moderator

    Joined:
    Sep 4, 2003
    Messages:
    26,300
    Likes Received:
    1,693
    [Mar 6, 2010]
    Thanks.
    #20
  22. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Mar 7, 2010]
    Is this a symptom of a FUBAR Haldex controller? Got issues with my S3 at the moment with shaking such as this - and the TC light is always on. I thought that was probably a Long/Lat sensor. I'm just too lazy to go and scan for codes.... LOL.
    #21
  23. nac5000
    Offline

    nac5000 New Member

    Joined:
    Aug 9, 2011
    Messages:
    6
    Likes Received:
    0
    [Sep 22, 2011]
    old post but anyway... I got my S3 on july and finally the other day I scanned it and I got this same 2 errors on haldex, my car haldex works ok no spinning, sometimes the ASR light turns on for some reason and when I turn off the car it turns off...

    greetings ;)
    #22

Share This Page