1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Haldex and Esp Help

Discussion in 'A3/S3 Forum (8L Chassis)' started by ant schof, Jan 30, 2011.

  1. ant schof
    Offline

    ant schof Member

    Joined:
    Jan 1, 2011
    Messages:
    84
    Likes Received:
    2
    Hi I'm a fairly new S3 owner , looking for some advice / help ref esp . I have no light on dash ref esp
    only bought the car a month ago , loving it but ironing out a few issues . Firstly think that the bulb ref esp may have been removed from the dash . Also after having a key programmed by audi recently
    i asked them to do a diagnostic log which came back with G85 fault (steering angle sender) implausible signal sporadic . So my question is if there's a fault with esp does that mean esp system is totally inop and what or how does this affect the haldex system ? if at all ! I can live without esp as long as my haldex is unaffected . Many thanks .
    #1
  2. superkarl
    Offline

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,585
    Likes Received:
    1,092
    As far as I know your Haldex should be ok. Only ESP affected by that. With that fault your ESP light should be on once moving. Does your car have ESP, some older ones don't.
    #2
  3. ant schof
    Offline

    ant schof Member

    Joined:
    Jan 1, 2011
    Messages:
    84
    Likes Received:
    2
    Hi Karl ,
    Thanks for the reply , so are you saying that the haldex controlls the esp not vice versa ? Mines an 02 plate S3 definitley has esp as i have the switch on the dash . However no esp light on the rev counter when switching on ignition . Me thinks the bulb has been removed to mask this fault before i bought the car dirty trick eh ! Many thanks ,
    Ant
    #3
  4. superkarl
    Offline

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,585
    Likes Received:
    1,092
    Can you feel the ESP working at all when pushing it, if you do You'l know it's the light, which I'm not sure on how to change.
    It's a very complicated system, with that fault I would imagine ESP not working, the 4wd should still be ok though. If the 4wd wasn't working, the ESP wouldn't. Lol, confusing i know. My 4wd is faulty, which in turn switches ESP off, only some days though, which makes me want to bang my head against a wall.
    #4
  5. superkarl
    Offline

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,585
    Likes Received:
    1,092
    To elaborate, the ESP depends on the 4wd working. Not the other way around.
    #5
  6. AudiS3Quattro
    Offline

    AudiS3Quattro Member

    Joined:
    Jan 19, 2009
    Messages:
    199
    Likes Received:
    2
    sorry to hijack your thread, but I had a diagnostics from Audi last week and they told me that my haldex control unit was broke, and they told me my 4wd was not working at all resulting in me having a 2wd s3, which i thought was the case as it drove horribly compared to my previous s3. However I do dtill get my ESP light working when the car looses traction, so by what people are saying surley if my haldex 4wd was inoperative then my ESP would be Inoperative too? help me too please!!
    #6
  7. ant schof
    Offline

    ant schof Member

    Joined:
    Jan 1, 2011
    Messages:
    84
    Likes Received:
    2
    I've never felt ESP cut in or any loss of power to point , am pretty sure the haldex is working as the car was great in the snow and i did nearly 600 miles in it at christmas time to get it home , on very icy roads . Thanks Carl , think you've answered my question on ESP , i guess its one for me to sort in the future , i.e open up the dash pod and replace the bulb and look into getting a new clock spring to clear the G85 fault and get my ESP back ! Hope you get your haldex sorted , i have read there can be a problem with a broken earth strap leading to the haldex , maybe worth looking into ! Many thanks all . Will update at a later date :)
    #7
  8. s3_stig
    Offline

    s3_stig Member

    Joined:
    Sep 27, 2009
    Messages:
    376
    Likes Received:
    0
    I have g85 fault is well steering angle sensor light should be on the dash and this shouldn't affect ur 4wd system as mine still works.
    I would say bulb was removed to hide this fault
    #8
  9. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    729
    It can be rectified by getting a 4 wheel alignment done in some cases, if it has had suspension work done
    #9

Share This Page