1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Glow Plug Light flashing

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by mm707, Jun 19, 2012.

  1. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    Hi,

    Driving along doing about 75-80 in cruise control and suddenly the car loses power, the glow plug light flashes. I was able to pull over and switch off. After about a minute I restarted, no problem, the car went the rest of the journey ( about 15 miles ) without any further issues. Seems ok in cruise control also.

    Anyone have any ideas what the problem could have been as I'm a bit concerned about driving too far in the future.

    Many thanks
     
  2. Advert Guest Advertisement


  3. deian3387

    deian3387 Member

    Joined:
    Feb 27, 2011
    Messages:
    86
    Likes Received:
    0
    You need to get it scanned for codes mate.. could be a few different things
     
  4. Macdoon

    Macdoon Well-Known Member
    Team Ibis Gold Supporter Audi A4 S-line owners group

    Joined:
    Jan 20, 2010
    Messages:
    1,941
    Likes Received:
    694
    Have you had the injectors/looms changed on recall.
     
  5. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    Yes - about 10 months ago
     
  6. Macdoon

    Macdoon Well-Known Member
    Team Ibis Gold Supporter Audi A4 S-line owners group

    Joined:
    Jan 20, 2010
    Messages:
    1,941
    Likes Received:
    694
    As above get it scanned, could be a number of things, and may be something really simple to fix.
     
  7. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    Had it scanned and it showed this .....

    000665 - Boost Pressure Regulation: Control Range Not Reached P0299 - 006 - Short to Plus - Intermittent



    The bloke cleared the code and said it may have just been some muck from the egr, anyway he says it's best to get the revs right up and give it a bit of a thrash and see how it goes.
     
  8. daled

    daled New Member

    Joined:
    Feb 25, 2011
    Messages:
    16
    Likes Received:
    0
    Thsi happened to me tyhe day before it went in for service and cambelt etc. Same code shown P0299 and my Indy suggested changing the turbo diverter valve, which he did.

    Two days after collecting the car it happened again tiwce in three days, so I will be getting it in again for him to check diagnostics. I don't know whether it is relevant but I had the injectors and loom replaced FOC under Audi goodwill last year.

    Will advise next course of shortly
     
  9. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    Me too and it's never been 100% since , please let us know how you get on
     
  10. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
  11. matthew999

    matthew999 Member

    Joined:
    Jun 3, 2011
    Messages:
    142
    Likes Received:
    6
    hello mm707,

    this might be completely irrelivent, but i used to use crappy supermarket petrol and this happened to me twice, up a slight hill on motorway doing similar speed. coil light on and limp mode, switch of and on and back to normal. Both times no fault was logged. I have now switched to either bp or shell and it hasnt happened since, 7 months and about 7k.

    Apart from that i also have a hessitation after injector inspection by whetstone audi.

    cheers

    matt
     
  12. deian3387

    deian3387 Member

    Joined:
    Feb 27, 2011
    Messages:
    86
    Likes Received:
    0
    Iv'e had this once on a car at work and it was a faulty MAP sensor (turbo pressure sensor)
    Fitted a new one and the car was sorted
     
  13. murran

    murran Well-Known Member

    Joined:
    Aug 10, 2010
    Messages:
    1,545
    Likes Received:
    39
    what engine code is this?
     
  14. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    it's a BRD engine

    thanks
     
  15. murran

    murran Well-Known Member

    Joined:
    Aug 10, 2010
    Messages:
    1,545
    Likes Received:
    39
    the fault code you posted up is to do with unexpected low boost pressure for a driving condition.
    given the engine code id be removing the egr valve and checking the flap is secure and able to rotate smoothly.
     
  16. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    Hi Murran, thanks for this. It had a new EGR about 18 months ago and has only done about 6k since, would you still check it ?
     
  17. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    Seems a bit sluggish too but only when accelerating at slow speed, when the revs are high it flies along no problem
     
  18. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    New vacuum unit on the inlet manifold has cured this. Fairly easy job and only about £10 for the part. Opened the old one and the diaphragm inside had a hole in it.

    No more hesitation when accelerating either.
     
  19. murran

    murran Well-Known Member

    Joined:
    Aug 10, 2010
    Messages:
    1,545
    Likes Received:
    39
    which vacuum unit?
     
  20. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    Part number S03G129061C , at front of engine, near top.

    vac.jpg
     
  21. dubdemand

    dubdemand VAG Addict

    Joined:
    Aug 13, 2010
    Messages:
    405
    Likes Received:
    8
    Been having the same issues with ours for a couple of years and haven't been able to resolve it yet. Had the injectors and loom done on the recall but still have this issue. I need to get the EGR off for a clean (although it looks like a new part I can't be sure when it was changed). I will also have a look at the vacume unit.

    Let us know how you get on.
     
  22. Advert Guest Advertisement



    to hide this advert.
  23. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    'Let us know how you get on.'

    This part fixed the problems I was having with hesitation and the underboost. To fit it you need to take off the egr and inlet manifold which was a lot easier than I thought it would be. My egr wasn't too bad as it was only 18 months old but I cleaned quite a lot of crud from the inlet manifold flaps etc. If you do it just be aware that there is a bolt holding the manifold on in the air intake which is usually covered in muck and not easy to see though easy to remove when you clean it up.

    vacuum unit is about £10 and if you replace all the gasgets it takes it up to just short of £20
     
  24. dubdemand

    dubdemand VAG Addict

    Joined:
    Aug 13, 2010
    Messages:
    405
    Likes Received:
    8
    Oops sorry mate. That will teach me not to skim read threads! Glad you found a fix and this is something ill mention to my mechanic next time it's in the shop!
     
  25. Audiholic

    Audiholic New Member

    Joined:
    Sep 2, 2012
    Messages:
    18
    Likes Received:
    0
    Just got home after a half hour drive and my glow plug warning light has started flashing. The car seems to running ok with no power loss. Have stopped and started it a few times but the light keeps flashing, even with the engine off/ignition on. I had the car serviced by audi back in november, and it had all the injectors replaced under an audi recall. Having read some of the posts above im now wondering if having that done has caused a problem? Have also checked my brake light bulbs and there all working too. Is the car safe to drive for now or will it do any harm?
     
  26. theo289

    theo289 Member

    Joined:
    Oct 31, 2012
    Messages:
    293
    Likes Received:
    11
    Did this issue get resolved? exactly the same issue on my car
     
  27. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    Yes, vaccum actuator on the inlet manifold. Easy and cheap fix
     
    Frostie333 likes this.
  28. theo289

    theo289 Member

    Joined:
    Oct 31, 2012
    Messages:
    293
    Likes Received:
    11
    Easy to fit?
     
  29. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    You have to remove the inlet manifold but it's just bolts, I did mine and I'm no expert by any means
     
  30. profi_007

    profi_007 New Member

    Joined:
    May 18, 2015
    Messages:
    4
    Likes Received:
    1
    Hello Everyone, I see that this post is older. I have Audi a4 b8 2.0 tdi 143 PS. I am having this issue for a year now. This happends to me when I go 160 + km/h . I replaced the a2c53248883 (03L129086V120, because it gaved me an intake manifold sensor fault + emission control system light ). After replacement the part was faulty and the light dissapeared. But yesterday again the problem appeared when driving 140+.
    PLEASE , I want to resolve this

    |Did this issue get resolved? exactly the same issue on my car|
    |Yes, vaccum actuator on the inlet manifold. Easy and cheap fix|

    How to find those vaccum actuator. Because we don't have Audi official service so no one will know to fix it. Is there a possibility to send me an ebay link or amazon anywhere to see how this look like and to order them. I must replace and fix this the problem is annoying.

    I am writing you from Albania. Thanks in advance
     
  31. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    260
    Likes Received:
    10
    You will probably only get the part from a vw / audi dealer.

    This part fits the b7 so not sure if it is on b8

    Try posting in the b8 section on this forum
     
  32. NOZ

    NOZ Member

    Joined:
    Feb 10, 2013
    Messages:
    208
    Likes Received:
    20
    ive just had this same problem glow plug flashing simple fix ... change the brake light switch under the drivers side foot well 3 screws for acess 1/4 turn twist of old unit swap for new problem fixed £13 from audi and a 15min job max
     
  33. Frostie333

    Frostie333 New Member

    Joined:
    Sep 3, 2016
    Messages:
    9
    Likes Received:
    0
    Hi mm707 I've read a lot about the vacuum actuater but can't find one anywhere, I have a A4 b7 2.0 tdi and have a lot of these symptoms so I have called local Audi dealer and they say the actuator is part of the manifold which comes in at around £670 can you tell me where to get the part from mtia
     

Share This Page