1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Glow plug light flashing with TC light on after a wash???

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by Tiffy, May 7, 2013.

  1. Tiffy
    Offline

    Tiffy Member

    Joined:
    Mar 3, 2013
    Messages:
    356
    Likes Received:
    86
    [May 7, 2013]
    The last few times i have washed my car and started it the Glow plug light will flash along with the Traction Control light being on.This will also revert the car to limp mode.....

    If i turn the car off and back on...after a few times this stops flashing and all is ok.

    Seems to be since i put the suspention in, so was wondering if it is brake related in anyway as the calipers did have to come off...
    #1
  2. Ads

    Ads

    [Sep 21, 2014]

  3. Mike.M
    Online

    Mike.M Well-Known Member

    Joined:
    Oct 11, 2003
    Messages:
    1,721
    Likes Received:
    82
    [May 7, 2013]
    Water must be getting into a connection and creating a short somewhere if it is only after washing it.
    #2
  4. Tiffy
    Offline

    Tiffy Member

    Joined:
    Mar 3, 2013
    Messages:
    356
    Likes Received:
    86
    [May 7, 2013]
    hhhhhhmmmmmmmmm................Could be anywhere....
    #3
  5. Steve220
    Offline

    Steve220 Member

    Joined:
    Jan 20, 2013
    Messages:
    228
    Likes Received:
    13
    [May 7, 2013]
    Tiffy, silly question, did you get a full 4 wheel geometry set up done after you lowered it?
    #4
  6. Tiffy
    Offline

    Tiffy Member

    Joined:
    Mar 3, 2013
    Messages:
    356
    Likes Received:
    86
    [May 7, 2013]
    Steve......Yes mate, just to be safe
    #5
  7. Tiffy
    Offline

    Tiffy Member

    Joined:
    Mar 3, 2013
    Messages:
    356
    Likes Received:
    86
    [Jun 1, 2013]
    Any more help on this guys???.....washed it today and its doing the same again.....
    #6

Share This Page