1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Give me the bad news

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by neal.aldum, Dec 15, 2010.

  1. neal.aldum
    Offline

    neal.aldum New Member

    Joined:
    Oct 8, 2009
    Messages:
    11
    Likes Received:
    0
    My 2.0l 140 bhp diesel A4 Avant with 100.000 miles has started loosing coolant but not externally, I am experiencing a lot of condensation from the exhaust just after cold starting and also it misfires for a second or two on cold starting. someone said to me that before taking the cylinder head off to check for cracks and replace the gasket, there is a known problem with the EGR valve coolers leaking.
    Any advice appreciated.
    #1
  2. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,228
    Likes Received:
    1,220
    Any mayonaise on the oil cap & inside the top?
    #2
  3. L80EWY
    Offline

    L80EWY Member

    Joined:
    Sep 21, 2009
    Messages:
    321
    Likes Received:
    11
    What year did Audi sort this problem out? My 2004 a3 2.0tdi was losing coolant which i thought was going to be cylinder head but i just put some rad weld in an its sorted so must have had a radiator leak. Why dont you try that
    #3
  4. Playsatan
    Offline

    Playsatan New Member

    Joined:
    Feb 18, 2010
    Messages:
    24
    Likes Received:
    0
    Get a garage to do a compression or hydrocarbon test.

    Hope it's good news.
    #4

Share This Page