1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Getting poor MPG

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Nutkin, Jan 30, 2011.

  1. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    I have my DV unfreezed but im still getting poor mpg,

    I put vag com on and got no codes at all, so im thinking it may be a dodgey MAF.

    There are two part numbers on gsf for MAF.

    187VG0130 AIR MASS METER "A4 AWT,AVJ,AMB,BFB,BEX" 37.50

    187VG0131 AIR MASS METER "A4 AWT,AVJ,AMB,BFB,BEX" 58.00

    What is the difference. My engine code is BEX so in theory they are both good to me, but if the 58 quid is genuine bosch ill happily pay the extra.
    Last edited: Jan 30, 2011
    #1
  2. Avant4me
    Offline

    Avant4me The're Graphite not black!!

    Joined:
    Mar 1, 2010
    Messages:
    257
    Likes Received:
    4
    If you have got bag com why don't youdo some logging and see how your MAF performs before replacing it? It will be under engine and the scroll through measuring blocks. I am thinking 002, 012, 015 one will be specified MAF against actual values and another specified against actual boost. Should be an easy way to tell if your MAF is reading correctly.
    #2
  3. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    Can do I'll have a play later I just think in nearly 7 years on 1 maf it could use replacing , but I seem to struggle to get over 28mpg and it's normally 32-33ish , strange that nothing is flagging up :-/ anything else it could be?
    #3
  4. nozdog
    Offline

    nozdog Member

    Joined:
    Jul 11, 2010
    Messages:
    57
    Likes Received:
    0
    I'd be inerested on this one I'm only getting about 25mpg driving normally and get about 30mpg driving like miss daisy.
    #4
  5. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    well im a bit stuck with logging as to where my maf actually and requested is, my mates b5 is on 011 and its obvious on the b6 it just seems to only have maf
    #5
  6. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    Group A: '002


    Group B: '003


    Group C: '031

    RPM Load Inj. On Time Mass Flow RPM Mass Flow Load Ign. Timing Lambda Factor Lambda Factor TIME



    TIME



    TIME

    STAMP /min % ms g/s STAMP /min g/s % °BTDC STAMP

    521.07 760 21.8 2.08 3.39 520.59 840 3.5 2.7 6.8 520.83 1.008 1 521.79 760 23.3 2.6 3.39 521.31 760 3.42 2.7 12 521.55 1 1 522.51 760 23.3 2.6 3.44 522.03 760 3.42 2.7 7.5 522.27 0.984 1 523.23 920 44.4 5.72 9.33 522.75 760 3.42 2.7 13.5 522.99 0.984 1 523.95 1600 36.1 3.12 10.56 523.47 1280 10.78 8.2 5.3 523.71 0.93 1 524.67 1880 72.2 8.32 30.53 524.19 1640 11.44 8.6 26.3 524.43 1.031 1 525.39 2400 103 11.44 53.17 524.91 2040 39.58 75.3 17.3 525.15 0.953 1 526.11 2800 115.8 13.52 72.5 525.63 2360 41.86 32.2 10.5 525.87 0.977 0.977 526.83 4000 121.8 13 92.61 526.35 3200 75.81 98 9.8 526.59 0.93 0.945 527.55 5360 145.1 16.64 141.42 527.07 4480 122.92 100 16.5 527.31 0.961 0.938 528.27 5920 20.3 1.04 0 527.79 5800 153.44 100 18.8 528.03 0.93 0.899 528.99 3320 45.1 5.2 32.06 528.51 5480 4.94 8.2 12 528.75 0.875 0.953 529.71 3480 60.2 5.72 39.42 529.23 3480 48.92 24.3 29.3 529.47 0.945 1 530.43 3520 27.1 2.6 16.61 529.95 3520 22.81 13.7 24 530.19 0.977 1 531.15 3480 24.1 2.6 15.81 530.67 3520 16.56 11.4 39 530.91 0.984 1 531.86 3440 25.6 2.6 17.11 531.39 3480 15.81 11 39 531.63 0.984 1 532.58 3480 30.1 3.64 22.58 532.1 3440 17.06 11.4 38.3 532.34 0.977 1 533.31 3400 32.3 3.12 21.5 532.82 3440 21.67 12.5 33 533.07 1.023 1 534.03 3440 32.3 3.64 21.64 533.55 3440 20.86 12.9 36.8 533.79 1.008 1 534.75 3480 32.3 3.12 22.08 534.27 3440 21.33 12.9 36 534.53 0.984 1 535.47 3520 32.3 3.12 20.58 534.99 3480 21.08 12.9 36 535.23 0.984 1 536.19 3560 47.4 4.68 33.72 535.71 3520 24.06 14.5 35.3 535.95 0.984 1 536.91 3720 60.9 6.24 44.92 536.43 3600 38.97 19.6 31.5 536.67 1.008 1 537.61 3920 56.4 5.72 41.61 537.15 3800 45.19 21.6 30.8 537.37 1.008 1 538.35 4040 42.1 4.16 31.22 537.87 3960 40.42 19.2 18.8 538.11 0.969 1 539.07 4120 34.6 3.12 25 538.59 4080 31.78 16.9 33 538.83 0.969 1 539.79 4200 36.1 3.64 29.69 539.31 4160 25.14 14.1 36.8 539.55 1.008 1 540.53 3760 14.3 1.56 8.11 540.03 4240 23.61 13.3 19.5 540.27 0.883 1 541.25 3000 50.4 5.72 32.31 540.75 3240 11.5 9.8 28.5 540.99 1.031 1 541.97 3120 48.9 5.2 29.25 541.49 3040 31.28 16.9 31.5 541.73 1.016 1 542.69 3200 63.2 6.76 40.08 542.21 3120 30.03 16.5 32.3 542.45 0.992 1 543.41 3320 65.4 6.76 40.94 542.93 3240 41.11 20.8 30.8 543.17 1.008 1 544.14 3400 62.4 6.24 39.42 543.65 3320 42 21.6 21 543.9 1.008 1 544.86 3440 47.4 4.68 29.78 544.38 3400 33.69 17.3 21 544.62 1 1 545.58 3480 45.1 4.68 29.56 545.1 3440 29.47 16.1 25.5 545.34 0.984 1 546.3 3480 45.9 4.68 29.69 545.82 3480 28.61 15.7 32.3 546.06 0.992 1 547.02 3520 45.9 4.68 30.14 546.54 3520 29.89 16.1 33 546.78 0.992 1 547.74 3560 46.6 4.68 31.39 547.26 3520 31.39 16.5 32.3 547.5 1.008 1 548.46 3560 46.6 4.68 30.92 547.98 3560 31.5 16.5 32.3 548.22 1.008 1 549.18 3600 47.4 4.68 32.17 548.7 3600 30.69 16.5 32.3 548.94 0.992 1 549.9 3640 53.4 5.72 37.94 549.42 3600 32.33 16.5 32.3 549.66 1 1 550.62 3800 122.6 13.52 104.64 550.14 3680 56.61 30.2 29.3 550.38 0.938 1 551.34 4000 139.1 15.6 105.75 550.86 3840 98.97 99.6 15.8 551.1 0.922 0.945 552.06 4240 140.6 15.6 112.53 551.58 4080 108.83 100 12 551.82 0.938 0.938 552.78 4480 142.1 15.6 122.36 552.3 4320 115.14 99.6 14.3 552.54 0.93 0.93 553.5 4720 140.6 16.64 125.61 553.02 4560 122.44 100 15.8 553.26 0.93 0.914 554.22 4920 142.9 17.68 134.08 553.74 4800 128.22 100 15.8 553.98 0.852 0.86 554.94 5160 147.4 18.2 143.39 554.46 5000 136.81 100 15.8 554.7 0.828 0.828 555.66 5360 146.6 18.2 148.53 555.18 5200 145.33 100 16.5 555.42 0.813 0.813 556.38 5560 144.4 18.2 154.19 555.9 5440 152.22 100 18 556.14 0.797 0.797 557.1 5760 145.9 18.72 160.25 556.62 5600 158.89 99.6 16.5 556.86 0.782 0.782 557.82 5920 141.4 18.72 158.22 557.34 5800 158.72 100 18.8 557.58 0.774 0.766 558.54 6080 138.3 18.2 162.36 558.06 5960 159.25 99.6 19.5 558.3 0.766 0.758 559.26 6240 135.3 18.2 162.08 558.78 6120 161.03 100 21 559.02 0.758 0.75
    #6
  7. Avant4me
    Offline

    Avant4me The're Graphite not black!!

    Joined:
    Mar 1, 2010
    Messages:
    257
    Likes Received:
    4
    Mate, copy them into excell first as it will format based on comma separated values.

    Log 002 as this will give you the MAF values. You are looking at around 170g/s for a standard 190bhp engine closer to 200 if it is mapped.
    Also log 115 as this will tell you how far off specified boost your car is, the engine should meet boost really quickly over 2000rpm.
    118 and 119 will tell you how hard the turbo is having to work to meet boost. Over 80% on boost duty cycle is bad i was told. THis is basically how far closed the turbo actuator is and refers to how much of the exhaust gasses are passing over the turbine. If your above 80% then your turbo is working really hard to meet boost pressure, and would suggest that either you have a leak or your MAF is lying.

    Also have a look at 020 as this is the timing retard on each cylinder. If the air/fuel ratio is off, the engine will detect detonation as a 'knock' and will retard timing accordingly. ranges from 1-9 with above 9 generating a fault code. Even a highly mapped car should not go above 6 if it has been done well.

    Matt
    #7
  8. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    Just realised that was terribly formatted.

    its hitting about 160g/s which if i divide by 0.8 gives over 190bhp Ill give those other blocks a try on the way home.

    I have this code too

    1 Fault Found:
    16825 - EVAP Emission Control Sys: Incorrect Flow
    P0441 - 002 - Lower Limit Exceeded
    #8
  9. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    [​IMG][/URL]%20%20Uploaded%20with%20ImageShack.us[/IMG][​IMG]

    shows 0.6 bar of boost and not too much effort from what i can tell.
    #9
  10. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    Where abouts is the evap chamber located?
    #10
  11. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    Can anyone shed any more light on this? I cleared the codes monday and it hasn't come back. The fuel economy is shockingly low. 14-20mpg on my work commute. can just scrape 24 if im careful.

    No fault codes, and I'm at a loss.

    the only thing i have noticed is on the mpg avg gauge when i first fire up it will go 15.1 15.6 15.9 then back to 15.0 and cycle through them a bit.
    #11
  12. nozdog
    Offline

    nozdog Member

    Joined:
    Jul 11, 2010
    Messages:
    57
    Likes Received:
    0
    Hi I did 202 miles to 37.00 litres worked to be 24.53 miles per gallon if this is any good to what my car is using. I'm going to get my car checked too because I think I should be getting better MPG. I'm only using shell fuel aswell. Nutkin were abouts are you based? Have you talked to Bill at Badger5 I would be taking my car there for a health check but he is to far away.
    Last edited: Feb 2, 2011
    #12
  13. vinesh
    Offline

    vinesh Member

    Joined:
    Nov 6, 2005
    Messages:
    214
    Likes Received:
    0
    Have you checked for any boost leaks?

    I had a split i/c hose and this dropped my avg mpg to 14mpg!!!
    #13
  14. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    can someone give me a good way to check for leaks?

    I cant hear a leak, but surely if there was one the boost wouldnt be hitting 0.6 bar or giving me 160g/s

    I have checked all the sensors etc and nothing, lambda is fine, coolent is fine, ait intake temp is ok and maf is ok.
    #14
  15. vinesh
    Offline

    vinesh Member

    Joined:
    Nov 6, 2005
    Messages:
    214
    Likes Received:
    0
    Visual inspection of all boost pipes and check for oil spray near boost/turbo pipes.
    #15
  16. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    all the vac hoses were replaced last june, so they all look fresh and new too me. not a hole in sight. I need to get the cover off for boost hoses but i think i made a discovery.

    the poor mpg only happens for the first bit of the journey, once the car gets to a certain temp it goes into a different mode and the mpg goes up.

    So when first started it just WILL NOT go above 15.9mpg and cycles up and then back to 15 even if im freerunning to a junction it will go down.

    Then once it hits i dunno about60 degrees or something it will suddenly pop in the 16+ mpg and work its way up normally.

    If i reset the mpg avg while driving along ill record normal 32-34mpg. its just this startup bit that is drinking a gallon every time i cold start.
    #16
  17. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    can anyone shed any light on this for me?

    was doing 8mpg in traffic this morning and it was only about 5 mins of slow moving.
    #17
  18. j033y
    Offline

    j033y Member

    Joined:
    Jan 29, 2008
    Messages:
    198
    Likes Received:
    0
    Have you worked out your actual MPG. not using the DIS. I think maybe something has gone wrong there.

    I average around 28.5 actual MPG (per my sig below!)
    #18
  19. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7

    200 miles to 53 litres.

    17.2 mpg and this is driving at 65 on a dual carridgeway to work each morning for 8 miles.
    #19
  20. vinesh
    Offline

    vinesh Member

    Joined:
    Nov 6, 2005
    Messages:
    214
    Likes Received:
    0
    Defo something wrong.

    My 2.5tdi returns around 350 to 400 miles (Full tank)
    #20
  21. j033y
    Offline

    j033y Member

    Joined:
    Jan 29, 2008
    Messages:
    198
    Likes Received:
    0
    Holy ****, and S4 would be better on fuel!

    If you have tried all the obvious places then it may need looking at more seriously. is it remapped? maybe get it looked at from ECU point of view, it must be pouring the fuel in.

    Hole in tank? I've had it on a few cars now, granted much much older!
    #21
  22. Avant4me
    Offline

    Avant4me The're Graphite not black!!

    Joined:
    Mar 1, 2010
    Messages:
    257
    Likes Received:
    4
    Mate, try and log 020 against 115. ONly ever do two logs at a time as any more brings the sample rate down too much.
    020 will show if the ignition timing is being pulled back by the ecu to compensate for the mixture being off.
    Logging against 115 will show us what the engine is doing boost wise at the same time. THis will rule out a boost leak once and for all.

    Would be worth having a look at 028 from start up until it goes into warm running mode, i will bet the knock sensor is going crazy.

    Just a thought have you noticed a noise from the front of the engine on startup, some describe it as sounding like a vacuum? It could be the secondary air pump which is prone to failure.

    WHat part of the country are you in?
    #22
  23. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    032 logs nothing over a correction of -0.9% most the time with -1.1% max deviation so i would suggest there is no vac leak.

    020 just gave 4 0.0CF blocks and didnt change

    120 showed the boost following requested fine up 1640mbar max, the requested and actual never being seperated more than 40mbar



    So annoying the car keeps saying its fine, but it clearly has something wrong with it!

    if you'd like em to email you the logs i can.
    #23
  24. Avant4me
    Offline

    Avant4me The're Graphite not black!!

    Joined:
    Mar 1, 2010
    Messages:
    257
    Likes Received:
    4
    Why not, Matthew.roberts1@blueyonder.co.uk.

    Have a look at your secondary air pump. On the transverse engine it is at the front towards the right, so if it was kept relative, then it will be on the passenger side towards the back???

    Looks like a plastic turbo charger housing, Its connected to an electric motor which pushes air into the engine under cold start conditions. The rivets go for a pass time resulting in a vacuum cleaner noise coming from it. Its an easy fix just involving an hour of your time, a drill and 6 fine nuts and bolts.
    #24
  25. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    as said

    boost is fine
    vac is fine
    timings fine

    im in coventry
    #25
  26. Avant4me
    Offline

    Avant4me The're Graphite not black!!

    Joined:
    Mar 1, 2010
    Messages:
    257
    Likes Received:
    4
    Nutkin, give me a call on 07971837724
    #26
  27. Pabs
    Offline

    Pabs Member

    Joined:
    Jun 2, 2010
    Messages:
    618
    Likes Received:
    40
    Might be a daft question but are you using the same petrol station, i used a random station 2 days ago, for £25 i got 80 miles which is shocking, normally a £60 fill up gives 350, and i have a mapped 1.8T 190
    #27
  28. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    yup she is always filled with VPower from the Shell at the end of my road.
    #28
  29. xs2man
    Offline

    xs2man Member

    Joined:
    Jun 4, 2008
    Messages:
    791
    Likes Received:
    15
    WOW. I get 280-300 miles for 55l in my S4. That doesn't sound right at all to me.
    #29
  30. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    Matt you are an absolute legend!!!
    #30
  31. MDA
    Offline

    MDA sploorer

    Joined:
    Dec 6, 2009
    Messages:
    87
    Likes Received:
    0
    whats happened !!!
    #31
  32. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    #32
  33. Avant4me
    Offline

    Avant4me The're Graphite not black!!

    Joined:
    Mar 1, 2010
    Messages:
    257
    Likes Received:
    4
    Dear god that test looks compliated. Hope you get it sorted mate, hope i helped
    #33
  34. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    tried the test, everything has passed! i think you may have got confused on the logs mate as they were percentage change not voltage. so its normal ish.

    I litrally just had the brakes done etc and thats made me skint, I have an airbag warning on too which is pretty annoying. if i can clear the airbag warning i think ill just part exchange the car.
    #34
  35. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    Have also changed coolent temp sensor :(


    not at all sure what else to try garage dont seem to know either.
    #35
  36. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    sooo, my cat thinks its -10 degrees when i started the car.

    hmmmmmmm
    #36
  37. j033y
    Offline

    j033y Member

    Joined:
    Jan 29, 2008
    Messages:
    198
    Likes Received:
    0
    Bingo!

    Therefore dumping more fuel in as its cold! Maybe??
    #37
  38. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    badger bill from badger 5 had a look at my logs but couldnt find anything wrong :( I think it may be part exchange time.
    #38
  39. Nutkin
    Offline

    Nutkin Member

    Joined:
    Aug 9, 2009
    Messages:
    831
    Likes Received:
    7
    #39
  40. MDA
    Offline

    MDA sploorer

    Joined:
    Dec 6, 2009
    Messages:
    87
    Likes Received:
    0
    Would it be worth taking it to an MOT station
    To see if it's running rich .?
    Just a thought
    I love to see you get to the bottom of it
    Matt
    #40

Share This Page