1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fuel pump and filter

Discussion in 'A3/S3 Forum (8L Chassis)' started by Jay, Apr 8, 2009.

  1. Jay
    Offline

    Jay Member

    Joined:
    Aug 27, 2006
    Messages:
    322
    Likes Received:
    0
    [Apr 8, 2009]
    Trying to get to the bottom of a surging/hesitation issue thats been annoying me since having the car remapped. Vagcom seems to be logging missfires now. I've had the Maf replaced after the MAF. The plugs, coil packs, temp sender and thermostat were replaced before the map. Car seems to be running hot when checking on the aircon (99 degrees)

    After reading this thread i'm beginning to think that my fuel pump maybe shot.
    http://www.audi-sport.net/vb/showthread.php?p=569369#post569369

    Where are the pump and filter located. Theres something under the rear passenger seat, is this the filter? Would it be cheaper to have this replaced first?

    Finally what sort of costs am i looking at to have the pump replaced.

    thanks
    #1
  2. Ads

    Ads

    [Sep 18, 2014]

  3. fran-s3
    Offline

    fran-s3 Active Member VCDS Map User

    Joined:
    Jan 29, 2008
    Messages:
    1,103
    Likes Received:
    1
    [Apr 8, 2009]
    Had the same issue with mine mate when mine was remapped. Again spent a wonga on Coil Packs, MAF, Sparks and DV testing and it was none! No errors in VAG-COM either...

    Yep thats a sign, also when you pop the bonnet after a run is it unusually roasting to? I could feel the heat on my face just looking at it!!!! Fuel pump is located under the passenger seat... Fuel filter is found under the car on the passenger side behind the door... Is if misfiring on all 4 cylinders higher up the rev range? Mine was on 3....

    Paid about about £40 for the pump (think it's in 2 sections I didn't need both) and about £60 to fit it as I've never done on before....

    Also as crazy as it sounds look at your exhaust tips... Mine have corroded in places where the fuels not been mixed right which is another symptom.
    #2
  4. Jay
    Offline

    Jay Member

    Joined:
    Aug 27, 2006
    Messages:
    322
    Likes Received:
    0
    [Apr 8, 2009]
    Had misfires on all 4. Going to check at some point if any more have come up after clearing them.

    Where did you end up getting your fuel pump from and did you get your filter changed at the same time.

    thanks
    #3
  5. fran-s3
    Offline

    fran-s3 Active Member VCDS Map User

    Joined:
    Jan 29, 2008
    Messages:
    1,103
    Likes Received:
    1
    [Apr 8, 2009]
    Oh right well it sounds like a strong possiblity to me then. Mine didn't even show as errors on VAG-COM for some reason.

    It was only by doing a live power run and my mate watching the laptop that they came up on the missfire column! Was only when it wsa about to make maximum boost.

    APS sorted it for me as they diagnosed it and sorted it all out. Got it from audi direct mate. No I tried a new fuel filter myself before taking it to APS, obv didn't make any difference. Again pop out and look at your exhaust tips to see if theres any signs of corrusion.
    #4

Share This Page