1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fuel gauge not working

Discussion in 'A3/S3 Forum (8L Chassis)' started by jeffers999, Aug 7, 2007.

  1. jeffers999
    Offline

    jeffers999 got boost

    Joined:
    May 5, 2007
    Messages:
    390
    Likes Received:
    0
    Hello peps i have a 1999 s3 but since i bought it the fuel gauge never worked if i fill it up it shows whatever it wants some times full then it will jump to empty iv even run out once it was showing half but obviously it was empty any ideas would be great cheers ?? Jeff...
    #1
  2. ForestHills
    Offline

    ForestHills New Member

    Joined:
    Jun 1, 2007
    Messages:
    15
    Likes Received:
    0
    Try a search for "faulty fuel gauge" and you will get various answers there.

    I think it can be a few things - mine doesnt go below the 1/4 mark but unfortunatly the fuel does:keule:

    I think someone that has one of the diagnostic machines that can read fault codes etc is the cheapest and quickest way to identify it. Im going to try the local VAG Specialist if not then Audi.

    Ive read Senders in the tank can be faulty or even the Dash Unit (very expensive) so its just a case of tracking it down.
    #2
  3. jeffers999
    Offline

    jeffers999 got boost

    Joined:
    May 5, 2007
    Messages:
    390
    Likes Received:
    0
    hmm ill have to get it scanned one day in the week i think. what ever it is its gonna cost me by the sounds of it cheers mate..
    #3
  4. mikel_86
    Offline

    mikel_86 New Member

    Joined:
    Jul 23, 2007
    Messages:
    26
    Likes Received:
    0
    My old a4 used to do this but then randomly one day it started working again. I guess it must have had some dirt or something buggering the mechanism in the tank. Not sure how it works exactly but this is the only explanation I can think of.
    #4
  5. fazzybear
    Offline

    fazzybear Member

    Joined:
    May 1, 2007
    Messages:
    127
    Likes Received:
    0
    Had this on my corrado 20v and it was a break in the live to the float which is located on the pump in the fuel tank,

    easy fix but petrol everywhere, not sure how easy this will be on the S3
    #5
  6. shuzzy
    Offline

    shuzzy New Member

    Joined:
    Dec 2, 2006
    Messages:
    15
    Likes Received:
    0
    Same problem with mine, needle doesn't move for ages then fuel light comes on with needle just below 1/2. carried on driving once and car ran out of fuel with needle just above 1/4. Anyway changed pump/assembly unit in the tank and hey presto - no difference still same fault. It is the gauge (stepper motor) itself that is faulty, however you cant just change the speedo cluster as the immobiliser chip is contained within it and is unique to your car. Nothing is ever straight forward !
    #6

Share This Page