1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Front suspension or engine "feels loose"

g60luke Mar 25, 2013

  1. g60luke

    g60luke New Member

    5
    0
    1
    Hi,

    I have a 2007 S3, and when I test drove could feel some play in the engine or front suspension.

    Thought it was probably the front control arm bushes as my earlier MK5 Golf felt similar.
    Upgraded to Poly Urethane bushes, and although feels tighter there is still play somewhere?

    It is noticeable when you go over a cobbled road or a sudden bump to the front end suspension.
    It is really faint and I am probably just being anal, but it bugs me!

    It just feels like play in the front end somewhere, only minimal but enough to notice

    Anyone had similar experience?

    Cheers
    Luke
     
  2. gen.heinz guderian

    gen.heinz guderian Well-Known Member

    1,346
    125
    63
    How many miles has it done? Could be track rod ends.
     
  3. g60luke

    g60luke New Member

    5
    0
    1
    Hi,

    67k miles

    Cheers
    Luke
     
  4. MrLapou

    MrLapou Well-Known Member

    1,233
    121
    63
    What condition are the front shocks in?
     
  5. g60luke

    g60luke New Member

    5
    0
    1
    Dont know, thinking of possibly stripping off front strut to see if top mount or shock is damaged?

    Would make sense if the shock is a little lazy, or if top mount has play in it I guess?
     
  6. S3Alex

    S3Alex Rarely neutral Team Ibis TFSI Owners Group Gold Supporter Audi S3 DSG

    10,359
    4,401
    113
    If the engine is moving on it's mounts,there could be significant wear in the mounts,and it may be worth having them looked at......certainly if the car has been modified at all,these are worth uprating in any case.
    .
    Otherwise,on any car of this age,parts like the suspension bushes will wear,and when i had mine replaced,the original ones did look a bit sorry.
     

Share This Page