1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Front fogs coming on when lights are switched on.

Discussion in 'A3/S3 Forum (8L Chassis)' started by Maz, May 27, 2010.

  1. Maz
    Offline

    Maz Moon is made of green cheese

    Joined:
    Jan 3, 2005
    Messages:
    1,015
    Likes Received:
    9
    Hi all, I fixed my brake light switch over the weekend (mini guide due to be uploaded) and whilst it was a straightforward job replacing I think I may have caused a new issue. My front fogs now come on everytime I switch the lights on.

    I plan to remove the the lower dash trim again this wknd to have a looksey.

    Any ideas how to fix or what I might have done to cause this?

    Thanks.
    #1
  2. Matt82
    Offline

    Matt82 Active Member

    Joined:
    Sep 7, 2009
    Messages:
    2,366
    Likes Received:
    2
    sounds like youre driving a peugeot or subaru. i heard the fogs on those cars are hardwired to come as the engine starts
    #2
  3. Westy
    Offline

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,295
    Likes Received:
    969
    Oh no Maz you might as well buy yourself a clio if you're going to drive round with the fogs on :whip:

    I've no idea how changing the brake light swithc would have caused that problem. Surely the fogs are part of a completely different relay!
    #3
  4. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    I'd say coincidence.....
    #4
  5. Maz
    Offline

    Maz Moon is made of green cheese

    Joined:
    Jan 3, 2005
    Messages:
    1,015
    Likes Received:
    9
    Lol, thats exactly why I must rectify this issue immediatley.

    I'm thinking I may have disturbed something when I unplugged the connections for the light switch behind the lower dash panel.
    #5
  6. Westy
    Offline

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,295
    Likes Received:
    969
    Yeah sounds like it. Just get it all apart and reconnect and see if the issue goes. Probably just a loose connection somewhere. I have a loose connection to the lights that light the headlights switch up.
    #6
  7. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,568
    Likes Received:
    267
    the switch can go dodgy, might be that, we had it on the TQS, had to dismantle the switch and reset the cam thingy inside
    #7
  8. Maz
    Offline

    Maz Moon is made of green cheese

    Joined:
    Jan 3, 2005
    Messages:
    1,015
    Likes Received:
    9
    Thanks, I'll give that a go.
    #8
  9. gareth_oau
    Offline

    gareth_oau Member

    Joined:
    Dec 3, 2008
    Messages:
    218
    Likes Received:
    0
    My fogs were always on with the headlights and the mechanic said it was a faulty headlight switch. As its illegal here to drive with fogs on, unless its foggy (which here it virtually never is), I just removed the fuse
    #9

Share This Page