1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forge Twintake

GavS3 Mar 28, 2012

  1. GavS3

    GavS3 New Member

    23
    1
    1
    Hey guys

    Does anyone have the Forge Twintake on their car which has a DSG gearbox?

    The reason i ask is because after fitting the kit to my car (2.0TFSI) i have got an engine light and ive been told it might have to do with it being DSG?

    Ive since got a scan and the error code says its the MAF sensor.

    Anyone care to shed some light to this issue?
     
  2. Paullie

    Paullie Banana Menace! VCDS Map User

    2,076
    287
    83
    Hi Gav, I've had the Forge Twintake fitted to my DSG S3 since last July and have had no issues whatever, *touch wood*. I've heard it said (over on Vortex.com) that it can cause 'turbulence leading to skewed MAF readings' because of the location of the MAF sensor with the TT fitted, but in all honesty haven't heard of anyone on here having probs with it. You could try cleaning your MAF sensor and see if this makes any difference. :wub: xx
     
  3. mjr901

    mjr901 Parts Manager - (Main Dealer) Gold Supporter Audi S3 Audi Main Dealer

    3,565
    1,015
    113
    Ive heard about the turbulent air to the MAF too. No problems with my P-FLO :)
     
  4. GavS3

    GavS3 New Member

    23
    1
    1
    Thanks for the quick replies!

    After doing further reading I think I may have found the issue. Ive been told the twintake kit in the USA has the MAF sensor mount reversed. I bought the kit from the US which is different to the rest of the world (UK, Europe, Australia).

    Would someone with the forge twintake take a photo of the maf sensor. It would be interesting to see which way the maf is facing!
     
  5. warren_S5

    warren_S5 Moderator Staff Member Moderator VCDS Map User

    7,210
    2,481
    113
    If the MAF sensor is reversed it will misread quite badly I'd have thought.

    I haven't seen an aftermarket kit with a mesh screen ahead of the MAF to date. Whilst I can understand the concerns of flow restriction I'm sure it's supposed to assist with the process of creating good laminar airflow over the MAF sensor to ensure accurate readings are maintained. Whilst I'm not expert in the development of CAI's(!), it seems an odd omission, but then what do I know.

    Can't see why US one would be different, but then again, what do I know.

    Can they supply you with single bespoke pipe for UK car? Forge stuff is top notch so I can't see there being any issues with the kit as too many people own them and love them.
     
  6. GavS3

    GavS3 New Member

    23
    1
    1
    Thanks Warren

    Ive sent for an email in regards to the issue, just waiting on a reply. I know they are top notch and nodoubt they will assist, i just assumed it would be a pretty easy plug n play :(
     
  7. Paullie

    Paullie Banana Menace! VCDS Map User

    2,076
    287
    83
    My other half has stolen my S3 this morning Gav and left me with the mud plugger as I've to take the pup to the vet this avo for his booster shot, but if no one manages to get you a pic soon, I'll get you one later on. :wub: xx
     
  8. GavS3

    GavS3 New Member

    23
    1
    1
    lol not to worry paulie, whenever you can that would be great.

    thanks alot for your help so far guys, hopefully i can solve this problem and start enjoying my ride :)
     
  9. Boydie

    Boydie Boycie VCDS Map User

    3,165
    298
    83
    Change the MAF - eliminate it as a fault.
     
  10. S.

    S. Well-Known Member Team Ibis TFSI Owners Group quattro Audi S3 Manual

    1,894
    473
    83
    +1.
     
  11. GavS3

    GavS3 New Member

    23
    1
    1
    Bit of an update

    The orientation of the MAF sensor is vitally important. It must positioned in a particular orientation. The issue is different MAF sensors used in different international markets. The MAF sensors in the UK, most of Asia, Australia, and a few other countries have flanges that are backwards from US market cars. The sensor would be positioned within the piping in the correct orientation, but the one-way flange that bolts to the piping in a particular position would be backwards

    So at least i have found the source of the problem, now just to rectify it :/
     
  12. rodaz

    rodaz New Member

    13
    8
    1
    Last edited: Apr 2, 2012
  13. Blackie

    Blackie Active Member

    697
    67
    28
    I fitted mine last week & had no problems

    Did you start it up before plugging the MAF in ?
     
  14. rodaz

    rodaz New Member

    13
    8
    1
    How do you mean this?
     
  15. GavS3

    GavS3 New Member

    23
    1
    1

Share This Page