1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Flashing glowplug light, loss of power, eps light on limp mode etc...

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by Av4nt, Aug 4, 2012.

  1. Av4nt
    Offline

    Av4nt Well-Known Member

    Joined:
    May 27, 2012
    Messages:
    1,114
    Likes Received:
    235
    [Aug 4, 2012]
    Apologies if this is a repeat post which im sure this issue maybe..but im on a mobile and cant really do thorough searches on forums on a mobile phone at 3:30 am on the side of a dual carriageway!

    cutting most of this short ive been told by an AA tow driver that it maybe a brake light switch.
    Can a simple switch really cause all this ****?? :

    Loss of power
    Glow plug flashing light
    Limp Mode/no acceleration
    ESP light
    brake lights permanently on ??

    I thought my turbo had gone initially...but nothing is smoking out the back.
    , none of the tail lights or healights are dimming so i dont think it would be the alternator. I will obv have it run through a diagnostics later on this morning by AA first off to find out what it is bringing up code wise if anything... but ffs if it turns out to be brake light switch why can't audi spend more of their money on making sure simple things dont break and cause electrical chaos! :banghead:

    Im hoping it is that and not some failing ECU problem etc :(

    I love audi but i also hate them.
    #1
  2. Ads

    Ads

    [Oct 22, 2014]

  3. Av4nt
    Offline

    Av4nt Well-Known Member

    Joined:
    May 27, 2012
    Messages:
    1,114
    Likes Received:
    235
    [Aug 4, 2012]
    Well it was towed to a garage and the core read came up with about 9 codes lol, all sorts of rubbish. Brake light switch being one and it looks like may possibly be an ECU error or just electrical short somewhere. boo :(
    #2
  4. PetrolDave
    Offline

    PetrolDave Well-Known Member

    Joined:
    Nov 25, 2003
    Messages:
    1,559
    Likes Received:
    82
    [Aug 4, 2012]
    Yup, check the brake switch and both brake light bulbs.
    #3
  5. Av4nt
    Offline

    Av4nt Well-Known Member

    Joined:
    May 27, 2012
    Messages:
    1,114
    Likes Received:
    235
    [Aug 9, 2012]
    just an update for any future readers. Garage called this morning to say that the electrics had shorted out due to a wiring harness being melted. Melted by.. i think he said the turbo pipe of somesort and had shorted out against the pipe after melting through the wire housing. Handy...

    I am quite **** at names for most things as a learner on car parts under the bonnet lol so ill post a pic up later if thats indeed all it was to show the offending pipe!
    #4

Share This Page