1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fk coilover knocking

briggsy Oct 27, 2010

  1. briggsy

    briggsy New Member

    7
    0
    1
    Hi guys I recently fitted some fk coilovers and when ever I go over the tiniest of bumps there's a loud knocking comes from the front?? I've checked that all nuts and bolts etc are tight which they are so I'm a bit stumped!! Anyone got any ideas what it might be?? Thanks
     
  2. FUNKYCLIFF

    FUNKYCLIFF Member

    185
    0
    16
    Could it be your suspension bushes???. If they have not been replaced before
     
  3. CMD

    CMD Pointing Forward's!!!!!!!!!

    3,015
    17
    38
    I had the same problem with the AP coilover setup. It sent me crazy all the bushes and conntrol arm's were fine. I could not wait to take them off after only 2 month's. I now running eibach suspension with no problem's.
     
  4. ultramodz

    ultramodz 06 A4 2.0T FSi S-Line SE

    515
    36
    16
    I've had no problems with my FK Konigsports - they've been on the car for around 2 years now.
     
  5. jaceyq

    jaceyq Member

    203
    7
    18
    if is it a sort of rubbery noise then that could be where the mechanics left the old rubber or shock protector on which is rubbing with the new one evertime you hit a bump... too cut a long story sort just jack up and put enough grease between and it should stop the problem. if it is ...
     
  6. ashley1

    ashley1 Member

    55
    4
    6
    Hey guys... I fitted FK AK Street coilovers a couple of months ago and have the same problem. Did you ever sort them out briggsy???
     
  7. Triple.O.G

    Triple.O.G Active Member

    1,113
    5
    38
    I had FK AK streets in 2010 and had the same problem. to put it simply its because there sh*t, save for some slightly better ones and get rid or they'll drive you mad.
     
  8. lawsy

    lawsy New Member

    7
    0
    1
    think thats what I'm going to do - 4 months of knocking on the FK Stree coilies and replacing on the multiling too..

    bin the coilies and get some proper suspension
     
  9. SinghB7

    SinghB7 Active Member

    522
    68
    28
    Must be fiitted incorrectly, I had cheap JOMs and fitted them myself, they were perfect.

    Sounds like you had a loose top mount.
     
  10. ukphillad

    ukphillad Member

    122
    13
    18
    +1 :)
     

Share This Page