1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

First beam light flickering

Defratos Dec 8, 2006

  1. Defratos

    Defratos You’re Dethpicable!!

    2,232
    0
    36
    Hey guys, just noticed this today, my driver's side first beam light is flicking on and off intermittently, got any ideas what it might be? Fuse maybe? but why flicker? why not switch off completely?
     
  2. jonS3

    jonS3 Member

    719
    0
    16
    mine did this, and it turned out to be a melted ballast connect/bulb hold. Have a look in the headlight from the front and see theres any smoke in there, mine smelt smoky too
     
  3. Defratos

    Defratos You’re Dethpicable!!

    2,232
    0
    36
    lol smoky? are you serious? so the ballast connect/bulb hold is that where the first beam bulb fits into it's socket? and why would this happen? I've changed mine to slightly whiter ones but they've been fine for months?
     
  4. buckas

    buckas Member

    749
    2
    18
    water in the connection?
     
  5. Defratos

    Defratos You’re Dethpicable!!

    2,232
    0
    36
    how would I go about sorting out either of the above scenarios?
     
  6. jonS3

    jonS3 Member

    719
    0
    16
    yeh seriously, i changed the side lights over a week or so before, and i think i must have upset it, as it was quite awkward to get them to fit. if it doesnt look smoky in there, or smell, then my guess is that it should be ok

    what i would do, would be take the whole headlight out, and check it over
     

Share This Page