1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Faulty fuel gauge and knackered speedo..??

Discussion in 'A3/S3 Forum (8L Chassis)' started by SilverSaloon, Apr 9, 2009.

  1. SilverSaloon
    Offline

    SilverSaloon Member

    Joined:
    Apr 4, 2009
    Messages:
    50
    Likes Received:
    0
    [Apr 9, 2009]
    Hi all, Got a few problems with my A3 1.8T, Hope you can help. The fuel gauge works fine but fluctuates with the movement of the fuel, For instance going round a roundabout will read empty and hard braking will read full tank etc..

    Any ideas on whats wrong there? It does work it just gets on my nerves as it beeps everytime i go round a corner saying no fuel..

    2nd problem is the speedo, It never worked when i bought the car so im doing mileage and its not being registered on the clock. Speedo doesnt work, I assume they're electric unlike old ford ones.. Any ideas people?

    Appreciate your help. Thanks alot. Nick.

    Also, i did have a haynes book, I give it away with a horrible white 1600 a3 i sold tother month. :sadlike:
    #1
  2. Ads

    Ads

    [Jan 26, 2015]

  3. SilverSaloon
    Offline

    SilverSaloon Member

    Joined:
    Apr 4, 2009
    Messages:
    50
    Likes Received:
    0
    [Apr 12, 2009]
    Any ideas peeps would be greatfull. thanks.,
    #2
  4. S3 chj
    Offline

    S3 chj Member

    Joined:
    Nov 21, 2007
    Messages:
    306
    Likes Received:
    1
    [Apr 12, 2009]
    check all your fuses mate i had this problem and i took each fuse out and it fixed it dont ask me how but it did lol
    #3
  5. SilverSaloon
    Offline

    SilverSaloon Member

    Joined:
    Apr 4, 2009
    Messages:
    50
    Likes Received:
    0
    [Apr 12, 2009]
    Ok, Will try that thanks.
    #4
  6. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,604
    Likes Received:
    1,295
    [Apr 12, 2009]
    There was a an issue with sensors/senders on the A3/TT which maybe you're issue given going round corners etc makes it go funny, could be the sensder has come lose of the arm etc if its based on the same style part/design as the 8P has which sure it is, also whats working on the cluster at all, revs, icons, etc etc?
    #5
  7. SilverSaloon
    Offline

    SilverSaloon Member

    Joined:
    Apr 4, 2009
    Messages:
    50
    Likes Received:
    0
    [Apr 13, 2009]
    Everything is working apart from the speedo itself and mileometer, revometer and all computer functions/clock are ok. Thanks for advice on fuel gauge.
    #6
  8. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,604
    Likes Received:
    1,295
    [Apr 13, 2009]
    Well they do have little mechanical units on the rear of the cluster that could have come loose inside the plastic housing, has a wheel gearing system, maybe the wheel has come of its locators, I'd remove the cluster & take apart & have a look, but I'm almost sure the fuel gauge is the sender of the fuel pump/level unit, simply cause of the round corners & braking observations.
    #7
  9. ibrahim
    Offline

    ibrahim New Member

    Joined:
    Aug 14, 2009
    Messages:
    1
    Likes Received:
    0
    [Aug 14, 2009]
    Hi a3agu

    Any joy getting this solved yet? I have a 1999 s4 with the exact same faults youre describing everything works fine except the speedo which doesnt work and the fuel gauge fluctuates whilst driving. I thought i might be able to add some info. It started after I had the timing belt replaced and didnt happen immediately but after about 5 minutes of driving and stayed like that for that evening. The next day it worked fine again for 5 minutes driving and since then nothing. Anyone got any more ideas...Please?
    #8
  10. mark_sarah
    Offline

    mark_sarah Limp mode!

    Joined:
    Nov 3, 2009
    Messages:
    203
    Likes Received:
    0
    [Nov 3, 2009]
    I have the same problem with my 1999 A3 1.8 Turbo sport. Mine was all ok, then one day speedo stopped working, and i also noticed the fuel gauge was fluctuating at the same time. The first thing i tried was removing and replacing all the fuses, but no joy. I have recently been told it is the speedo cluster that needs replacing.
    But would be nice to find someone that can fix them, rather than go through the grief matching up part numbers.
    #9
  11. mark_sarah
    Offline

    mark_sarah Limp mode!

    Joined:
    Nov 3, 2009
    Messages:
    203
    Likes Received:
    0
    [Nov 7, 2009]
    Replaced the cluster, and it did not fix the problem.. Anymore help would be greatfully received...
    #10
  12. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,604
    Likes Received:
    1,295
    [Nov 7, 2009]
    Fuel sender in tank could be affecting the gauge which also could be causing some interference with other cluster functions.
    #11
  13. djdougalno1
    Offline

    djdougalno1 Member

    Joined:
    Oct 22, 2008
    Messages:
    189
    Likes Received:
    1
    [Nov 8, 2009]
    not to sure bout the fuel gauge problem but the speedo problem will be the road speed senor audi call it an impulse sensor goes in the back of the gear box not a big job just a bit fiddly an also make sure bu get the right one depending on weather the car is 5 or 6 speed or quattro model
    #12

Share This Page