1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fault Codes Meanings

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by Yarsir, Aug 26, 2011.

  1. Yarsir
    Offline

    Yarsir New Member

    Joined:
    Aug 12, 2011
    Messages:
    14
    Likes Received:
    0
    Hello
    people



    Car, 2006 A4 Avant Tdi 170, 94k FASH



    Symptoms none. Problems yellow flashing glow plug lightly randomly coming on.

    Yesterday - yellow flashing glow plug light again with check engine light permanently
    on.



    Only had the car a few weeks, maybe normal but noticed lumpy idle and just
    today strong smell of fuel

    Any help advice would be appreciated. Thanks


    Chassis Type: 8E - Audi A4 B6/B7
    Scan: 01 02 03 08 09 0F 11 15 16 17 18 36 37 45 46 55 56 57 65 67
    69 75 76 77

    VIN: WAUZZZ8E27A054421 Mileage: 151910km/94392miles
    -------------------------------------------------------------------------------
    Address 01: Engine Labels: Redir Fail!
    Part No SW: 03G 906 018 AQ HW: 03G 906 018 AQ
    Component: R4 2.0l PPD1.3 9971
    Revision: --H23--- Serial number:
    Coding: 0000072
    Shop #: WSC 00414 210 83158
    VCID: 74EC0ED56E2B

    2 Faults Found:
    005214 - Mass Air Flow during Regeneration too Low
    P145E - 006 - Short to Plus - Intermittent - MIL ON
    Freeze Frame:
    Fault Status: 10100001
    Fault Priority: 5
    Fault Frequency: 7
    Reset counter: 40
    Mileage: 0 km
    Time Indication: 0

    Freeze Frame:
    RPM: 1568 /min
    Torque: 24.0 Nm
    Speed: 25.0 km/h
    0.00 %
    85.41 %
    Mass Air / Rev.: 321.6 mg/str
    Mass Air / Rev.: 610.4 mg/str

    012546 - Motor for Intake Manifold Flap (V157): No Signal
    P3102 - 006 - Short to Plus - Intermittent
    Freeze Frame:
    Fault Status: 00000001
    Fault Priority: 5
    Fault Frequency: 7
    Reset counter: 40
    Mileage: 0 km
    Time Indication: 0

    Freeze Frame:
    RPM: 0 /min
    Torque: 144.0 Nm
    Speed: 0.0 km/h
    0.00 %
    #1
  2. gary3306
    Offline

    gary3306 Member

    Joined:
    Oct 17, 2010
    Messages:
    950
    Likes Received:
    27
    Yea, you need a new MAF sensor and a new Motorized intake Manifold Flap. Both around £150 ish from the dealer (MAF sensor may be a bit more)
    #2
  3. Yarsir
    Offline

    Yarsir New Member

    Joined:
    Aug 12, 2011
    Messages:
    14
    Likes Received:
    0
    Thanks for the reply. That's expensive news I didn't want to hear :sadlike:

    Only recently had the car serviced, all filters and oil, couple of days later the problem started but probably just bad timing?

    Was typing first post while in the car, cleared the faults, drove 10 feet then the glow plug light came straight back on!

    This!

    VCDS Version: Release 10.6.4 (x64)
    Data version: 20110418


    Saturday,27,August,2011,21:49:29:26576


    Chassis Type: 8E - Audi A4 B6/B7
    Scan: 01 02 03 08 09 0F 11 15 16 17 18 36 37 45 46 55 56 57 65 67
    69 75 76 77

    VIN: WAUZZZ8E27A054421 Mileage: 151910km/94392miles
    -------------------------------------------------------------------------------
    Address 01: Engine Labels: Redir Fail!
    Part No SW: 03G 906 018 AQ HW: 03G 906 018 AQ
    Component: R4 2.0l PPD1.3 9971
    Revision: --H23--- Serial number:
    Coding: 0000072
    Shop #: WSC 00414 210 83158
    VCID: 74EC0ED56E2B


    1 Fault Found:
    005214 - Mass Air Flow during Regeneration too Low
    P145E - 006 - Short to Plus
    Freeze Frame:
    Fault Status: 11000001
    Fault Priority: 5
    Fault Frequency: 1
    Reset counter: 40
    Mileage: 0 km
    Time Indication: 0


    Freeze Frame:
    RPM: 1600 /min
    Torque: 64.0 Nm
    Speed: 53.0 km/h
    0.00 %
    85.41 %
    Mass Air / Rev.: 392.4 mg/str
    Mass Air / Rev.: 648.6 mg/str


    Readiness: N/A
    #3
  4. Yarsir
    Offline

    Yarsir New Member

    Joined:
    Aug 12, 2011
    Messages:
    14
    Likes Received:
    0
    Can anyone concur :yes:

    After a quick search seems to be a common issue on these....

    Thanks
    #4
  5. chrisa4quat
    Offline

    chrisa4quat Member

    Joined:
    Sep 21, 2004
    Messages:
    897
    Likes Received:
    10
    both are on this, air mass meter and intake manifold flap (throttle body). check fuse for engine. see if fuse has blown. fuse will be side of dash. You can also get these parts from euro car parts a bit cheaper, poss gsf?
    #5
  6. Yarsir
    Offline

    Yarsir New Member

    Joined:
    Aug 12, 2011
    Messages:
    14
    Likes Received:
    0
    Hello, thanks for the reply.

    Well decided to remove the MAF and clean it with electrical circuit cleaner.

    Refitted the MAF and all was fine for 1 day, nice idle, no smoke or warning lights.

    Went out today and after around 3 miles same yellow glow plug light started to flash :blownose:
    Turned of and started again a couple of hours later on way home, light had gone out but strong smell of fuel and smoking on cold.

    Just cleared the fault the same fault again -
    Tuesday,30,August,2011,17:38:53:26576
    VCDS Version: Release 10.6.4 (x64)


    Address 01: Engine Labels: Redir Fail!
    Control Module Part Number: 03G 906 018 AQ HW: 03G 906 018 AQ
    Component and/or Version: R4 2.0l PPD1.3 9971
    Software Coding: 0000072
    Work Shop Code: WSC 00414 210 83158
    VCID: 74EC0ED56E2B
    1 Fault Found:


    005214 - Mass Air Flow during Regeneration too Low
    P145E - 006 - Short to Plus - Intermittent
    Freeze Frame:
    Fault Status: 00000001
    Fault Priority: 5
    Fault Frequency: 1
    Reset counter: 40
    Mileage: 0 km
    Time Indication: 0


    Freeze Frame:
    RPM: 1472 /min
    Torque: 32.0 Nm
    Speed: 49.0 km/h
    0.00 %
    85.41 %
    Mass Air / Rev.: 321.6 mg/str
    Mass Air / Rev.: 735.8 mg/st


    Readiness: N/A

    Will have to order replacement MAF from dealers tomorrow. As far as the manifold flap issues goes, sprayed a little WD40 on it and has been fine since, but I'm guessing the messed up readings from the MAF with over fueling may have triggered that fault??

    Thanks
    #6
  7. *Adam
    Offline

    *Adam Member

    Joined:
    May 11, 2011
    Messages:
    55
    Likes Received:
    1
    Unplug your MAF and see if it runs without the glow plug light flickering but it does seem to want a new MAF. Just got one myself for £133 with a £52 surcharge :(
    #7
  8. Yarsir
    Offline

    Yarsir New Member

    Joined:
    Aug 12, 2011
    Messages:
    14
    Likes Received:
    0
    Fitted a new MAF a couple of days ago. No issues since, car seems to idle/drive smoother
    Just waiting for the injectors to pack up now :redrs4:

    Thanks
    #8
  9. Yarsir
    Offline

    Yarsir New Member

    Joined:
    Aug 12, 2011
    Messages:
    14
    Likes Received:
    0
    Well all started again now. Same symptoms, strong smell of fuel, 2 yellow lights and same faults codes as above.

    Going to order a new intake manifold flap and have it fitted. I'm guessing the manifold flap issue is leading to the MAF fault? As i've already changed that. Could it be anything else?

    Thanks
    #9

Share This Page