1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fault Code - P2181: Any ideas?

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by Brendan12, Sep 25, 2011.

  1. Brendan12
    Offline

    Brendan12 Member

    Joined:
    May 13, 2011
    Messages:
    142
    Likes Received:
    3
    Hi, I scanned my car and it came up with this fault code. Can anyone shed any light on what it might be?


    Chassis Type: 8E - Audi A4 B6/B7
    Scan: 01 02 03 08 09 0F 11 15 16 17 18 36 37 45 46 55 56 57 65 67
    69 75 76 77

    VIN: WAUZZZ8E35A499120 Mileage: 89030km/55320miles
    -------------------------------------------------------------------------------
    Address 01: Engine Labels: 06F-907-115-AXX.lbl
    Part No SW: 8E0 910 115 J HW: 8E0 907 115 C
    Component: 2.0l R4/4V TFSI 0080
    Revision: --H02--- Serial number:
    Coding: 0104000318070020
    Shop #: WSC 00586 210 88211
    VCID: 2854E424E275
    1 Fault Found:
    008577 - Performance Malfunction in Cooling System
    P2181 - 008 - Implausible Signal - Intermittent
    Freeze Frame:
    Fault Status: 00101000
    Fault Priority: 0
    Fault Frequency: 1
    Mileage: 88905 km
    Time Indication: 0
    Freeze Frame:
    RPM: 2814 /min
    Load: 48.2 %
    Speed: 63.0 km/h
    Temperature: 73.0°C
    Temperature: 16.0°C
    Absolute Pres.: 1000.0 mbar
    Voltage: 14.224 V
    #1
  2. RMH1A4cab
    Offline

    RMH1A4cab I'm in Cruise control

    Joined:
    Jul 12, 2010
    Messages:
    524
    Likes Received:
    15
    think its either a engine temperature sensor or thermostat are faulty .
    #2
  3. Brendan12
    Offline

    Brendan12 Member

    Joined:
    May 13, 2011
    Messages:
    142
    Likes Received:
    3
    Ahh, they are on my list to be changed as the temperature display is acting a bit strange! Thanks!!
    #3
  4. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    strange how? taking longer to warm up? over heating?
    this fault often flags up if the indicant engine temp and dash temp are substancially different.
    #4
  5. Brendan12
    Offline

    Brendan12 Member

    Joined:
    May 13, 2011
    Messages:
    142
    Likes Received:
    3
    It never seems to get to temperature, unless it gets a bit of stick. All heaters are fine though so I presume its the stat or temperature sensor.
    #5
  6. B5NUT
    Offline

    B5NUT Well-Known Member

    Joined:
    Feb 6, 2010
    Messages:
    2,249
    Likes Received:
    249
    The error code shows a single fault frequency, but the "Implausible Signal" fault can only be generated by the the sensor. Get that changed first and if your still not getting upto temp then change the stat.
    #6
  7. Brendan12
    Offline

    Brendan12 Member

    Joined:
    May 13, 2011
    Messages:
    142
    Likes Received:
    3
    Oh ok yeah I will try that first. Thanks!
    #7

Share This Page