1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fault code - I don't understand

Discussion in 'VCDS (formerly VAG-COM) forum' started by Ads, Oct 8, 2009.

  1. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 8, 2009]
    Hi,

    Just done a scan on vag-com because my interior courtesy lights don't work and neither does my glove box light. All other interior illumination is fine. I got the following fault:

    Address 09: Cent. Elect. Labels: 8P0-907-279.LBL
    Part No SW: 8P0 907 279 D HW: 8P0 907 279 D*
    Component: Bordnetz-SG 1.0 H27 0601
    Coding: A18C5F00A0141000000000000000000000
    Shop #: WSC 00000

    Part No: 8P2 955 119 C
    Component: Wischer WWS Audi350 0180
    Coding: 16711696
    Shop #: WSC 00000

    1 Fault Found:
    02399 - Control Circuit for Terminal 30 for Interior Illumination
    009 - Open or Short to Ground



    Can't find the fault code 02399 on ross-tech's site. Is this just telling me there is a break in the circuit somewhere?? Dodgy wire/connection somewhere???

    Thanks
    #1
  2. Ads

    Ads

    [Dec 26, 2014]

  3. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 8, 2009]
    Open or Short to Ground denotes wiring/fuse issue given its not seeing a circuit connected, what have you touched recently, check fuses 1st then wiring, elsa helps for these jobs
    #2
  4. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 8, 2009]
    Lights weren't working when I bought the car. There is one of those hands free kits installed too, also by previous owner, and the wiring for it goes in through where the stereo is and a mic pops out where the front courtesy light is. Maybe something was disturbed when it was fitted??

    I've checked fuses and they are fine. Also checked voltage at fuses and 12v is present. Checked for voltage at terminals in courtesy light unit and no volts there.

    So to check wiring I guess I've gotta start ripping stuff off??? :faint:
    #3
  5. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 8, 2009]
    I know its unlikely, but have you checked the bulbs aswell as usually the simplest solution is always the last one we check, you didnt say so thought I'd mention, lol

    If not bulbs, then sounds like either wiring has been damaged, pulled apart or a connector is loose, simple wire tracing needed mate to fix the issue, I think its simple once found, but if its shorting above which is possible then should be able to resolve fairly easily
    #4
  6. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 9, 2009]
    Yep checked bulbs, well two of the three mentioned. Is it possible one faulty bulb could prevent rest from working maybe? I'll check the other one.
    Checking the wires could be a nightmare. They run behind the dash and headlining don't they?
    As I've got power at the fuse I guess the problem is somewhere between there and the unit? Is it a direct route or do they go somewhere else first? Isn't there an onboard supply unit or something, j519??

    I'm not looking forward to this!
    #5
  7. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 15, 2009]
    Just out of interest, have you been playing with coding before this happened mate?

    Check the J519 module thats above the drivers footwell & pull out the relay if its present KL30 & then push it back in, need elsawin for these things to check wiring, I checked & I would suggest you also check visually that all the plugs are pushed home onto the board whilst checking relay.
    #6
  8. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 15, 2009]
    Hello mate...

    Nope, interior lights weren't working when I bought the car. I reckon it's got something to do with the handfree kit the last owner had installed.

    Considered having a look at the J519 module, but pulling part of the dash away put me off. I'll give it a go though. Thanks.

    Question..... if for example the wire feeding my rear interior light was broken would it prevent the whole circuit from working or just that light??

    I checked elsawin (or was it ETKA) for wiring diagrams and I found something like this...
    [​IMG]

    So looks like the three lights I am having problems with are all on the same circuit.
    #7
  9. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 15, 2009]
    Yeah thats the image I was looking at aswell, it depends where the wire break is mate, if its in the loom before the lights connected then yes it would disconnect all of them, but it doesnt need all connected to have say some of them working, but do check that relay aswell & also the connectors on the J519 & push the wires in to see if its a loose pin on a block.

    Now if there was a wire shorted out then yes this could turn of all the lights, does this effect anyother illumination lights like say the red ones on the climate, cluster, boot light etc?

    I guess who ever did the BT would possibly of trapped a wire against a metal part thus grounding it, this isnt unheard of, have a look on the J519, removing trim is no biggy at all mate, 2 screws underneath & remove the fuse box cover on right side of dash & undo one screw there, hexagon head, just get a socket set out also check everywhere possible the guy would of run wires so in light assmebly in roof & down pillar, but only after checking the J519 board as could be simply a plug not in fully.
    #8
  10. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 15, 2009]
    Rest of illumination works fine..... boot light, red ones scattered throughout dash/doors/lighter/etc, cluster.

    Ok, will definitely check out J519, probably not until saturday now.
    I'm safe to disconnect any connectors/relays I find there, right?? Obviously as long as they aren't fixed in place, and I put them back properly.


    Christ.... I'm on the verge of nipping down the pound shop, buying a torch and taping to my friggin rear view mirror!!! :mad:
    #9
  11. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 15, 2009]
    Yeah its fine to remove/disconnect things, relays I would do whilst engine is of, check them for any discolouration, I found on mine, the relays had got some white discolouration on them guessing from heat & I just scratched it of so had bare metal again & this seemed to resolve an issue I had months back.

    You'll maybe find the rleays are very well in there & requires some pulling/wiggling side to side, but if patient & careful all should be good.
    #10
  12. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 15, 2009]
    Brilliant mate. I'll give it a go on saturday and let you know how I get on.
    And once again, thanks :icon_thumright:
    #11
  13. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 17, 2009]
    Right... I checked the j519, pulled out and checked everything I found there but lights still not working.
    Also checked for relay at KL30 but its empty. Should there be one there??

    Had a look to see if I could trace wires but they all disappear up the pillar.
    #12
  14. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 17, 2009]
    whats your engine & gearbox code so can be more specific in elsa mate, cause it says terminal 30 & that is the KL30 relay I think, but lets check 1st huh.
    #13
  15. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 17, 2009]
    Engine and gearbox code??? Haven't got a clue mate!! Sorry. :confused:
    Find that in the car can I??

    It's a 2.0 FSi, manual, 53 plate.
    That help?
    #14
  16. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 17, 2009]
    In front of the service booklet is good place to start.
    #15
  17. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 17, 2009]
    Haven't got it with me at the moment. Probably not til tomorrow.
    #16
  18. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 17, 2009]
    Just had a look in engine bay and there's a sticker on the cambelt cover.
    AXW..... Sure that's an engine code, isn't it?!
    #17
  19. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 18, 2009]
    After pulling out and reinserting all relays at J519 I thought I'd run another scan.
    Loads of electrical faults were present (horn etc) but assume that is because of pulling those relays?!?
    Anyway, cleared all fault codes and rescanned. Now I'm left with one again. It's the interior light fault but slightly different for the one in my opening post.

    This is what I get now:

    Address 09: Cent. Elect. Labels: 8P0-907-279.LBL
    Part No SW: 8P0 907 279 D HW: 8P0 907 279 D*
    Component: Bordnetz-SG 1.0 H27 0601
    Coding: A18C5F00A0141000000000000000000000
    Shop #: WSC 00000
    Part No: 8P2 955 119 C
    Component: Wischer WWS Audi350 0180
    Coding: 16711696
    Shop #: WSC 00000
    1 Fault Found:
    00059 - Terminal 30 for Interior Lighting
    012 - Electrical Fault in Circuit


    Heeeellllllppppppppppppppp!!!

    Terminal 30.... is this the KL30 mentioned???
    Because as I mentioned, I don't have anything plugged in there. Should I??
    And if I should, what's kind do I need to buy? Can I pick up a generic relay from a car place or do I need to go to Audi to get one??
    Ooorrrrr.... can I swap one of the relays that I do have just to see if this cures the problem??

    Sorry, loads of q's but cheers!! :beerchug:
    Last edited: Oct 18, 2009
    #18
  20. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 18, 2009]
    Had trouble finding car in elsa, found now so checking over what I can.

    Ok do you have the reading lights aswell in the light assembly in roof, as in a seperate switch for driver/passenger to turn on a small light each side for say map reading cause might be just 1 wire feeding these lights which goes into light assembly, also do you have a cup holder & storage under the climate control assuming you have interior light pack whic includes red lights in doorhandles at night, as it is possible some of these share the same wire from elsa anyway.

    Have you checked the light assembly for voltage for when the door is open on all pins, I assume the airbag light in roof lights up when you turn ignition on.

    Also if you check in the rear of the unit where the KL30 relay could plug in, is there any wires immediately behind this, check fuses under the bonnet aswell & not just the normal fuses, there are some screwed ones aswell.

    I'm still studying the wiring, so will report back when I find anything of interest.

    Is your battery in the boot or under the hood trust me its relevant.
    Last edited: Oct 18, 2009
    #19
  21. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 18, 2009]
    Ok well after reading it more, it is definitely the B466 supply wire from the J519 that should be feeding all 3 as per your image, as I also checked under convenience which shows the same mate, I dont think its the grounding wire cause they both use a different wire for this, only common thing is the B466 feed wire, so I would check that terminal at the J519 for power 1st with meter.

    It should be a 10 pin connector in black plugged into the K socket which they are labelled so just turn on car & open door then leave the head assembly siwtch in flat position so the lights turn on from open door & see what happens on that pin, if pin has power then u know its the wire from there onwards, if no power then need to look at the board, the supply power to the board, fuses again etc, process of elimination mate.
    #20
  22. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 18, 2009]
    Also I do wonder what you did as the fault has changed to a different code, possibly there is a dodgy pin in there somewhere.
    #21
  23. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 18, 2009]
    No, don't have reading lights, just the main door opening light.
    My cup holder (used to be a card holder) is on top of the climate control.
    I don't have the light pack.

    Yep, checked light assembly with doors open but no voltage.
    And yep, airbag light works fine.

    Good idea, I'll check behind KL30 in a little bit.
    I've checked fuses in box under bonnet and all look to be fine.

    Battery is under bonnet.

    Gonna have to get hold of a meter, my one went missing.

    So basically work backwards so can isolate area of problem. Sounds like a plan mate.
    Have already checked fuse box at right end of dash and had 12v there. Also checked light unit as mentioned but didn't have voltage there.

    So path is... fuse box ---> J519 ---> light unit ???
    So problem must be wiring after fuse box, J519, wiring from J519, or light unit.

    EDIT - can't be light unit as glovebox and rear light unit don't work either. So wiring after fusebox, J519, wiring after J519.
    Last edited: Oct 18, 2009
    #22
  24. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 18, 2009]
    Only thing I have done is removed and reinsert the relays at J519.

    Original fault code I received 02399 wasn't even listed on ross-tech, i don't think.
    This new one is though.

    I'm hoping it's this empty KL30 that's causing the problem.

    I'm gonna go check behind it for wiring now.
    #23
  25. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 18, 2009]
    And then there was light!!!!!!
    :yahoo: SSSOOORRRTTTTEEEDDDD!!!! :yahoo:

    Pulled out the relay for the horn and stuck it into the empty KL30, and on came all three lights.

    Cheers (it's Nigel isn't it??!) for pushing me to pull off part of my dash to check the onboard supply unit and pointing me to KL30, otherwise probably wouldn't have done it! :icon_thumright:

    Pretty productive weekend.... fitted armrest, lights working. Nice :)

    Thanks again mate :applaus:
    #24
  26. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 18, 2009]
    Was there wiring behind the KL30 then, cause it was saying KL30 was used in elsa, so why you didnt have relay is beyond me, glad you sorted.

    Assume you will get the proper relay from audi as you need horn huh.

    There's a thanks button to your right, lol.

    & yes its Nigel, no worries.
    #25
  27. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 18, 2009]
    There wasn't any wiring behind KL30. Didn't feel like there was wires behind any of the terminals tbh.
    As for the missing relay, I reckon it all revolves around this bluetooth kit install.

    And yep, I'll be down audi at some point this week to get the relay. I've already tried to beep someone and all I got was a big fat.... :tumble:
    #26
  28. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 18, 2009]
    Good luck, update when all sorted
    #27
  29. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 26, 2009]
    Relay now sourced and fitted.... but from Volkswagen, not Audi.
    Audi didn't have any in stock and would've taken a few days for delivery, so parts guy checked all local VAG dealers and gave me details of nearest VW who had stock.

    So, £8 for relay instead of the 100 odd english pounds Audi probably would've charged to diagnose, fix, etc.

    :o.k:
    #28
  30. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 26, 2009]
    Nah mate the relay from either would be same price I should think, sometimes the outlook we have on the dealers can be wrong, thats why I dont call them stealers anymore given I understand to a degree what they go through with VAG & the limitations they have with pricing & technical side.

    So no more faults with vagcom & all is working 100%?
    #29
  31. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 26, 2009]
    Sorry, didn't make myself clear..... I meant that it's good that I only had to pay £8 for the relay and fit it myself, rather than pay probably over £100 to Audi to take my car in, diagnose the problem and supply and fit the relay.

    I am left with one fault though that was there beforehand... it's an engine fault. Something like.... 16825 - EVAP Emission Control Sys: Incorrect Flow.

    Cleared it about a week ago and it stayed away for a while. Came back this weekend though. Car doesn't feel any different though.
    #30
  32. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 26, 2009]
    I get yer no worries.

    Can you post up the exact error or is that definitely it?
    #31
  33. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 27, 2009]
    In fact there are TWO fault codes....

    Address 01: Engine Labels: None
    Part No SW: 06F 906 056 BT HW: Hardware No
    Component: MED9.5.10 00 5340
    Coding: 0000072
    Shop #: WSC 06435
    Part No: 06F 907 807 A
    Component: NOX 0309170119 004 3608
    06F907807A NOX 0309170119 004 3608
    2 Faults Found:
    16825 - EVAP Emission Control Sys: Incorrect Flow
    P0441 - 008 - Implausible Signal - Intermittent
    16575 - Fuel Pressure Sensor (G247): Implausible Signal
    P0191 - 008 - Implausible Signal - Intermittent
    Readiness: 0000 0000

    According to ross-tech, 16575 can be caused by a low fuel level. Thinking back I was pretty low on fuel when I did my last scan. In fact I'm sure I had the refill warning pinging in DIS. I've filled up now so I'll clear the fault and re-scan.

    The other fault, 16825, comes back after a few days when cleared. Reading other's posts seems quite common on the fsi, something to do with air leaks or something. Probably get my head under the bonnet this week to see if I can notice any bad hoses or connections.
    #32
  34. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Oct 27, 2009]
    Really need to get car on a leak test kit from air filter feed onwards I guess, there's a smoke version to which I'd love to have but £700 is tad OTT for me, but find someone local who would do for cheap price, only takes what 30 minutes tbh, pressure system up ad smoke then look for any leaks
    #33
  35. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    581
    [Oct 27, 2009]
    Didn't even know such a thing existed!
    I'll have a nose about and see if I can find somebody with one. Cheers for that.
    #34

Share This Page