1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Evening Everyone

Discussion in 'The Welcome Section' started by Sammo, Apr 25, 2008.

  1. Sammo
    Offline

    Sammo New Member

    Joined:
    Apr 25, 2008
    Messages:
    19
    Likes Received:
    0
    Hi everyone

    I have a 92 S2 Coupe that I have endless problems with so I thought the more forums I join the more chance I have of fixing it.

    So wait for the questions to start coming.

    Cheers

    Sammo
    #1
  2. voorhees
    Offline

    voorhees Moderator Staff Member Moderator

    Joined:
    Dec 18, 2005
    Messages:
    15,020
    Likes Received:
    1,146
    Sammo
    Welcome to the site,I'm sure you'll find the help you need.
    If you struggle then I could give you the number of a guy who quite clever with S2's
    #2
  3. Rev-head
    Offline

    Rev-head Active Member

    Joined:
    Oct 14, 2004
    Messages:
    2,987
    Likes Received:
    7
    Hello Sam ...Tell me your issues mate ..I have had plenty of long nights fixing S2/S4's..

    :beerchug:
    #3
  4. Sammo
    Offline

    Sammo New Member

    Joined:
    Apr 25, 2008
    Messages:
    19
    Likes Received:
    0
    Well if I accelerate hard the car will start to boost then it will suddenly just cut everything to the extent you nearly smack your face on the steering wheel. After doing it the once it will just keep doing it no matter how hard or soft you accelerate.

    I had the whole front of the car off the other day and found a split in the Michelin Man hose at the front which I replaced with a Samco hose. After putting it all back together the problem is still there. I also have noticed that the bolt on top of the wastegate is unwound quite far.

    The last thing which I think is very much connected to the problem is when you are accelerating, before it shits its pants you can hear the air being sucked in(or pushed out) and when you change gear you can really hear the dump even though it just has a standard recirc valve.

    Someone please help as it making me want to get rid of the car. It has done this since the day after I bought the bloody thing!

    Oh yeh and its a 3B engine.

    Cheers

    Sammo
    #4
  5. evilscotsman
    Offline

    evilscotsman Space Cowboy

    Joined:
    May 1, 2008
    Messages:
    1,350
    Likes Received:
    10
    Hi mate, im new to the forum too :)

    Does sound like boost is getting dumped, could be a boost leak that happens under pressure like the hose swells and lets go at the end connection just as the boost builds....could also be a faulty divertor / bov letting go under pressure, check all the boost and vacuum hoses for splits or cracks, and that the factory bov has the correct connection to the inlet vacuum so it only triggers on throttle release.
    #5
  6. audivro
    Offline

    audivro Member

    Joined:
    Apr 30, 2008
    Messages:
    36
    Likes Received:
    0
    had the same on a turbo celica,could well be the same thing.The turbo is hitting the ecu's boot upper limit and the pressure is being dumped to save the engine.(ecu failsafe)Sounds like the same thing based on the actuator issue you mentioned.

    P.s welcome dude i am new here also:w00t:
    #6
  7. Nilz
    Offline

    Nilz Defo worth the wait :)

    Joined:
    Apr 9, 2006
    Messages:
    10,208
    Likes Received:
    387
    welcome mate, i cant help with this unfortunately, but you have a nice car :)
    #7

Share This Page