1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ESP Warning Light Fault..

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by Ekco163, Dec 29, 2010.

  1. Ekco163
    Offline

    Ekco163 New Member

    Joined:
    Jun 26, 2010
    Messages:
    25
    Likes Received:
    0
    [Dec 29, 2010]
    Help..

    I've got a problem with my 2005 B7 1.8T A4 (not quattro).

    The warning light on the dash is not coming on when I start the car or by pressing the ESP button. The traction control seems to be working as it should but the light does not come on when it kicks in.

    This may be unrelated but it started playing up after the car was left over the xmas break for a few days and I checked my tyre pressure's and found my two rear tyres to be low (now all at 32psi as per door pillar label.)

    I've checked the two fuses for the ESP Both okay, when I removed the 10amp one and started the car it triggered the DIS panel warning for the brake system, So it seems as though its working.

    I've checked the brake light bulbs/switch, ABS works fine, no other dash warnings, car drives fine, Battery Volts 12.2v

    Do the dash warning LED's go bad.?
    Any ideas..??:confused:
    Last edited: Dec 29, 2010
    #1
  2. Ads

    Ads

    [Oct 20, 2014]

  3. kite
    Offline

    kite Member VCDS Map User

    Joined:
    Oct 12, 2007
    Messages:
    678
    Likes Received:
    17
    [Dec 29, 2010]
    a vagcom scan would be a good place to start
    #2
  4. Mike B
    Offline

    Mike B Member

    Joined:
    Jul 10, 2007
    Messages:
    793
    Likes Received:
    8
    [Dec 29, 2010]
    How do you know that it is working?Can you see any diff by pushing the button if so I guees it must be the led I have lost some in my light switch but can live with that
    #3
  5. Ekco163
    Offline

    Ekco163 New Member

    Joined:
    Jun 26, 2010
    Messages:
    25
    Likes Received:
    0
    [Dec 29, 2010]
    No didn't try pushing the switch. Didn't get uncontrolled wheelspin when testing the car it acts the same as before the light problem, not very scientific i know..:). Hope its not the LED, dont fancy getting a new dash panel.

    I've not got Vagcom but starting to wonder if it would be a good investment..:sm4:
    #4
  6. danotto
    Offline

    danotto VAG HUNTER

    Joined:
    Jun 23, 2007
    Messages:
    1,090
    Likes Received:
    1
    [Jan 1, 2011]
    i had a problem with my esp light staying on randomly and couldnt switch it off turns out it was a faulty brake pedal switch
    #5
  7. richrich14
    Offline

    richrich14 Member

    Joined:
    Dec 31, 2010
    Messages:
    30
    Likes Received:
    0
    [Jan 1, 2011]
    sorry to butt in a little in tis thread, question for danotto. My ESP light seems to come on randomly until either reset (cleared using vag com)or somtimes when the car is switched off and on again. How did you find out it was a brake pedal switch? and where is it located?
    #6
  8. danotto
    Offline

    danotto VAG HUNTER

    Joined:
    Jun 23, 2007
    Messages:
    1,090
    Likes Received:
    1
    [Jan 3, 2011]
    a mate had vagcom,and it showed up brake pedal switch internal fault.so he changed it for me whilst on holiday,not 100% sure where exactly it is fitted but im guessing its on top of the brake pedal lever,as my old audi s3 was there also.
    #7
  9. Ekco163
    Offline

    Ekco163 New Member

    Joined:
    Jun 26, 2010
    Messages:
    25
    Likes Received:
    0
    [Jan 7, 2011]
    Update - Disconnected the battery last weekend and noticed that the esp light came on when starting the car after reconnecting, then It went out and didn't come back on even when pressing the switch. Then this morning when starting it came on and worked as normal, done about 70 miles, so it must have been sorting itself out..?? :huh::huh:
    Last edited: Jan 7, 2011
    #8

Share This Page