1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ESP not working

Discussion in 'A3/S3 Forum (8L Chassis)' started by ex_scoobydoo, Dec 17, 2009.

  1. ex_scoobydoo
    Offline

    ex_scoobydoo Member

    Joined:
    Oct 2, 2009
    Messages:
    179
    Likes Received:
    0
    i dont think my ESP is working, i did know this from the start, well i knew the esp button didnt work so one wet day i tried to wheel spin which the car did for a split second then it got traction, now tonight the roads are like glass so i dipped the clutch a little doing a hard right turn out of a junction and nearly ended up doing a doughnut lol, although it was good fun, i am getting no esp light show on the clocks and also no esp light on the ESP button,
    were do i go from here ?
    #1
  2. Westy
    Offline

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,295
    Likes Received:
    969
    Normally when ESP is nackered you'll get the ESP light on the dash stall on all the time so if you dont get the light I dont know.

    You're best bet would be to get the car scanned to see what fault codes its showing otherwise you could be changing sensors just for the sake of it.

    By the way the owners manual advises that ESP is turned off in the snow :icon_thumright:
    #2
  3. ex_scoobydoo
    Offline

    ex_scoobydoo Member

    Joined:
    Oct 2, 2009
    Messages:
    179
    Likes Received:
    0
    no fault codes, it was scanned a couple of weeks ago
    does it maybe turn itself of when under a certain temp
    #3
  4. Westy
    Offline

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,295
    Likes Received:
    969
    I'm afraid not mate. Mine was flashing away at me this morning till I manually turned it off. When you press the button is there definitely no dash light? Could the bulb have blown?
    #4
  5. ex_scoobydoo
    Offline

    ex_scoobydoo Member

    Joined:
    Oct 2, 2009
    Messages:
    179
    Likes Received:
    0
    deffo no lights on the dash or the button, and the wheels spin for fun, its not working :( no fault codes either
    #5
  6. Westy
    Offline

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,295
    Likes Received:
    969
    What car are you driving? if its an S3 the wheels shouldn't spin unless the haldex isn't working.
    #6
  7. Andrew@A.L.D
    Online

    Andrew@A.L.D Cylinder Head Master

    Joined:
    Jun 19, 2009
    Messages:
    3,504
    Likes Received:
    354
    Same thing happened to a lad on here, same faults as yours and in the end it was his Haldex controller that had gone, i sold my old unit to him and fixed the probkem
    #7
  8. ex_scoobydoo
    Offline

    ex_scoobydoo Member

    Joined:
    Oct 2, 2009
    Messages:
    179
    Likes Received:
    0
    yer its an s3 2000 apy
    dam must be the haldex, what am i looking at to fix and what work involved
    #8
  9. Andrew@A.L.D
    Online

    Andrew@A.L.D Cylinder Head Master

    Joined:
    Jun 19, 2009
    Messages:
    3,504
    Likes Received:
    354
    I have the performance haldex and well worth it.

    You may find a performance haldex 2nd hand

    std ones go for about £100+ on ebay

    A garage should only charge you 1 hours labour only

    If DIY its a bit harder under axle stand on your back so could take longer
    #9

Share This Page