1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ESP Light.

tom2 Sep 26, 2012

  1. tom2

    tom2 Member

    167
    17
    18
    Hi,

    The ESP light came on the dash this morning whilst driving to work (1.8Tq 190). It stays on permanent it doesn't flash. Also, last week whilst i was driving the brake warning light came on, but after turning off and back on again the light went off and has been fine since.

    Brake pads are good/clean but brake pedal feels a bit lighter, That may just be me though.

    Any ideas before it goes back to the dealers,

    Cheers
    tom
     
  2. VagCabby

    VagCabby Active Member

    489
    65
    28
    Is your wheel alignment alright? My wheel alignment was out, so with that out and the camber on the road my steering wheel was off center which was causing my esp light to ping on when driving on a straight road. After turnig the engine off and back on again it was fine untill I went on a motorway again. Got my alignment done and tyres rotated and all was fine.
     
  3. tom2

    tom2 Member

    167
    17
    18
    as far as i know its fine, is there a way of knowing or shall i just take it down the local kwik fit to check?
     
  4. murran

    murran Well-Known Member

    1,545
    39
    48
    lol at kwik fit! better off taking it to the green grocers.

    you need it code reading to find out the fault. could be one of a few things.... steering angle sensor, accelaration sensors etc
     
  5. hades-

    hades- Yorkshire & Humber Rep. Regional Rep VCDS Map User

    9,470
    645
    113
    as above could be anything get the codes read
    and bypass kwakfit
     
  6. quattrojames

    quattrojames Moderator Staff Member Moderator Audi A6 Audi Avant Owner Group

    14,039
    565
    113
    Check your brake lights work and the pedal switch isn't broken.
     
  7. tom2

    tom2 Member

    167
    17
    18
    just got back from taking the car for a thrashing and light is still on, borrowing a mates vagcom tomorrow. Brakes and brake lights work fine, as does the ABS. And it seems that the ESP is working too, Tried it on a big roundabout just, on a soaking wet road and usually if i turn esp off i can slide the car, but i tried my best and couldn't lol...
     
  8. murran

    murran Well-Known Member

    1,545
    39
    48
    if the esp light is on then it isnt working.
    report back what fault codes are coming up and we can advise!
     
  9. pauldazzle

    pauldazzle Well-Known Member

    1,090
    75
    48
    Kwikfit:no:
     
  10. J.quattro

    J.quattro New Member

    15
    0
    1
    could be a dirty maf sensor .
     
  11. murran

    murran Well-Known Member

    1,545
    39
    48
    a dead fish has more diagnostic capabilty than the average kwikfit employee.

    any updates?
     

Share This Page