1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ESP Faulty

ben_turbo1 Aug 3, 2010

  1. ben_turbo1

    ben_turbo1 Member

    181
    0
    16
    Hi Everyone,

    After selling my S3 back in Feb I have finally got another Audi but this time an A3 1.8ts.

    Anyway when I press the ESP button the light doesn't come up on the dash like it did when I had exactly the same model a few years ago. Only picked the car up today and only realised the ESP button wasn't working tonight. Will try some spirited take offs tomorrow and see if the ESP is kicking in or not.

    I've searched for this on the forum and there's a couple of people whom have had this issue with their S3s but as mine is only 2wd I am looking for some pointers on where to look to diagnose the fault.

    Will also plug into vagcom when I see my brother next.

    Thanks in advance
     
  2. ben_turbo1

    ben_turbo1 Member

    181
    0
    16
    Ok my ESP is deffo not working. I have ordered Vagcom as driving 40mins to my brothers house everytime I want to use it is a real pain so I should be able plug my car in soon which no doubt will point me to the fault.

    Here's a question for you guys with big brake conversions, I've got some brembos fitted on the front, will they stop the ESP from working or is there any reason someone may of disconnected the ESP when they fitted the brakes?

    Thanks
     
  3. s3dave

    s3dave TFSI Hybrid Supporter

    10,110
    736
    38
    i would have thought the esp light would have come on if not working??
    does it come on with the ignition lights?
     
    Last edited: Aug 4, 2010
  4. Matt82

    Matt82 Active Member

    2,365
    2
    36
    daves right. it should come on when the ignition goes on... otherwise some genius has taken the bulb out
     
  5. s3dave

    s3dave TFSI Hybrid Supporter

    10,110
    736
    38
    and usually the abs light will come on,, if not working as they are related to the wheel sensors
     
  6. ben_turbo1

    ben_turbo1 Member

    181
    0
    16
    Ok I get all the lights come up on the dash when I turn the egnition on apart from the warning triangle in a circle which from memory is the ESP light. Does this mean someone has taken the light out/ the the bulb is faulty?

    I'm guessing even if the light is not working Vagcom will pick up on any problems?
     
  7. badger5

    badger5 www.badger5.co.uk Site Sponsor

    9,424
    1,973
    113
    check the instrument bulbs by logging into it on vagcom and running a test.. it exercises all dials and lightsm led/lcd segments etc
     
  8. ben_turbo1

    ben_turbo1 Member

    181
    0
    16
    Will do Badger, thanks for the input.
    ESP is working at all though as I can't put any power down without spinning up, hoping its just a sensor or something as I don't have the expensive haldex to worry about.
     
  9. ben_turbo1

    ben_turbo1 Member

    181
    0
    16
    Ok downloaded VCDS-lite but am still waiting for them to send me to registration code but carried out a quick scan of the parts it would let me and it came up with:
    01423 - Lateral Acceleration Sensor (G200)
    012 - Electrical Fault in Circuit
    Think I changed one of these on my S3 or maybe it was the longitudinal one but anyway do you think this could be the reason my ESP isn't working?
    I will know more once rosstech send me the registration number.

    Thanks
     
  10. s3dave

    s3dave TFSI Hybrid Supporter

    10,110
    736
    38
    01423 for sure
     
  11. ben_turbo1

    ben_turbo1 Member

    181
    0
    16
    So you think thats deffo the problem? Obviously I will change the sensor but seem to remember they are a bit expensive. Will wait untill I can do a full scan and see what other issues I find.

    Still damm happy with the car though, for half the price of my S3 its a bargain.
     
  12. thegoal007

    thegoal007 Another S3 owner....

    804
    26
    28
    shouldn't you clear all errors first - give it a spin and then check again in case some are old uncleared errors.
    Also I believe that Lateral Sensor is interchangeable with the other sensor - ones near/behind the glove box and the other under the steering - can never remember which is which !
     
  13. ben_turbo1

    ben_turbo1 Member

    181
    0
    16
    Yep your right they are interchangeable and from memory I think the lateral one is under the steering so I will give them a swap and a scan.

    Cheers
     

Share This Page