1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ESP and Battery Warning Lights

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by djcormie, Apr 14, 2009.

  1. djcormie
    Offline

    djcormie Member

    Joined:
    Mar 20, 2008
    Messages:
    42
    Likes Received:
    0
    [Apr 14, 2009]
    Hi All

    Just wondering has anyone else had a similiar problem with their 130 TDi Sport. My ESP light came on a few weeks back, I felt a vibration through the engine at the same time, so I stopped, turned the car off and back on and it was fine. I read in the manual that this can happen, so wasn't too bothered, that and the car is due a service so I thought I'd get it checked then for vag com codes.

    Then I was coming home last Thursday and the ESP light came on again, I was stuck in traffic so turned it off and back on, ESP light came on again and the battery light starting flashing. There was a vibration like the engine was wobbling too much when the ESP light came on. I got the car home and haven't driven it since. I'm using my better half's car till I get to the garage. But I'm just worried if this is going to be a costly fix.

    I had read that it could be lights sometimes, but I only changed the indicators and sidelights and my brake lights seem to be fine....oh and I fitted a new battery just before Christmas

    Cheers for any help

    Mark
    #1
  2. Ads

    Ads

    [Sep 20, 2014]

  3. evilscotsman
    Offline

    evilscotsman Space Cowboy

    Joined:
    May 1, 2008
    Messages:
    1,350
    Likes Received:
    12
    [Apr 15, 2009]
    ESP also involves the ABS as well mate, but I saw too that it says if the ESP light comes on, and goes off later its ok (?) - weird eh!

    Could it be the ABS pump causing the vibes?

    Did you get it scanned for codes yet?
    #2
  4. djcormie
    Offline

    djcormie Member

    Joined:
    Mar 20, 2008
    Messages:
    42
    Likes Received:
    0
    [Apr 15, 2009]
    yeah i'd have thought that the light just comin on of its own accord can't be good...

    i'm ringing the garage today and hopefully get it in soon

    thanks for the reply
    #3
  5. docurley
    Offline

    docurley Moderator Staff Member Moderator

    Joined:
    Dec 12, 2003
    Messages:
    3,859
    Likes Received:
    25
    [Apr 15, 2009]
    Could be the Brake switch has this is what happend to mine and after replacing the switch for £8 it sorted the problem out.
    #4
  6. djcormie
    Offline

    djcormie Member

    Joined:
    Mar 20, 2008
    Messages:
    42
    Likes Received:
    0
    [Apr 15, 2009]
    thanks Doc, I had read that alright but the brake lights seem to be workin OK, is there anything else that would be associated with the brake switch that I would need to check??
    #5
  7. jase0851
    Offline

    jase0851 Member

    Joined:
    Oct 8, 2004
    Messages:
    784
    Likes Received:
    1
    [Apr 15, 2009]
    i get brake switch error codes every now and then i will have to change mine eventually
    #6
  8. docurley
    Offline

    docurley Moderator Staff Member Moderator

    Joined:
    Dec 12, 2003
    Messages:
    3,859
    Likes Received:
    25
    [Apr 15, 2009]
    My brake lights worked fine but some how the switch is linked in to the ESP and ABS and although my brake lights worked OK the switch still took out the ESP & ABS my brake lights only stopped working after I took the switch apart.:redface:

    I should add the fault would come and go but in the end it stayed on and thats when I took the switch apart also Audi have upgraded the part so it's a know fault at Audi.
    #7
  9. djcormie
    Offline

    djcormie Member

    Joined:
    Mar 20, 2008
    Messages:
    42
    Likes Received:
    0
    [Apr 16, 2009]
    thanks Doc, I got a switch last night and got it in, seemed to be fine until the ESP and ABS light came on and now when I turn the car on the brake warning symbol is appearing in the DIS and its beeping, can't be good. I'm going to swop back to old one to see what that does and refit the new just to be sure.

    The battery light is still flashing as well.

    Car is booked into the garage on Monday, so we'll see....
    #8
  10. djcormie
    Offline

    djcormie Member

    Joined:
    Mar 20, 2008
    Messages:
    42
    Likes Received:
    0
    [Apr 20, 2009]
    so this all might be a bit more than originally thought.....

    I've changed the brake switch and when I turned the ignition back on the brake warning light appears on the DIS and it beeps three times, brake light work OK though

    And then all the lights started to flash on the dash and all went dead. I turned the ignition off and tried to start again it wouldn't even turn the engine and all the lights on the dash would go out. I tried to jump it this morning from another car, it starts but then dies after 30seconds, oh dear.

    I was supposed to be taking it to the mechanic today, but I might have to rethink that.....
    #9
  11. evilscotsman
    Offline

    evilscotsman Space Cowboy

    Joined:
    May 1, 2008
    Messages:
    1,350
    Likes Received:
    12
    [Apr 20, 2009]
    dodgy battery or battery connection mate i'd say, and then the immob maybe threw a fit when you reactivated the ecu with the jumper car?

    Try connecting the leads and leave connected for a few minutes, then turn on the ignition and see the check go out before starting attempts to give the immob time to hand over. The original faults could have been battery related but the shutting down after 30 secs sounds like the immobiliser.

    weird, but I had some strange behaviour before I changed my battery, lights glowing inside while driving then dimming out, stupid esp warnings at walking speed while parking etc etc, forgot about that :)
    #10
  12. djcormie
    Offline

    djcormie Member

    Joined:
    Mar 20, 2008
    Messages:
    42
    Likes Received:
    0
    [May 5, 2009]
    Right so, after all the above, the flashing battery light was a dodgy alternator pulley on the front of it apparently, so that was fixed along with the alternator getting refurbed and the battery light has gone, but the ESP and ABS lights are still coming on, but not immediately only after driving and not always at the same time, some times its after 5mins of driving other times could be 20mins. Weird....

    My mechanic isn't too worried and says it could be from all the messin around with the battery, could have tripped some sensors that need reset, its going to him to get sorted this Monday

    Just thought I'd post a quick follow up in case anyone else comes across the same problem, will update on the rest next week
    #11
  13. evilscotsman
    Offline

    evilscotsman Space Cowboy

    Joined:
    May 1, 2008
    Messages:
    1,350
    Likes Received:
    12
    [May 5, 2009]
    hmmm try getting the codes cleared and see if they return again.
    #12
  14. djcormie
    Offline

    djcormie Member

    Joined:
    Mar 20, 2008
    Messages:
    42
    Likes Received:
    0
    [May 12, 2009]
    The saga continues, the car was serviced yesterday and the mechanic said the only codes that were showing were associated with the low battery when the alternator was banjoed, so he cleared them all and thought it should all be good. But driving home last night the ESP and ABS lights popped on again, still really random though they were on after 5mins on the way home and then again immediately when I went out for a cycle, but on the way back home no sign of them for a good 30mins drive.....Have to pop back down today to the mechanic to see what the crack is
    #13
  15. djcormie
    Offline

    djcormie Member

    Joined:
    Mar 20, 2008
    Messages:
    42
    Likes Received:
    0
    [May 12, 2009]
    So it would seem the fault is this
    01435 - Brake Pressure Sensor 1 (G201): Electrical Fault in Circuit

    Possible Causes

    • Brake Pedal Switch (F) faulty/jammed
    • Brake Pressure Sensor 1 (G201) faulty
    Possible Solutions

    • Check/Replace Brake Pedal Switch (F)
      • See Measuring Blocks
    • Check/Replace Brake Pressure Sensor 1 (G201)
      • ABS Hydraulic Unit (N55) may need to replaced
      • Perform Brake Pump Bleeding
      • Perform Brake Pressure Sensor 1 (G201) Basic Setting
      • Replace Brake Electronics Control Module (J104
    The brake switch that I fitted is working as the mechanic checked it through vag com, so it would seem to be the pressure sensor.....
    #14

Share This Page