1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error - Solenoid Valves for engine mounting short to B+

jay786 Feb 22, 2012

  1. jay786

    jay786 Member

    91
    0
    6
    I have got this error coming on the diagnostics .. is this realted to car shaking alot and making noise because my car shakes alot.

    How can i resolve or fix this problem.

    Thanks
     
  2. marktdisport

    marktdisport Active Member

    1,195
    15
    38
    have a look at the rear gear box mount m8, just had mine replaced with my DMF and CLUTCH
     
  3. jay786

    jay786 Member

    91
    0
    6
    how much did it cost you to change dmf and clutch
     
  4. simon.m

    simon.m Active Member

    2,747
    6
    38
    the engine mount with the solenoid on it is just off to the right hand side when looking from the front of the car you can see it. have a look at the 2 wires going to it see if they have snaped
     
  5. jay786

    jay786 Member

    91
    0
    6
    ANy pictures to show me ..
    What is it near?

    Thanks and sorry for being dumb
     
  6. simon.m

    simon.m Active Member

    2,747
    6
    38
    i dont have any mate but you cant miss it if you look down the right hand side by the inside wheel arch you will see it it has 2 wires coming off of a round dome looking thing
     
  7. jay786

    jay786 Member

    91
    0
    6
    What part do i have to buy or replace?
     
  8. simon.m

    simon.m Active Member

    2,747
    6
    38
    you can normally re do the wires if not its the hole engine mount i think
     
  9. marktdisport

    marktdisport Active Member

    1,195
    15
    38
    mine was showing engine mount fault but it was picking the knocking up off the knackered split rear one on the gear box, dmf clutch, rear mains oil seal, gearbox mount cost me around £600
     
  10. jay786

    jay786 Member

    91
    0
    6
    I dont know what to look for .. the cables seem okay ... so whats the error for?
     
  11. quattrojames

    quattrojames Moderator Staff Member Moderator Audi A6 Audi Avant Owner Group

    14,039
    565
    113
    It's telling you the engine mount is knackered.
     
  12. jay786

    jay786 Member

    91
    0
    6
    oh okay so how do i know which one to change?

    How much are they?

    THanks
     
  13. simon.m

    simon.m Active Member

    2,747
    6
    38
    as far as i know there is only one engine mount that has the solenoid on it and thats the one on the right hand side that you can see
     
  14. jay786

    jay786 Member

    91
    0
    6
    okay but if its telling me this one is worn out ... what about the other one?
    Both been put into place same time .. how would i know if the other one is not knackered
     
  15. quattrojames

    quattrojames Moderator Staff Member Moderator Audi A6 Audi Avant Owner Group

    14,039
    565
    113
    :banghead:

    These engine mounts are 'electric' - when a current is passed through them they will stiffen up, thus at idle the mount will be softer to minimise the vibrations, but it will stiffen up at speed. The other mount (assuming there's only one on the 1.9's?) is a normal rubber mount so will not have the electric feature. This is a very common failure on A4's.
     
  16. twist123

    twist123 Member

    186
    1
    16
    Its the passengers side of the engine and theres only one.
     
  17. jay786

    jay786 Member

    91
    0
    6
    Are u sure theres only one .. i saw two circular dome thing on a 1.9 TDI?

    If its one im so happy .. please confirm?
     
  18. twist123

    twist123 Member

    186
    1
    16
    One AFAIK. Phone Audi parts and ask them.
     
  19. marktdisport

    marktdisport Active Member

    1,195
    15
    38
    theres two fitted to your car one with wiring and one without !! ive got a brand new without wiring from audi still in the box :whistle2:
     
  20. jay786

    jay786 Member

    91
    0
    6
    Do i change both ...
    How much?
     
  21. jay786

    jay786 Member

    91
    0
    6
    anyone got pictures of both
     
  22. marktdisport

    marktdisport Active Member

    1,195
    15
    38
    you wont want the bill for changing both m8, nearly £80 for the one without wiring expect the other to be more, did you check the rear gearbox mount ???? this was causing mine to pick up knocking and gave me that code...........
     
  23. jay786

    jay786 Member

    91
    0
    6
    no i havent .. gearbox mount .. wheres that located?
     
  24. jay786

    jay786 Member

    91
    0
    6
    what do i loook for ... how much will that set me back?
     
  25. twist123

    twist123 Member

    186
    1
    16
    If youre getting a code for the mount, its the electric one. Its very likely to fail. The other is not.

    Dont get ahead of yourself, change the mount, then think of the rest.
     
  26. jay786

    jay786 Member

    91
    0
    6
    its just if i do both at once .. id save on the labour and get it done once and for all
     
  27. quattrojames

    quattrojames Moderator Staff Member Moderator Audi A6 Audi Avant Owner Group

    14,039
    565
    113
    Why don't you take it in to someone who knows what they're doing?

    It seems that everything we mentioned you want a price for. Take it somewhere and get them to establish exactly what's wrong and go from there, I don't see this idle speculation is getting anyone anywhere.
     
    white.akita likes this.

Share This Page