1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Erratic Idle

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by Olly P, Mar 27, 2013.

  1. Olly P

    Olly P My other cars a mk2 Golf GTi

    Joined:
    Dec 2, 2008
    Messages:
    696
    Likes Received:
    12
    So, i've got an erratic idle on my 2005 A4 DTM. Fairly regularly, when I come to a stop the revs rise to around 1200 then lowly falls back to 800 ish.

    I've taken the car to a garage to fit coilovers recently and asked them to look at the problem They fixed a small boost leek and this cleared the engine management light.... after a day its now retuned.

    Is there anything I should check before taking it back? I don't have a copy of vag-com so can't scan for the code, i'm just wondering if any ones had similar problems? I've seen a few threads suggesting that it could be a faulty PCV valve?

    Any help much appreciated
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. B5NUT

    B5NUT Well-Known Member
    VCDS Map User

    Joined:
    Feb 6, 2010
    Messages:
    2,702
    Likes Received:
    354
    I would look at the MAF, you could unplug it and see if the fault still occurs. Had this on a couple of my A4's and and it was the MAF. First one I was able to clean the other had to be replaced.
     
  4. Olly P

    Olly P My other cars a mk2 Golf GTi

    Joined:
    Dec 2, 2008
    Messages:
    696
    Likes Received:
    12
    Brilliant, thanks for the info :icon_thumright:
     
  5. claudefrog

    claudefrog Member

    Joined:
    Dec 13, 2006
    Messages:
    372
    Likes Received:
    1
    I heard the coolant temp sensor can also cause this issue, if you scan the car with vag-com or even a generic OBD reader it will help point you in the right direction.
     
  6. mancdan

    mancdan Active Member

    Joined:
    Jun 1, 2011
    Messages:
    403
    Likes Received:
    32

Share This Page