1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Erratic idle + fault code

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Crunch, Feb 15, 2009.

  1. Crunch
    Offline

    Crunch Member

    Joined:
    Jan 1, 2009
    Messages:
    118
    Likes Received:
    0
    [Feb 15, 2009]
    Hi, Ive noticed that now and again my 2.0 tdi a3 will idle slightly erratically. Only really noticeable when sat at lights and the car will shake slightly. It only does it now and again.

    When I had it remapped, the bloke looked to see if it had thrown any codes, and it had thrown something to do with glow plug number 4 circuit failure, although this could have been an old code.

    Speaking to a friend, he seems to think the fault has nothing to do with the problem i've got and it's a possible sticking egr valve.

    Anyone got any ideas?

    Cheers, Dom
    #1
  2. Ads

    Ads

    [Oct 2, 2014]

  3. RobinA3
    Offline

    RobinA3 Well-Known Member

    Joined:
    Aug 11, 2005
    Messages:
    1,785
    Likes Received:
    27
    [Feb 15, 2009]
    won't be the glow plug error causing the problem as the glow plug only comes into action when the engine is started up cold
    #2
  4. RobinA3
    Offline

    RobinA3 Well-Known Member

    Joined:
    Aug 11, 2005
    Messages:
    1,785
    Likes Received:
    27
  5. Khufu
    Offline

    Khufu Active Member

    Joined:
    Jan 2, 2003
    Messages:
    5,703
    Likes Received:
    30
    [Feb 15, 2009]
    I'd go with that too.
    #4
  6. Crunch
    Offline

    Crunch Member

    Joined:
    Jan 1, 2009
    Messages:
    118
    Likes Received:
    0
    [Feb 15, 2009]
    where would i start with that? cheers
    #5
  7. kaz219
    Offline

    kaz219 Active Member VCDS Map User

    Joined:
    Jun 8, 2008
    Messages:
    1,806
    Likes Received:
    2
    [Feb 16, 2009]
    check the engine bay for hoses that have split/have holes etc.

    Also, check the seals..

    These can be identified as some holes may leave black marks around where the air has been escaping (the gungy black stuff thats found when the manfiold, imf, egr are stripped off..) This may only apply to the thick main pipe in the middle front of the engine where the egr is located...

    I have a pic of my air leak and how i identified it and a vid of the revs bouncing but this is on my home comp. Im at my flat at uni now..Probs wont be home till nextweekend or even the weekend after but when i get chance, i'll post the pic and vid and you can compare it to yours.

    My leak was inbetween the EGR and the manifold - the seal had perished as i changed the IMF and it must have moved about as they are connected...

    On Vagcom, the revs were idling between 810ish and just under 850ish IIRC. It happened when i drove the car for a few mins, parked it up and started it again... It was very slight but enough to annoy me!
    #6
  8. sprout99
    Offline

    sprout99 Member

    Joined:
    Jun 13, 2006
    Messages:
    373
    Likes Received:
    0
    [Feb 16, 2009]
    check the ones either side of intercooler.

    They are known for either popping out or splitting.
    #7
  9. Crunch
    Offline

    Crunch Member

    Joined:
    Jan 1, 2009
    Messages:
    118
    Likes Received:
    0
    [Feb 16, 2009]
    Thanks for the help. I'll have a look at the weekend in the daylight.

    Would i not notice the leak at higher revs, or wouldnt it make noise under boost?
    #8
  10. kaz219
    Offline

    kaz219 Active Member VCDS Map User

    Joined:
    Jun 8, 2008
    Messages:
    1,806
    Likes Received:
    2
    [Feb 16, 2009]
    It depends on the kidn of air leak.

    Mine was fine when driving - just idled a bit rough...
    #9
  11. kaz219
    Offline

    kaz219 Active Member VCDS Map User

    Joined:
    Jun 8, 2008
    Messages:
    1,806
    Likes Received:
    2
    [Feb 16, 2009]
    It depends on the severity of air leak and which pipe its leaking from...

    Mine was fine when driving - just idled a bit rough...
    #10
  12. Lance-22
    Offline

    Lance-22 A3TDI

    Joined:
    Nov 9, 2008
    Messages:
    116
    Likes Received:
    1
    [Feb 18, 2009]
    i sometimes get this problem but it is only very rarely, not enough to really bother me much but i will check for air leaks next time im under the bonnet as this seems the most likely cause..
    #11
  13. jemd3@yahoo.com
    Offline

    jemd3@yahoo.com New Member

    Joined:
    Feb 20, 2009
    Messages:
    4
    Likes Received:
    0
    [Feb 20, 2009]
    Hi,

    Audi TDI 2.0 Sport 53 plate
    My car was just serviced and timing belt change by the main dealer. I now have, what sounds like the same problem. Did you get it resolved?
    #12
  14. sprout99
    Offline

    sprout99 Member

    Joined:
    Jun 13, 2006
    Messages:
    373
    Likes Received:
    0
    [Feb 20, 2009]
    our was cutting out when stood in traffic - new pipes fitted and idle speed turned up.
    #13
  15. APL TDi
    Offline

    APL TDi Member

    Joined:
    Jan 4, 2009
    Messages:
    289
    Likes Received:
    1
    [Feb 20, 2009]
    Mine ildes a bit rough every now and then.

    Its not enough to bother me though.
    #14
  16. Crunch
    Offline

    Crunch Member

    Joined:
    Jan 1, 2009
    Messages:
    118
    Likes Received:
    0
    [Feb 20, 2009]
    Not sorted it yet as i spent a few hours cleaning it today so cba working on it now. When yours does it does it do it enough to make the car noticable wobble and jiggle the passengers about. If you get out you can hear the engine, it almost sounds as if its misfiring.
    If it makes any difference my cambelt was done about 1k ago (not by audi)
    #15
  17. Dan Gliballs
    Offline

    Dan Gliballs Active Member

    Joined:
    Jul 5, 2006
    Messages:
    1,568
    Likes Received:
    3
    [Feb 20, 2009]
    Strange, I just read this thread title as 'eric idle'..............
    #16

Share This Page