1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine Warning Light - Have fault codes - don't know if its a concern.

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by sebbelcher, Jun 4, 2012.

  1. sebbelcher
    Offline

    sebbelcher Member

    Joined:
    Mar 30, 2009
    Messages:
    53
    Likes Received:
    0
    [Jun 4, 2012]
    Hi Guys,

    Posting this I have realised that its been well over a year since I last logged in - which means its been well over a year since my Audi gave me any grief! So that is something to celebrate!

    Any-hoo. About a week ago, whilst pottering along, my engine warning light came on. I've just now had chance to hook-up Vag-Com and pull the codes - they were:

    17544 - Fuel Trim: Bank 1 (Add): System too Lean


    P1136 - 001 - Upper Limit Exceeded


    16891 - Idle Control System RPM: Higher than Expected.


    P0507 - 001 - Upper Limit Exceeded - Intermittent

    I cleared the codes and took the car for a 15 min drive and the engine warning light has not come back on. However I have been noticing a slightly 'lumpy' idle recently (which matches the codes) - if I'm stopped at lights for over 20 seconds or so, the idle speed will drop slightly, rocking the car, before (presumably) the engine management picks up the RPM to stop it stalling, it will over-rev for a couple of seconds before settling back down. This repeats every 20 seconds roughly.

    Anything to worry about? It's due a service in a couple of months, so I'm tempted just to leave it until then, as there is nothing in the codes that hints at a cause.

    Agree? :)

    Thanks all!
    #1
  2. Ads

    Ads

    [Oct 21, 2014]

  3. Mike B
    Offline

    Mike B Member

    Joined:
    Jul 10, 2007
    Messages:
    793
    Likes Received:
    8
    [Jun 4, 2012]
    What engine?
    #2
  4. quattro tony
    Offline

    quattro tony Member

    Joined:
    Sep 4, 2010
    Messages:
    167
    Likes Received:
    0
    [Jun 4, 2012]
    Ive seen these codes on a 1.8t and it was the breather valve in the breather pipe system had failed. There was a lot of vacuum in the oil system esp when the dipstick tube was pulled out a bit. Please confirm the engine to us though;)
    Last edited: Jun 4, 2012
    #3
  5. sebbelcher
    Offline

    sebbelcher Member

    Joined:
    Mar 30, 2009
    Messages:
    53
    Likes Received:
    0
    [Jun 5, 2012]

    Sorry folks, missed out a crucial bit of info there! It is indeed a 1.8T on a 03 plate -engine code BFB I think.
    #4
  6. bowen
    Offline

    bowen Member

    Joined:
    Mar 28, 2011
    Messages:
    457
    Likes Received:
    14
    [Jun 5, 2012]
    Try taking the oil cap off with the engine running, if there is suction then there is your problem. Check the crankcase breather valve.
    #5
  7. sebbelcher
    Offline

    sebbelcher Member

    Joined:
    Mar 30, 2009
    Messages:
    53
    Likes Received:
    0
    [Jun 12, 2012]
    Hey,

    I tried to take the oil filler cap off with the engine running - so much suction that I actually physically couldn't - had to lever it up with a screwdriver blade. Tried clamping the tube which comes off the breather valve, and sure enough the suction went away - so I'm pretty sure that's the problem.

    I read on another forum a post recommending replacing the turbo vacuum valve at the same time as the additional pressure in the engine caused by the faulty breather valve can damage it. Has anyone else heard of or recommend this?? Its not a cheap part (compared to the breather valve with is a mere tenner).
    #6
  8. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    [Jun 12, 2012]
    just the pcv will fix it.
    tho the actual valve is cheap. getting to remove it and disturbing the other breather pipes..... rubber ones be all gunked up and soft and plastic breather pipes go brittle and break too. youll end up spending more than a tenner!
    #7
  9. sebbelcher
    Offline

    sebbelcher Member

    Joined:
    Mar 30, 2009
    Messages:
    53
    Likes Received:
    0
    [Jun 18, 2012]
    So, good news and bad news.

    First the good news, I bought the parts today and fitted the new valve. The job was a complete pain in the arse, even after taking the coolant header tank off you are still constantly working with your wrists bent at angles they were never intended to. No surprise the plastic parts of the L-shape breather pipe fell away like wet cake when I removed the large end from the engine. The small end also snapped off in the rubber T-piece. It took an enormous amount of effort to get the other side of the T-piece off the fixed pipe, not only to remove the fscking annoying one-use clips but also to physically pull it off - took a good 10 minutes of wiggling and swearing. Thankfully once those two were off you are able to pull the T-piece into a better working position to get the last pipe off and pull the valve out.

    Replaced all the parts, used decent quality jubilee clips to put it back together as a favour to myself for the next time I have to do this repair!

    Started the engine, all good, steady smooth idle and no suction on the filler cap. Took it for a spin and everything is feeling normal again, hooray!

    You can see the remnants of the old parts below.
    [​IMG]

    And the all too familiar broken valve.
    [​IMG]

    Now the bad news - well, I hope its not too bad, but it's certainly not good. When I pulled the L-shape part of the pipe out of the engine block the plastic part of the join literately disintegrated into bits and while I managed to catch and control most of it, a pinky fingernail sized piece of the soft plastic plunged into the depths of the engine. I spent about 15 minutes with a torch and my fingers inside the engine trying to locate it, but to no avail. I even tried getting the hoover in there to suck it out but all I ended up achieving was ruining my hoover with oil and gunk. Wherever it had got to, it was lodged.

    So how bad is this... its a soft bit of plastic so if it encounters anything mechanical it shouldn't be a problem, my concern is it floating around and eventually blocking something :-/

    What is the in the void directly below where this pipe joins? Should I be worried?
    #8
  10. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    [Jun 18, 2012]
    hopefully it wont find its way to the oil pick up in the sump.
    #9

Share This Page