1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine Temp Dial - AND Air Con Problem

A13X-A3 May 30, 2007

  1. A13X-A3

    A13X-A3 Progress Through Technology

    20
    0
    1
    2 quick questions

    Just noticed that the engine temp display dial on my '97 1.6 Sport doesnt work. It used to, but now it just doesnt seem to move until i go over a bump or something, this I guess means its a faulty connection. Is this something I should be worried about, as it could just be connection to display or to the computer. I wouldnt mind changing it after this problem anyway, is it a difficult job or not?

    Also

    When i bought the car, the air con didnt work, a bit of banging around let the 'fan' start up. This has since stopped and it gets difficult in the rain in Wales to keep the windows clear. It seems to be heating up the air alright, as if I switch it 'on' to a certain temp the wind flow from driving will be cooled/warmed. Is it easy to whip out the 'fan' and change it, or service it?

    Want to do this as soon as possible now that im out of uni for summer.

    Cheers guys

    Alex
     
  2. twist

    twist Member

    84
    0
    6
    The aircon relys on more than a fan. It uses a compressor driven by the engine. If this isnt working correctly for what ever reason then regardless if the fan works the AC wont.

    If the gas level is to low the compressor wont kick in, this could be due to a leak or it just needs a regas. Or the compressor or some other componet could be knackered
     
  3. AndyMac

    AndyMac Moderator Staff Member Moderator

    9,832
    46
    38
    I think he means the heater blower is knackered, nothing really to do with the aircon. If the blower brushes are worn out = no aircon or heat.
    the brushes do eventually wear out on the blower motors. It's a very simple job to replace the motor, just remove the glovebox and there it is. A few bolts and it's out. Have a look on ebay for a replacement Valeo unit.

    for the engine temp problem it's almost certainly a faulty temp sensor. Again easy DIY replacement. And make sure you do replace it as it also feeds info to the ECU so it's not just a cosmetic item for the temp guage.
     
  4. A13X-A3

    A13X-A3 Progress Through Technology

    20
    0
    1
    Yeh i thought it was the blower motor to be honest. Because it isnt just when the Air Con button is on, the rest of the blowers dont work. Glad its nice and simple. And simple with the temp sensor.

    Cheers Both

    Alex
     
  5. twist

    twist Member

    84
    0
    6
    Sorry misread what you said
     

Share This Page