1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine swap

Discussion in 'A6/S6/Allroad forum (C5 Chassis)' started by Calibar, Aug 7, 2009.

  1. Calibar

    Calibar New Member

    Joined:
    Aug 7, 2009
    Messages:
    8
    Likes Received:
    0
    Hi guys,just bought an 2001 a6 but got stiffed,engines knackered and needs replaced,its an awt 1.8t 5v and I've had no luck finding a replacement,a few breakers have told me the aeb is exactly the same ,thought someone may have more experience on this ,any info would be appreciated,thanks.
     
  2. Advert Guest Advertisement


  3. aposegil

    aposegil Member

    Joined:
    May 19, 2003
    Messages:
    40
    Likes Received:
    0
    as long as its a 1.8t you should be fine.

    then all you have to do is put all your parts on it and done
     
  4. Broken Byzan

    Broken Byzan Photographic Moderator
    Staff Member Moderator VCDS Map User quattro Audi A4

    Joined:
    Apr 26, 2004
    Messages:
    13,168
    Likes Received:
    452
    AWT is small port and VVT isnt it?

    So you would either need an APU engine to drop in, or an AJL and swap some oarts over, or an AEB will go, but everysensor and manifolds will need to be swapped.

    I know for a good running AJL engine deoending where you are based
     
  5. Calibar

    Calibar New Member

    Joined:
    Aug 7, 2009
    Messages:
    8
    Likes Received:
    0
    Hi.got the engine swapped over but the oil pressure warnings still on on the dash ?says in the manual to turn it over with the fuel pump disabled which I've done but its not for going out after 15 seconds of cranking ?Is there any way of checking if the oil is indeed pumping through the engine ?cheers in advance.
     
  6. Calibar

    Calibar New Member

    Joined:
    Aug 7, 2009
    Messages:
    8
    Likes Received:
    0
    update,got the pressure light off,(new sump switch did the trick)new prob is clutch,went to bleed it but the pedals just going to the floor regardless of minutes of pumping,theres plenty fluid in the reservoir,took the slave out and it seems ok,fluids getting to it and its squeezable,any advice would be hugely appreciated.
     
  7. Calibar

    Calibar New Member

    Joined:
    Aug 7, 2009
    Messages:
    8
    Likes Received:
    0
    Hi guys,got everything sorted and it passed its mot today but after picking the car up I noticed the speedo and mileometer aren't working(thought this would b an mot failure ?)all other instruments are fine, thinking I've missed something when putting the engine back in ,any advice will be great.
     
  8. Calibar

    Calibar New Member

    Joined:
    Aug 7, 2009
    Messages:
    8
    Likes Received:
    0
    247 views and no one knows how to fix this ?changed the engine speed sensor but that didn't cure it,any info would be great ,any info !
     
  9. Broken Byzan

    Broken Byzan Photographic Moderator
    Staff Member Moderator VCDS Map User quattro Audi A4

    Joined:
    Apr 26, 2004
    Messages:
    13,168
    Likes Received:
    452
    The speedo drive is taken from just above the driveshaft on the passengerside. Its very likely you pulled the wire out as it's contained within the engine loom. It will be hanging around the rear of the engine
     

Share This Page