1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine Stutter 1600 -2000 rpm.......

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by Chrisd1983, Jun 21, 2012.

  1. Chrisd1983
    Offline

    Chrisd1983 Member

    Joined:
    Sep 23, 2007
    Messages:
    49
    Likes Received:
    0
    [Jun 21, 2012]
    Morning,

    Recently I have noticed my B7 2.0 Tdi 140 to have a hesitation / stutter at around 1600 - 2000 rpm when accelerating, especially in 2nd and 3rd gears. It doesnt do it every time but it is happening more regularly.

    Does anyone have any advice on what I can do to resolve this issue?

    Thanks,

    Chris
    #1
  2. Ads

    Ads

    [Sep 15, 2014]

  3. podgemasterson
    Offline

    podgemasterson New Member

    Joined:
    Apr 21, 2012
    Messages:
    12
    Likes Received:
    1
    [Jun 21, 2012]
    You have just described the same problem I'm having,
    So I'm also waiting for responses!
    #2
  4. podgemasterson
    Offline

    podgemasterson New Member

    Joined:
    Apr 21, 2012
    Messages:
    12
    Likes Received:
    1
    [Jun 21, 2012]
    I also have this and want some help...
    #3
  5. Lee Applin
    Online

    Lee Applin Guest

    [Jun 21, 2012]

    personally myself my first call would be to look for vacum leaks, then clean the egr, fuel filter air filter and diesel treatment in the fuel
    #4
  6. mm707
    Offline

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    229
    Likes Received:
    3
    [Jun 21, 2012]
    On mine I changed the fuel filter which was due anyway but I think what seemed to make a difference was putting a double dose of Millers ecomax in the fuel and then using it at each fill up for a while.
    #5
  7. .Jas.
    Offline

    .Jas. Member

    Joined:
    Mar 14, 2012
    Messages:
    119
    Likes Received:
    5
    [Jun 21, 2012]
    Try some BG244, that cured my stutter, but then mine is high mileage (108k), worth a go for 20 odd quid
    #6
  8. neilenty
    Offline

    neilenty New Member

    Joined:
    Jun 22, 2012
    Messages:
    7
    Likes Received:
    0
    [Jun 22, 2012]

    Hi all,

    I have a 2007 2.0 tdi (170) and have the exact same problem.

    I had a break down a while back due to faulty injectors, one failed but two were replaced and the car ran ok. Then I needed a cam belt change and Audi changed the other two were replaced. Since then I had the same issue as above, a slight stutter between 1600-2000 revs. Took the car back to audi but it was running fine when they came out for a test drive.

    few days later it happened again. went back to audi and again they ran a diagnostic no fault codes stored and running fine again.

    However, yesterday it had a major kangaroo episode (in fourth gear at 35mph), happened in 2nd gear (slowing down) and again in 1st when I tried to setoff again.

    took it into audi, they rang this morning, still no fault code and running ok again. However they did say that say that someone else had the "exact same issue" but this caused a fault code and was due to the actuator spitting in air with the fuel.

    They have ordered one and it will be replaced monday. I did a search within this forum and sure enough "actuator" and 170p a4 all come up with this fault, but a change of this part has again often not resolved the problem.

    It seems this is due to the change of the injectors (which were a recall - unknown to me, but changed "by courtesy" when I had my cambelt done.

    hope this helps others, and fixes mine
    #7
  9. mm707
    Offline

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    229
    Likes Received:
    3
    [Jun 22, 2012]
    Interesting. I've not been happy with mine ever since the injectors were replaced. Not starting as well, lumpy idle and now the stutter.

    Please let us know if the actuator solves the problem.
    #8

Share This Page