1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine stalling when cold

Discussion in 'A4/S4 forum(B5 Chassis)' started by OldRedEyes, Oct 18, 2012.

  1. OldRedEyes

    OldRedEyes Member

    Joined:
    Feb 22, 2010
    Messages:
    442
    Likes Received:
    0
    The wifes motor has been playing up the last few days.

    When it's warm it starts and runs fine, but when it's cold i.e. first thing in the morning or after work and trying to go home.

    It turns over fine, starts then the revs just drop off. It will keep doing this until you get fed up and keep your foot on the gas.

    It's as if you need to pull the choke out (That takes me back).

    Any idea's?

    It's a 1.8T by the way
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. i_786_i

    i_786_i Member

    Joined:
    Aug 9, 2012
    Messages:
    61
    Likes Received:
    3
    Sounds like its fuel related. Had a similar issue like this on a bmw - changed the fuel filter and all was well again.

    Try checking the fuel lines, sensor and filter etc otherwise a diagnostic check should hopefully throw out a code.
     
  4. Bradderz_1988

    Bradderz_1988 Dont replace it, Upgrade it !!

    Joined:
    Aug 19, 2010
    Messages:
    3,592
    Likes Received:
    165
    Could be an immo problem mine used to do something similar where it would start then immediatly die. Have you got access to vagcom ?? A scan may pick something up.
     
  5. aragorn

    aragorn "Stick a V8 in it!"
    Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    16,668
    Likes Received:
    474
    Vagcom scan is a good plan.
     
  6. OldRedEyes

    OldRedEyes Member

    Joined:
    Feb 22, 2010
    Messages:
    442
    Likes Received:
    0
    Rather embarasing this tbh.
    Wife looked on the net, said it's the coolant temp sensor, i said i wanted to get it scanned so she should buy me the lead.
    She sent me off to pick up the part from Audi, i fitted it and it has been fine since, saturday morning.
    She still has not ordered the lead!
    She is still gloating!

    Cheers guys
     

Share This Page