1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine shake and a lot of smoke

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by b6.mo, Jan 7, 2014.

  1. b6.mo

    b6.mo New Member

    Joined:
    Sep 14, 2013
    Messages:
    13
    Likes Received:
    0
    Hi guys, I bought an Audi A4 b6 1.9 tdi a few months ago. When I bought the car it drove fine, only issue being that the car would shake on a cold start for about 20 seconds.

    The shaking gradually got worse and now shakes a ridiculous amount along with a lot of white smoke. No engine lights are showing however a fault does come up on the diagnostic thing and it shows '4th cylinder miss fire'. I purchased an injector from a local scrapyard, had it fitted and still the same problem.

    The mechanic has now told me it needs a new engine but I'm hoping the problem can be solved without having to purchase a new engine. Any ideas?
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. dualmono21

    dualmono21 Well-Known Member
    VCDS Map User

    Joined:
    Dec 9, 2006
    Messages:
    1,098
    Likes Received:
    69
    get the car scanned and post up the codes
    a common problem on the 1.9tdi engine is for the wiring harness which connects the injectors goes faulty or reads a high impedance and stops the injectors working
    to be honest you should have changed the wiring harness before changing the injector
     
  4. b6.mo

    b6.mo New Member

    Joined:
    Sep 14, 2013
    Messages:
    13
    Likes Received:
    0
    Ah sorry forgot to mention, mechanic tried changing the wiring harness. He happened to have a new harness in the garage.
     
  5. dualmono21

    dualmono21 Well-Known Member
    VCDS Map User

    Joined:
    Dec 9, 2006
    Messages:
    1,098
    Likes Received:
    69
    no problem

    ideally you still need the codes the car is giving you , this could give you a good insight into whats actually wrong
     
  6. desertstorm

    desertstorm Well-Known Member
    Audi A4

    Joined:
    Nov 21, 2013
    Messages:
    2,688
    Likes Received:
    952
    Have you checked the glowplugs ??? . If the fault occurs only on cold starts then it's not going to be an injector fault.
    Does it clear when the engine is warm.
    If so I would get a new mechanic or somebody who knows something about diesels as he is either a poor mechanic or is trying to rip you off.

    Karl.
     
  7. b6.mo

    b6.mo New Member

    Joined:
    Sep 14, 2013
    Messages:
    13
    Likes Received:
    0
    The engine shake and the smoke is now constant, it continues even once the car has warmed up. I'll get the fault code and post it up tomorrow.
     
  8. b6.mo

    b6.mo New Member

    Joined:
    Sep 14, 2013
    Messages:
    13
    Likes Received:
    0
    I haven't checked the glowplugs yet, can they cause the engine to shake excessively?
     
  9. B5NUT

    B5NUT Well-Known Member
    VCDS Map User

    Joined:
    Feb 6, 2010
    Messages:
    2,782
    Likes Received:
    369
    No, they are only used at engine startup. Before chucking the engine get a second opinion from another garage. I got advised to chuck an engine when it was a simple head gasket fault.
     
  10. Viking

    Viking Bloody Viking...

    Joined:
    Mar 20, 2010
    Messages:
    232
    Likes Received:
    20
    No, Glowplug fault would be poor starting and a bit of smoke for a few seconds. No misfiring really. Look elsewhere for your problems.

    What engine code is your car?
     
  11. b6.mo

    b6.mo New Member

    Joined:
    Sep 14, 2013
    Messages:
    13
    Likes Received:
    0
    My engine code is avf. I'll be getting a second opinion tomorrow hopefully.
     

Share This Page