1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine mgmt light and car shuddering

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Mikebabs1, Dec 20, 2007.

  1. Mikebabs1
    Offline

    Mikebabs1 Member

    Joined:
    May 14, 2004
    Messages:
    185
    Likes Received:
    1
    [Dec 20, 2007]
    Hi all,

    When I started the car up this evening to come home from work it hesitated slightly before firing up, which hasn't happened before. Then once started and idling the whole car shuddered slightly, but revs sit at a steady 9k ish as normal.

    Pulled away and it shuddered when low revs, almost like it's kangerooing slightly, but revs are steady, there's no drop. Then the yellow engine management system light came on.

    Seems to be ok when cruising along over 2000 revs, although there's possibly a slight drop in power, but whenever slowing down, or stopping, it shudders again.

    Car is as per signature, done around 85k miles.

    Anyone know what could be the cause? Just what I need right before xmas!

    Thanks all.

    Mike
    #1
  2. Ads

    Ads

    [Oct 30, 2014]

  3. Mikebabs1
    Offline

    Mikebabs1 Member

    Joined:
    May 14, 2004
    Messages:
    185
    Likes Received:
    1
    [Dec 20, 2007]
    Just been doing some searching on here of old threads and sounds to me like it could be a dead coilpack from what I've read of other similar sounding problems.

    Anyone care to agree or disagree with this diagnosis?

    If it is, can the parts be bought from halfords or parts shops or is it a stealers job?

    Cheers

    Mike
    #2
  4. ChuckH
    Offline

    ChuckH Member

    Joined:
    Nov 11, 2007
    Messages:
    159
    Likes Received:
    0
    [Dec 20, 2007]
    Doubt that its a Halfords job Allmost certainly s dealer part !
    #3
  5. J7USS
    Offline

    J7USS Shuddup Foooool!!

    Joined:
    Oct 25, 2006
    Messages:
    3,683
    Likes Received:
    1
    [Dec 20, 2007]
    Yeah sounds like coilpack...
    Try vagparts, they're pretty decent. Its not a major job, DIY!!
    #4
  6. terrysingh
    Offline

    terrysingh Member

    Joined:
    Mar 12, 2007
    Messages:
    184
    Likes Received:
    0
    [Dec 20, 2007]
    coil pack defo... i had one go while doing 90mph crapped my self, decided to change all 4, from what i can remember since 2001 there have been 7 different variations with audi trying to solve this problem,

    i had black to coil pack in the can and now a later revision and ther red now. i think there about 22 quid each, i think ecp do the too?
    #5
  7. Mikebabs1
    Offline

    Mikebabs1 Member

    Joined:
    May 14, 2004
    Messages:
    185
    Likes Received:
    1
    [Dec 20, 2007]
    Thanks guys.

    Think I'll order a coilpack and use the missus car to get to work tomorrow. Fortunately I'm off after that until Jan so should give me enough time to get the part and fit it.

    Cheers

    Mike
    #6
  8. arthurfuxake
    Offline

    arthurfuxake Controversial & Contradictive

    Joined:
    Mar 16, 2004
    Messages:
    1,308
    Likes Received:
    0
    [Dec 21, 2007]
    Get someone with Vag-Com to read the error code. I'm guessing Vag-Com will tell you which coil has failed, unless you're going to replace all 4.
    #7
  9. Mikebabs1
    Offline

    Mikebabs1 Member

    Joined:
    May 14, 2004
    Messages:
    185
    Likes Received:
    1
    [Dec 21, 2007]
    Yeah would be helpful, but unfortunately I don't know anyone who has one.

    Might just have to replace one at a time and test to see if it fixes the problem.

    Cheers.

    Mike
    #8
  10. Mikebabs1
    Offline

    Mikebabs1 Member

    Joined:
    May 14, 2004
    Messages:
    185
    Likes Received:
    1
    [Dec 23, 2007]
    Got the part, and luckily for me it was the first one that had gone, so job done in about 10 minutes.

    As per my other post though (http://www.audi-sport.net/vb/showthread.php?p=463027&posted=1#post463027) the engine management light is now on permanently, whereas before it was flashing. Hoping I just need to get the fault code reset or something.

    Cheers

    Mike
    #9
  11. pav-g
    Offline

    pav-g Member

    Joined:
    Jan 6, 2007
    Messages:
    734
    Likes Received:
    1
    [Dec 23, 2007]
    Someone on classifieds was selling a couple of coilpacks couple of weeks ago, maybe a good idea to track them down... One of mine went a few weeks ago and the symptoms do sound familiar. Good luck
    #10

Share This Page