1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine Management Light has come on after turbo replacement

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by vinceremedy, Mar 21, 2010.

  1. vinceremedy
    Offline

    vinceremedy New Member

    Joined:
    Mar 7, 2010
    Messages:
    26
    Likes Received:
    0
    [Mar 21, 2010]
    hi

    Have a 1.8t audi a4 and the turbo went on me, so have had it refurbished by universal turbos as it coould be saved and had new oil pump, oil pick up and engine flushed and new fully synthetic oil replaced. However while car parked after driving all afternoon i restarted it and then the engine warning light (sometimes called the emissions light) came on but not flashing glowing yellow/orange. The car didn't drive any different and i called the AA who didn't plug it in but started it up and said there was no suspicious smoke and sounded all well and good.

    What should i do take it back to the garage where i had the work done? Or has anyone got VAGCOM nearby? Weymouth Dorset who could give me a clue?

    The AA said it should be fine to drive and it wasn't misfiring or anything serious, but obviously i'm feeling a little worried as i have just spent £870 on the car! They said it could have been some left over oil in the exhaust system from the turbo failure causing the sensor fo flash up a problem.

    Can anyone help?
    #1
  2. golf
    Offline

    golf ***** rent boy VCDS Map User

    Joined:
    Jan 17, 2007
    Messages:
    1,556
    Likes Received:
    2
    [Mar 21, 2010]
    The ECU stores fault codes, so you may need to get the faults cleared and see if it comes back. If you don't have access to VAG-COM then disconnect the battery for a little while and if there are no underlying problems the engine light should not come on.
    #2
  3. vinceremedy
    Offline

    vinceremedy New Member

    Joined:
    Mar 7, 2010
    Messages:
    26
    Likes Received:
    0
    [Mar 21, 2010]
    The engine management light didn't come on before when the turbo went it was an oil pressure warning flashing up. this has now stopped. The engine light just came on while starting the car from idle? Have driven it again today o the shops again it seems ok, no clunky noises or mis-firing etc. So not really sure? Do you think it could be the 02 sensor?
    #3
  4. madvw
    Offline

    madvw Active Member

    Joined:
    Jul 26, 2005
    Messages:
    2,488
    Likes Received:
    2
    [Mar 21, 2010]
    no point guessing. get it scanned, clear the faults, and see if it comes back.
    #4

Share This Page