1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine dead...2.0TFSI - Result of oil pressure light coming on.

Adam31 Feb 16, 2011

  1. Adam31

    Adam31 New Member

    15
    0
    1
    Need some help....my engine died yesterday in my A3, 2.0TFSI 06 plate, it has 93K miles on it.

    Over the last few weeks the oil pressure warning light kept coming on and then going out, had it checked out at a VAG specialist and it didn't come on when they checked it. Yesterday when going home from work it came on for a few seconds and then the engine cut out.

    I got it taken back to the garage and the timing etc is still correct and the belt still intact, however there is no compression in any of the cylinders?any ideas as I now need to get them to take the head off and have a look.

    Plus I am sure there must be a problem with the oil pump and pick up.

    Thanks in advance...and repair estimates if you think you know what it is would be good aswell!

    Cheers.

    Adam
     
  2. hades-

    hades- Well-Known Member VCDS Map User

    9,482
    646
    113
    well its a comon problem for the pick up pipe to block up
    you realy should have had the sump off and pick up pipe replaced when your light came on
     
  3. benr

    benr Member

    819
    1
    16
    Interested to see if the vag specialist did a scan for fault codes... i have no idea though
     
  4. hades-

    hades- Well-Known Member VCDS Map User

    9,482
    646
    113
    when the pickup gets blocked it dont show on vcds
     
  5. benr

    benr Member

    819
    1
    16
    But, surely if the light comes on it will log an intermittent DTC? (may not be a relevant DTC, but one nonetheless)
     
  6. hades-

    hades- Well-Known Member VCDS Map User

    9,482
    646
    113
    no it will only log if its a fault with the sensor
     
  7. aragorn

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    18,605
    870
    113
    Oil pressure is a mechanical fault, not an electronic one.

    The Engine ECU doesnt know nor care about oil pressure.

    The engine is probably full of sludge due to lack of servicing, which has blocked the oil pickup and caused low pressure.

    NEVER drive a car with oil pressure problems. Had you fixed this when it first flickered on, you'd have had a small bill to change the oil pump. You now probably need a new engine.
     
  8. benr

    benr Member

    819
    1
    16
    Interesting i assumed anything which caused a light would log a code. Hope the OP can get it sorted....
     
  9. Adam31

    Adam31 New Member

    15
    0
    1
    I did take it to them a short time after it first came on and they said they would check the pipe etc so I really hoped that it would have been ok. I know it doesn't show up on the scan. I do have a comeback if it turns out that its oil pressure related as the last job sheet/invoice stated at the bottom that they had checked for the fault and found nothing as I requested.

    The oil is fine and it is serviced regularly at Audi/or a specialist so can't be that.

    I am awaiting a phone call back as I have now asked them to take the head ans sump off to find the problem. It still hand cranks over but no compression.

    Thanks for the replies.
     
  10. Cyrix

    Cyrix Member

    292
    23
    18
    No compression in ANY of the cylinders?

    Willing to bet money they find the hydraulic lifters have seized up causing the valves to stick hence no compression.

    I've a very cheap block/head from a 30k crash damaged 2.0 TFSI if you find you need it....
     
  11. Adam31

    Adam31 New Member

    15
    0
    1
    PM'd
     

Share This Page