1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Emissions light. 3.2 v6

Discussion in 'A3/S3/Sportback (8P Chassis)' started by youstolemyname, Oct 7, 2010.

  1. youstolemyname
    Offline

    youstolemyname Member

    Joined:
    Sep 7, 2010
    Messages:
    31
    Likes Received:
    0
    [Oct 7, 2010]
    Hi all. Have been enjoying my new toy for the last two weeks until an emissions light came on last Friday under heavy acceleration. This light stayed on for a while, went off then stayed on permanently. It went back to the dealer who said they replaced spark plugs and the light was off.

    Until today that is! I accelerated heavily when the engine was just below 90 degrees on the temp chart and it cane back, flashing
    and juddering heavily as I accelerated. Eventually the light went off, juddering stopped and all was normal.

    Is it normal for the engine to behave this way when cold or is it time to go back the dealers again??
    #1
  2. Ads

    Ads

    [Oct 1, 2014]

  3. youstolemyname
    Offline

    youstolemyname Member

    Joined:
    Sep 7, 2010
    Messages:
    31
    Likes Received:
    0
    [Oct 7, 2010]
    Apologies for the rambling post, sent from my iPhone!
    #2
  4. housey11
    Offline

    housey11 New Member

    Joined:
    Aug 9, 2010
    Messages:
    25
    Likes Received:
    0
    [Oct 7, 2010]
    Just had the light come on with my 3.2 get it plugged in to check fault codes.Look on my previous post and there is a link that shows people local too you that have the vagcom software. Ask nicely and you never know you! as i have found there are some very helpful people out there.
    #3
  5. edition
    Offline

    edition Active Member

    Joined:
    Nov 1, 2007
    Messages:
    1,428
    Likes Received:
    0
    [Oct 7, 2010]
    Back to the dealers, no warning lights should come on!
    #4
  6. Hellz
    Offline

    Hellz Geordie Racer

    Joined:
    Apr 15, 2009
    Messages:
    372
    Likes Received:
    6
    [Oct 7, 2010]
    I'd take it back to the dealers but as you mention 'juddering' it could be a coil (or maybe more than one) on its way out...
    #5
  7. Sarah's A3
    Offline

    Sarah's A3 MODERATOR V6 S3 Hybrid Staff Member Moderator

    Joined:
    Feb 19, 2010
    Messages:
    5,920
    Likes Received:
    28
    [Oct 7, 2010]
    My emissions light came on when my coil pack failed! Ended up changing them all.
    #6
  8. edition
    Offline

    edition Active Member

    Joined:
    Nov 1, 2007
    Messages:
    1,428
    Likes Received:
    0
    [Oct 7, 2010]
    That or maybe a lamba sensor......
    #7
  9. paddy
    Offline

    paddy Audi=No fault code, no idea

    Joined:
    Feb 6, 2008
    Messages:
    5,133
    Likes Received:
    123
    [Oct 8, 2010]
    I didnt get juddering with the lambda. My guess is coil pack as its under hard acceleration. Under load the resistance across the plug goes up and the load on the coil increases so more likely to break down under those circumstances
    #8

Share This Page