1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Emissions Control Light

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Pabs, Jun 2, 2010.

  1. Pabs
    Offline

    Pabs Active Member

    Joined:
    Jun 2, 2010
    Messages:
    618
    Likes Received:
    40
    Hi everyone, has anybody in the manchester area got a Vag Com or VCDS??? My Emissions Control Light came on today going down the motorway, i've bought a cheap one off ebay but its not working. Any help would be greatly appreciated. Its not the coil packs, the engine isn't misfiring or anything like that, it shouldn't be the cat as that was replaced last year with a sports one. Any ideas????

    Thanks
    #1
  2. paulsb
    Offline

    paulsb Member

    Joined:
    May 20, 2010
    Messages:
    138
    Likes Received:
    0
    it might just be the cat you put on. mine has aftermarket cats on and i have just cleared a fault code on mine. can't remember what the specific code was but the description sugests that the cat dosen't heat up quick enough.
    #2
  3. Pabs
    Offline

    Pabs Active Member

    Joined:
    Jun 2, 2010
    Messages:
    618
    Likes Received:
    40
    Found a place in manchester thats going to do a diagnostic check for me so hopefully it won't be too serious or expensive!!! On yours do you just keep clearing the fault code when the light comes on?? This is the 1st time its done it since i've had the complete exhaust system changed and that was over 16mths ago.
    #3
  4. paulsb
    Offline

    paulsb Member

    Joined:
    May 20, 2010
    Messages:
    138
    Likes Received:
    0
    yep, the garage i went to cleared the fault code for £25 and that included a printout of any previous codes and a service light reset.

    this is the code that i think was the problem;

    16815 - Warm Up Catalyst; Bank 2: Efficiency Below Threshold
    P0431 = 35-00 - -
    Last edited: Jun 3, 2010
    #4
  5. Pabs
    Offline

    Pabs Active Member

    Joined:
    Jun 2, 2010
    Messages:
    618
    Likes Received:
    40
    Thanks for that, i'll see what mines says later on when i get it checked!! Cheers
    #5
  6. Pabs
    Offline

    Pabs Active Member

    Joined:
    Jun 2, 2010
    Messages:
    618
    Likes Received:
    40
    Had the diagnostic done, the fault codes were all to do with the lambada sensor, cleared the codes, light hasn't come back on yet, everything is working as it should. Got the windows to close when i lock the car too :yahoo:
    #6
  7. paulsb
    Offline

    paulsb Member

    Joined:
    May 20, 2010
    Messages:
    138
    Likes Received:
    0
    good to hear. glad it wasen't something expencive.
    #7

Share This Page