1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Electrical Help B6 Avant - Central Locking / Windows

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by marco-polo, Aug 27, 2013.

  1. marco-polo
    Offline

    marco-polo New Member

    Joined:
    Apr 16, 2013
    Messages:
    8
    Likes Received:
    1
    Hi all,
    Newby post on this forum - Just sourced myself an 1.9TDi SE avant a little while back and swore blind I was going to keep it 'standard'. Two months on and things are changing as per the norm, wheels have arrived, coilovers on order and the interior is switched out for a leather S4 number.... It's still somewhere near standard in my mind!...
    Any how, my issue is this - Just before switching the interior the windows worked fine with just the odd moment where it may take two or three attempts at getting the one touch working. Now I've switched the interior over the windows no longer work and neither does the central locking - the drivers door has to be locked with the key.....
    The interior I've put in has extra puddle lights on all four door cards compaired to the original interior, so i'm assuming the modules need re-programing via vagcom to recognise the new lights. Am I right in thinking this? and would this effect the locking as well as the windows?
    I've hooked it up and run a full fault check but nothing came up other than the coolant temp sensor which I changed, cleared the code and ran another check - but nothing....
    Will I need to change the door modules for one which has the puddle light prgram or maybe just ditch the lights and put the old door looms in which dont have these on?
    Can anyone shed any light on the way forward or give me any clue as to what codes to try with vagcom to rectify.
    Cheers in advance

    Marc
    #1
  2. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep

    Joined:
    Jul 8, 2008
    Messages:
    8,703
    Likes Received:
    489
    check the loom between door and car

    pull rubber back and check for broken wires very common on the B6 B7 range
    #2
  3. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep

    Joined:
    Jul 8, 2008
    Messages:
    8,703
    Likes Received:
    489
    the puddles wont affect the locking and windows
    and yes you can code them via vcds
    #3
  4. marco-polo
    Offline

    marco-polo New Member

    Joined:
    Apr 16, 2013
    Messages:
    8
    Likes Received:
    1
    Cheers dude.
    Just got the rubber off and the thick brown wire had gone.
    Soldered it back together but still got the same issues......
    Baffled is the word
    #4
  5. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep

    Joined:
    Jul 8, 2008
    Messages:
    8,703
    Likes Received:
    489
    take a very close look if the brown was broke chances are 1 or 2 of the thin wires are aswell

    they break but still look ok check them 1 by 1 any with a small slit etc pull on them they break inside and look ok still
    are the mirrors working ?
    #5
  6. marco-polo
    Offline

    marco-polo New Member

    Joined:
    Apr 16, 2013
    Messages:
    8
    Likes Received:
    1
    I'm on it again tonight, so I'll check the other wires and see how it goes.
    No nothing operable from the drivers door works, i.e. locking, windows, mirrors. The central locking still works on the other doors & boot though....
    #6
  7. fitzbongo
    Offline

    fitzbongo New Member

    Joined:
    Aug 28, 2013
    Messages:
    1
    Likes Received:
    0
    My boot keeps opening when I drive my b6 avant can anyone help don't think it's electrical . Do I need a new latch ? Thanks ( not completely just to the safety position )
    #7
  8. stu_m
    Offline

    stu_m Active Member

    Joined:
    Oct 25, 2009
    Messages:
    1,442
    Likes Received:
    36
    also pull the multiplug out and check the pins mine had broke in there as well as the wiring!!

    I ended up having to cut the plug out and joining the wires as a temp fix 3 years ago.....its still like it now :lmfao:
    #8
  9. marco-polo
    Offline

    marco-polo New Member

    Joined:
    Apr 16, 2013
    Messages:
    8
    Likes Received:
    1
    Managed to sort it - broken brown wire, broken green & red wire and broken pins in the multiplug.....
    Cheers for your input guys, I now have doors that lock and windows that oen & close again.
    It feels like I've got a new motor!...
    #9
    pink.teg likes this.

Share This Page