1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Electric coolant pump on S3

JohnyD Jul 15, 2012

  1. JohnyD

    JohnyD New Member

    23
    0
    1
    Hi,

    Quick question... On my S3, when I switch off the engine and can hear the electric coolant pump running, if I open the bonnet I can hear the actual coolant kind-of bubbling through the system. Is this normal? To my mind I was thinking that meant there was some air in the system or something like that. Just wondering what other peoples sounded like. Can't beat a good bit of new car paranoia!

    Thanks,

    John.
     
  2. Westy

    Westy Well-Known Member

    17,443
    1,103
    113
    That's perfectly normal mate, nothing to worry about.
     
  3. JohnyD

    JohnyD New Member

    23
    0
    1
    Excellent, glad to hear that!

    Cheers,

    John.
     
  4. JohnyD

    JohnyD New Member

    23
    0
    1
    Another quick one!

    I read somewhere on here that it's meant to come on with the ignition. Should it do this absolutely every time without fail? Just noticed mine isn't doing it today, either with the engine stopped or after a run.

    Cheers,

    John.
     
  5. dancuz

    dancuz Member

    140
    11
    18
    Yeh it should. Check the left hand fuse of the three on top of the battery. If its not that check the plug on to the pump for a dirty connection. Thirdly, hit it with something and see if it starts - if the last one works you either need a new pump or need to clean the brushes on your current one. It could also be the control module but not as likely.....
     
  6. JohnyD

    JohnyD New Member

    23
    0
    1
    Thanks for that. I'll get outside in a minute with the gentle persuasion tool!
     

Share This Page