1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Eggy smell to climate control

hillg81 Nov 3, 2010

  1. hillg81

    hillg81 Member

    94
    3
    8
    Just started noticing yesterday that I have an Eggy smell coming from my climate control

    Only lasts for 2mins when it's first used from cold though

    Any ideas??
     
  2. talentwalsh

    talentwalsh Member

    139
    0
    16
    Do you use it often? The gas can become stagnant if not used for a while. A recharge of gas may be on order
     
  3. s3dave

    s3dave TFSI Hybrid Supporter

    10,110
    736
    38
    No its not the gas, it is bacteria on the condenser.....you can try a disinfectant bomb at halfords about a tenner ....
    common problem if you dont use it regulary
     
  4. BASS 666

    BASS 666 BMW aye right dead on..

    463
    1
    16
    it can be both of the above mine was a dirty pollen filter.
     
  5. hillg81

    hillg81 Member

    94
    3
    8
    Used every day guys!
    What do you think?
    It's due a service at audi soon do will get a new pollen fitted then
     
  6. s3dave

    s3dave TFSI Hybrid Supporter

    10,110
    736
    38
    If you can smell the gas you have a bigger problem and it would be empty within miniutes
     
  7. BASS 666

    BASS 666 BMW aye right dead on..

    463
    1
    16
    i think he meant a smelly system.
     
  8. hillg81

    hillg81 Member

    94
    3
    8
    Not gas guys just a bit of a Eggy smell ;0(
     
  9. BASS 666

    BASS 666 BMW aye right dead on..

    463
    1
    16
    like i say, i changed my pollen filter and it went away so give it a try mate.
     
  10. hillg81

    hillg81 Member

    94
    3
    8
    Didn't do it the morning strange......pollen filter going to be done on service end of this month
     
  11. djarchive

    djarchive Member

    292
    7
    18
    Anybody got a link to a pollen filter? Can it be easily changed?
     
  12. s3dave

    s3dave TFSI Hybrid Supporter

    10,110
    736
    38
    You need to take the scuttle panel off,
    wipers off and carefully unclip the scuttle panel, filter is on the passenger side....
     
  13. DaveA3

    DaveA3 Audi A-Trizzle!

    2,370
    15
    38
    how much are pollen filters mine is starting to smell aswell. i need to open it up anyway as i have loads of leaves behind there
     
  14. DaveA3

    DaveA3 Audi A-Trizzle!

    2,370
    15
    38
  15. hillg81

    hillg81 Member

    94
    3
    8
    I've got a sneaky idea that it's to do with my washer jets!
    Ive not sprayed my washer jets when I got in the car today until tonight!
    If I spray them as soon as the cars started and the climate control is blasting the windscreen the smell appears!
    No washer jets but climate control and it's fine!
     
  16. BASS 666

    BASS 666 BMW aye right dead on..

    463
    1
    16
    that would be really wierd cause they are not linked at all..i know you can smell the screen wash when you spray the window but you would need to be using some nasty stuff lol..
     
  17. hillg81

    hillg81 Member

    94
    3
    8
    It's halfords best!!!!
    I'm going to empty it today and refill and see what happens!
     
  18. A3Tom

    A3Tom Smell my finger.

    3,504
    14
    36
    Could be manky washer water. One of our cars at work smelt real bad of farts when you cleaned the windscreen...the washer fluid had gone off!!. Give it a fill up with warm water with some detol in it or something and then spray it all through before refilling as normal.

    My AC smelt by the way...new pollen filter cured it. Dead easy to fit and no need to remove wipers etc as there was a little flap on my scuttle that I could lift up to get to it etc.
     
  19. hillg81

    hillg81 Member

    94
    3
    8
    Problem sorted!
    Flushed out twice with fairy liquid and its fine now!
    Might do again with something else soon that can remove the **** from inside as the fairy liquidf hasnt removed it all
     

Share This Page