1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ECU'S BROKE!

Discussion in 'A4/S4 forum(B5 Chassis)' started by cossie, Mar 5, 2011.

  1. cossie
    Offline

    cossie Member

    Joined:
    Apr 6, 2010
    Messages:
    73
    Likes Received:
    6
    Have had my 1996 1.8t sport for about 2 years now and its been great. Treated it to a service 3 weeks ago and 4 new disks and pads, not cheap. All good till last week it developed a misfire, not firing on cylinder 2 ive been told. Audi specialist has diagnosed an ecu fault and quoted £846 to supply and fit! Gutted! Probably more than the cars worth. Anyway, ive found a place in Glasgow that says they might be able to repair the ECU, ES Alternators, for a good bit cheaper than a new one. Sorry for rambling on but has anyone had an ecu repaired successfully? Or any other ideas on a cheap solution, really dont want to scrap it. Cheers guys.
    #1
  2. deanski
    Offline

    deanski wax on, wax off

    Joined:
    May 20, 2010
    Messages:
    373
    Likes Received:
    6
    not an audi but my wifes ecu went on her xsara and it got repaired. just depends how bad its got i suppose. good luck fella, hope its a simple job.
    #2
  3. trev m
    Offline

    trev m Member

    Joined:
    Nov 1, 2009
    Messages:
    35
    Likes Received:
    0
    #3
  4. Broken Byzan
    Online

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,568
    Likes Received:
    267
    Have they deffo checked the ignition amp?As that usually drops cyl 2 first before failing.
    #4
  5. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,495
    Likes Received:
    299
    If its cylinder 2 i will put money on it being the Ignition Amplifier.

    Its on top of the airbox.

    If it turns out to actually be the ECU (which is highly unlikely) i've got a spare you can have for not-much-money.
    #5
  6. dest
    Offline

    dest Member

    Joined:
    Jul 18, 2007
    Messages:
    193
    Likes Received:
    8
    Have you got vagcom?
    #6
  7. bengal
    Offline

    bengal Member

    Joined:
    Sep 25, 2010
    Messages:
    537
    Likes Received:
    1
    Before you go buying parts I'd recommend unplugging the ignition amp and checking the contacts for corrosion if they are corroded clean them up with a bit of folded sandpaper or a nail file, if they are ok you can test the amp although if the problem is intermittent it doesn't always work.

    There's a guide here DIY test of power output stage/ignition amp module N122 (long & BWW) - AudiWorld Forums unfortunately the pics aren't working but you should be able to follow it ok.

    The amps are a common problem on the agu engined a3's like I have, Iv'e had to replace it once and recently had to clean the contacts on it as they were gunked up.

    As others have said they miss on cylinder no2 so there's a good chance it will be this rather than the ECU.
    #7
  8. electricracer
    Offline

    electricracer Member

    Joined:
    Aug 30, 2008
    Messages:
    149
    Likes Received:
    0
    if all else fails send ecu to bba reman they will test to be sure. i use them all the time really good:thumbsup:
    #8
  9. sam80quattro
    Offline

    sam80quattro Member

    Joined:
    Dec 12, 2006
    Messages:
    131
    Likes Received:
    0
    get a second hand ecu if you think its broke, i also have a few spares lying about
    #9
  10. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,495
    Likes Received:
    299
    Its extremely unlikely to be the ECU.
    #10
  11. cossie
    Offline

    cossie Member

    Joined:
    Apr 6, 2010
    Messages:
    73
    Likes Received:
    6
    Right guys sorry for the silence but had a lot on recently but a very big thanks for all your repies and imput. Turns out there was nowt wrong with the ecu, it was the ignition amplifier all along. My local mechanic, his auto electrician and an Audi VAG specialist all said faulty ecu. Anyway got a new ignition amplifier in and engines fine apart from new problem. Exhausts now broke off at the cat! Gutted. Going into the garage tomorrow to assess the damage. Exhausts broke at the flexi pipe so hopefully wont need a new cat. Anyway thanks again for all the help.
    #11
  12. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,495
    Likes Received:
    299
    And you now see why i hate garages!
    #12
  13. cossie
    Offline

    cossie Member

    Joined:
    Apr 6, 2010
    Messages:
    73
    Likes Received:
    6
    Agreed Aragorn, robbing bstards.
    #13
  14. Broken Byzan
    Online

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,568
    Likes Received:
    267
    See sometimes useful information is available on the web.LOL

    Glad we could help !
    #14
  15. cossie
    Offline

    cossie Member

    Joined:
    Apr 6, 2010
    Messages:
    73
    Likes Received:
    6
    I see your in South Wales, how about driving the 10 hours or so up to Glasgow and fixing my exhaust for me aswell! Cheers Byzan.
    #15

Share This Page