1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

econ button light always on after on and off?

Discussion in 'A3/S3/Sportback (8P Chassis)' started by aterro, Jul 17, 2011.

  1. aterro
    Offline

    aterro Banana Armour

    Joined:
    Aug 10, 2009
    Messages:
    166
    Likes Received:
    2
    [Jul 17, 2011]
    hello
    at first

    the econ button wouldnt turn off straight away when driving..

    But after the car was on a journey it, i would press the econ button and it would go off and aircon would come on:)

    But now it doesnt go like that all. it wont let me switch the econ button off at all(always lit)

    I havent had a a regas ever.
    i dont want to waste 50 on a regas if its the pump?

    Any ideas, ways to check what is what?
    cheers
    #1
  2. Ads

    Ads

    [Nov 27, 2014]

  3. aterro
    Offline

    aterro Banana Armour

    Joined:
    Aug 10, 2009
    Messages:
    166
    Likes Received:
    2
  4. box500
    Offline

    box500 Member

    Joined:
    Jul 4, 2011
    Messages:
    163
    Likes Received:
    18
    [Jul 17, 2011]
    On most cars, econ staying on is down to no gas. Yours could be a symptom of low gas but I'm no expert.

    Why not take up kwik fit's offer of a re-gas, if it doesn't get 10 degs cooler you don't pay. So if there is a major leak or compressor fault you won't have to pay. p.s. there are plenty of stories of kwik fit finding other "faults" e.g. needs new pads and discs sir, so just get the aircon done and nothing else.
    #3
  5. K50HYL
    Offline

    K50HYL Member

    Joined:
    Jul 2, 2011
    Messages:
    83
    Likes Received:
    0
    [Jul 17, 2011]
    Yea mine is the same.
    Its because it needs a regas.

    Mine has got a leak so i need to get my pipe changed.
    But kwikk fit shouldnt charge you if it has got a leak
    #4
  6. K50HYL
    Offline

    K50HYL Member

    Joined:
    Jul 2, 2011
    Messages:
    83
    Likes Received:
    0
    [Jul 17, 2011]
    Yea mine is the same.
    Its because it needs a regas.

    Mine has got a leak so i need to get my pipe changed.
    But kwikk fit shouldnt charge you if it has got a leak
    #5
  7. jp_s3
    Offline

    jp_s3 New Member

    Joined:
    Mar 2, 2011
    Messages:
    9
    Likes Received:
    0
    [Jul 18, 2011]
    Mine is exactly the same mate and its going into the stealers tomorrow to get fixed. They narrowed it down to the high pressure switch behind the radiator which needs replacing.
    #6
  8. Boydie
    Offline

    Boydie Boycie VCDS Map User

    Joined:
    Dec 24, 2006
    Messages:
    2,859
    Likes Received:
    194
    [Jul 18, 2011]
    Check fuse F8

    This happened to me after getting my aircon gassed at Kwik Fit.

    The econ light would come on if the car was on and stationary and not go off. I vagcom'd it and the V157 fault came up which was related to the throttle body. I replaced this at £175 for the part and it cured it. There is a massive thread on here about it, search "V157"
    #7
  9. aterro
    Offline

    aterro Banana Armour

    Joined:
    Aug 10, 2009
    Messages:
    166
    Likes Received:
    2
    [Nov 18, 2011]
    Just to update this for others
    It was my gas
    It was to low
    Around 10 psi it was so didn't turn on!

    It's all working now :)
    #8

Share This Page