1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Drivers side electric door mirror stopped working

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by alex350r, Aug 12, 2013.

  1. alex350r
    Offline

    alex350r Member

    Joined:
    Aug 12, 2013
    Messages:
    67
    Likes Received:
    3
    [Aug 12, 2013]
    Hi Guys,

    I'm new to the forum - I recently bought a 2006 B7 Audi A4 2.0 TDI. Yesterday I noticed that the electric adjustment on the drivers side door mirror has stopped working. I took the mirror apart this morning using a guide on here. I removed what I assume is the motor - the round part which has a sort of ball joint in the middle? I noticed it was very stiff to move so gave it a good soaking of WD40 but sadly this hasn't helped. I also tried to get a voltage from the connector that attaches to the motor but I couldn't find one - I did try all combinations of the wires. The wierd thing is occasionally it will adjust up but all other directions don't work. I'm currently thinking it's a burnt out motor - what do you think? The next thing I'm planning to do is try the motor in the other mirror to rule out a wiring issue. How much is a replacement motor likely to set me back from Audi? Or am I better scouring fleabay for one?

    Cheers

    Alex
    #1
  2. Ads

    Ads

    [Dec 29, 2014]

  3. alex350r
    Offline

    alex350r Member

    Joined:
    Aug 12, 2013
    Messages:
    67
    Likes Received:
    3
    [Aug 12, 2013]
    I should mention that when the upwards adjustment occasionally works it only moves a tiny bit and then stops again. I'm pretty certain it's the motor. One other thing - are the motors different for each side? I assumed they'd be the same. I've got a part no - 8E2 858 532 L but when searching for that I get the whole mirror assembly back when all I want is the motor.

    Any help would be appreciated.

    Cheers

    Alex
    #2
  4. alex350r
    Offline

    alex350r Member

    Joined:
    Aug 12, 2013
    Messages:
    67
    Likes Received:
    3
    [Aug 12, 2013]
    BUMP - anyone? :sorry:
    #3
  5. hades-
    Offline

    hades- Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,078
    Likes Received:
    558
    [Aug 12, 2013]
    give it time for someone to come and answer
    after all its a work day
    im sure someone will be along soon.
    #4
  6. alex350r
    Offline

    alex350r Member

    Joined:
    Aug 12, 2013
    Messages:
    67
    Likes Received:
    3
    [Aug 14, 2013]
    Ok here's an update - I tried the motor from the drivers side mirror in the passenger side one and it works fine - typical! So it looks like it's an issue with the adjustment switch or perhaps some wiring. The wierd thing is that occasionally the upwards adjustment works on the drivers side for about 2 seconds then stops.

    Has anyone seen this problem before?? I can't believe i'm the first to suffer it. Anyhow it looks like i'll need to take the door card off to get to the switch (something I didn't really want to do!). How hard is it to get the door card off? any walkthroughs on here? I remember on my old Gold MK4 it was a right pain! And any pointers to look for once I get it off?

    Thanks

    Alex
    #5
  7. hades-
    Offline

    hades- Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,078
    Likes Received:
    558
    [Aug 14, 2013]
    yes you need to look in the rubber boot between door and car
    very comon for the wires to break
    #6
  8. alex350r
    Offline

    alex350r Member

    Joined:
    Aug 12, 2013
    Messages:
    67
    Likes Received:
    3
    [Aug 14, 2013]
    Ok thanks - any tutorials for taking the door card off? preferably with pictures? Is it a big job?

    Cheers
    #7
  9. hades-
    Offline

    hades- Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,078
    Likes Received:
    558
    [Aug 14, 2013]
    its not a door card off job

    open the door you will see a black rubber boot going from door to car
    thats where the wires break check in there but have a good look as they break but sometimes done come apart.
    #8
  10. alex350r
    Offline

    alex350r Member

    Joined:
    Aug 12, 2013
    Messages:
    67
    Likes Received:
    3
    [Aug 14, 2013]
    Ah ok brill thanks, i'll have a look tomorrow. Bloody rubber boots - I just fixed the rear washer on my wife's polo, the pipe had split inside one of those rubber boots going to the boot!

    Thanks for your help.
    #9
  11. alex350r
    Offline

    alex350r Member

    Joined:
    Aug 12, 2013
    Messages:
    67
    Likes Received:
    3
    [Aug 25, 2013]
    Checked the rubber boot today but no luck - I did find a wire that had started to break so I cut and re-joined but it turns out this is the speaker wire and nothing to do with the mirror! Any pointers of where to look next as it still doesn't work? Am I going to need to take the door card off now?
    #10
  12. ricostuart
    Offline

    ricostuart Active Member

    Joined:
    Feb 3, 2013
    Messages:
    386
    Likes Received:
    35
    [Aug 26, 2013]
    Sounds like it might be a door card off job. I'm going to do mine at some point, so if you do find a good set of instructions, do please post a link!
    #11

Share This Page