1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DPF light followed by emission control system light

StuF Sep 9, 2013

  1. StuF

    StuF Member

    54
    5
    8
    The dpf light on my 2009 A4 2.0 tdi CR170 has been on and off for the last couple of weeks. This was followed today by the emission control system light which is on continuously. I'm assuming these two are related?

    The car is driving fine by the way. Anyone any other ideas or do I need to get the error codes pulled first?

    Cheers :)
     
  2. hollows wife

    hollows wife Well-Known Member

    1,404
    164
    63
    basically its warning you the dpf is full . or it could be the pressure sensor on the dpf gone faulty .

    get the error codes and get them to check the ash mass of the dpf .
     
  3. @udi A3

    @udi A3 Site Sponsor Site Sponsor VCDS Map User

    1,819
    197
    63
    Where are you based, i may be able able to check and regenerate it if your driving style doesnt allow it to.
     
  4. StuF

    StuF Member

    54
    5
    8
    Cheers fella. Will get the codes pulled as soon as I can. Getting married at the weekend so probably won't get a chance till next week. If I leave it will it eventually go into limp mode? As I've already decided I'll be getting the dpf deleted and the car mapped
     
  5. StuF

    StuF Member

    54
    5
    8
    I'm in Sunderland
     
  6. hollows wife

    hollows wife Well-Known Member

    1,404
    164
    63
    next stage if dpf is full is limp mode when you try to boot it, as it doesnt look like its doing a regen .
    All the best for your wedding day ,congrats to you + your future wife
     
  7. StuF

    StuF Member

    54
    5
    8
    Thanks fella, that's very much appreciated :)

    Ok, will take it for a another spin and try and force a regen tomorrow. If it goes into limp mode, how driveable will it be? Is it simply a case of not being able to generate any boost or does it limit revs? Wouldn't normally be a problem but I'm short on free time at the minute lol
     
  8. NVM

    NVM Member

    98
    67
    18
    Limp mode will reduce turbo pressure and revlimit in everygear at 3000rpm.

    a dpf delete and remap is what you need.
     
  9. StuF

    StuF Member

    54
    5
    8
    Thought as much, the emission control light has gone off today but I suspect it'll make a reappearance lol.
     
  10. @udi A3

    @udi A3 Site Sponsor Site Sponsor VCDS Map User

    1,819
    197
    63
    as per pm happy to plug u in and check soot levels on route to the meet oop north :D
     
  11. StuF

    StuF Member

    54
    5
    8
    Yep definitely fella, it's much appreciated :)
     
  12. Zafi

    Zafi Well-Known Member

    1,299
    326
    83
    Mine was exactly same. Turned out to be the sensor. £85 fitted at Vastech in Northallerton.
     
  13. AudiMrG

    AudiMrG New Member

    16
    0
    1
    Please don't laugh. But have you tried
    3rd gear
    3000 rpm
    3 miles
     
  14. Zafi

    Zafi Well-Known Member

    1,299
    326
    83
    I tried 4000 rpm for 20 miles, did not cure it. Then I plugged in and it all became clear.....
     
  15. helal786

    helal786 New Member

    24
    0
    1
    What was the outcome ?
     
  16. AudiMrG

    AudiMrG New Member

    16
    0
    1
    try read it again 3 is the key number
     
  17. Zafi

    Zafi Well-Known Member

    1,299
    326
    83
    this
     
  18. StuF

    StuF Member

    54
    5
    8
    Sorry lads just got back off my hols so haven't looked at the thread in a while. Error light is still on the dash and the car is still driving fine. Tried driving 20 odd miles at high rpm with no joy.

    Car will hopefully be getting the fault codes pulled on Saturday ;)
     
  19. StuF

    StuF Member

    54
    5
    8
    Update :)

    Tom (@udi A3) very kindly plugged the car in tonight. Turns out the DPF is fine and a sensor has gone.

    5253 - Diesel Particle Filter; Differential Pressure Sensor
    P2452 00 [039] - Elect. Malfunction
    Not Confirmed - Tested Since Memory Clear

    So it looks like it's going to a cheap fix :)
     

Share This Page