1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Doors open read out on DIS.

Westy Jan 13, 2009

  1. Westy

    Westy Well-Known Member

    17,443
    1,103
    113
    I dont think this is meant to happen!

    When I open the drivers door my DIS shows that the drivers door is open. But If I have my drivers door shut and open the passenger door is shows that both doors are open! :wtf:
     
  2. omegadirective

    omegadirective Member

    136
    0
    16
    It's probably the contact switch on the door locks., or the contact circuit. I've just had one replaced at Audi for £170, and that was a good deal. Originally I got quoted over £220 as the door trim has to come off. :(
     
  3. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,328
    1,708
    113
    Does it still show as open when the drivers is shut without passengers open & do the lights go out normally?
     
  4. Westy

    Westy Well-Known Member

    17,443
    1,103
    113
    Not too sure what you mean?

    When both doors are shut the dis shows them shut. When the drivers is open on its own the dis shows just the drivers door open. If only the passenger door is open the dis shows both doors open!
     
  5. Nilz

    Nilz Defo worth the wait :) Team Ibis TFSI Owners Group quattro Audi A4 S-line owners group saloon Manual

    11,329
    876
    113
    Do you have any probs with the Boot, or is it just the doors??

    It could be the microswitch thats causing a problem, there is a common fault on the S3, where in the heat it thinkst that the drivers door is open, i know thats slightly different to what you are having, but it could be something along those lines causing the problem....
     
  6. Westy

    Westy Well-Known Member

    17,443
    1,103
    113
    The boot reports back fine. HAs anyone changed a micro switch themselves cos I dont like the sound of £200 from Audi.
     
  7. RGS3

    RGS3 Member

    125
    5
    18
    Hi there, I had a similar problem a while back - drivers door showing a open intermittently - also meant the alarm wouldnt set. I think its the micro switch and there was a link to replacing the microswitch - looked a bit fiddly so I bought the whole latch assembly from Audi for about £40 and fitted it myself. There's a link on here somewhere about how to do this which I followed - took a few hours but saved me a few quid.
     
  8. RGS3

    RGS3 Member

    125
    5
    18
  9. Westy

    Westy Well-Known Member

    17,443
    1,103
    113
    Thanks, I take a look for the guide cos my alarm doesn't arm either so it may be the same issue you had. How did you diagnose which door switch needed replacing cos mine only has issues when opening the passenger door but its the drivers door that displays as open too!!!
     
  10. Nilz

    Nilz Defo worth the wait :) Team Ibis TFSI Owners Group quattro Audi A4 S-line owners group saloon Manual

    11,329
    876
    113
    I just sprayed inside the keyhole with WD40 and it did the trick....might be worth a go....
     
  11. RGS3

    RGS3 Member

    125
    5
    18
    Sounds odd that both doors are causing a problem - mine was definately only the drivers side. Wish I could find that link for you - there were pictures in the guide.
     
  12. Westy

    Westy Well-Known Member

    17,443
    1,103
    113
    I'll give the WD40 trick ago later that seems like the cheapest/easiest/fastest thing to try at the moment. I'll let you know how it goes.
     
  13. Nilz

    Nilz Defo worth the wait :) Team Ibis TFSI Owners Group quattro Audi A4 S-line owners group saloon Manual

    11,329
    876
    113
    No worries, let us know....
     
  14. Westy

    Westy Well-Known Member

    17,443
    1,103
    113
    Ok the WD40 didn't do a thing except get rid of an annoying squeak I had on the passenger door handle. Oh well I'll get the doors apart at some point.
     
  15. Nilz

    Nilz Defo worth the wait :) Team Ibis TFSI Owners Group quattro Audi A4 S-line owners group saloon Manual

    11,329
    876
    113
    LOL...soz dude, at least you got rid of the squeak :)
     

Share This Page