1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Don't think my ESP is working

Discussion in 'A3/S3 Forum (8L Chassis)' started by S3 Johnny, Sep 16, 2009.

  1. S3 Johnny
    Online

    S3 Johnny The grass isn't always greener

    Joined:
    Sep 11, 2009
    Messages:
    239
    Likes Received:
    0
    [Sep 16, 2009]
    Hi all, i don't know what is wrong with my esp but no lights come on when i push it, i've only had it since 5th oct so only just tryed it,
    Anyone got any ideas?
    Thanks for your time Johnny :kissmyrings:
    #1
  2. emery1990
    Offline

    emery1990 Active Member

    Joined:
    Jun 6, 2009
    Messages:
    1,070
    Likes Received:
    2
    [Sep 16, 2009]
    It might just be an electrical fault, go around some sharpish corners and roundabouts and try using your power, if you cant use your power then the esp's on, if you can use the power then its off.
    #2
  3. simch
    Offline

    simch Active Member

    Joined:
    Feb 22, 2004
    Messages:
    2,028
    Likes Received:
    1
    [Sep 16, 2009]
    5th oct?

    Try it on grass! First, seems an obvious question, but do you have esp? Should be a switch on dash to turn it off if so. What happens if you push the switch? A light should come on on the dash to warn you it's off. This is the same light that should flicker if on and it activates. BUt a stock car needs a bit of provoking to do so, best have a go on wet grass. A few quick starts should see it flicker away as will some attempts at donuts!
    #3
  4. S3 Johnny
    Online

    S3 Johnny The grass isn't always greener

    Joined:
    Sep 11, 2009
    Messages:
    239
    Likes Received:
    0
    [Sep 16, 2009]
    Hi simch, yeah it has got esp it a 2003 S3. but when i push it no lights to be seen. I'll try the wet grass
    #4
  5. SWAMP DONKEY
    Offline

    SWAMP DONKEY New Member

    Joined:
    Oct 28, 2009
    Messages:
    8
    Likes Received:
    0
    [Oct 28, 2009]
    S3 Johnny.

    I think ive got the same problem.

    just bought a 2003 s3

    To be honest i think its just the lamp in the cluster that is faulty.
    #5
  6. lee111s
    Offline

    lee111s Member

    Joined:
    Oct 22, 2009
    Messages:
    51
    Likes Received:
    0
    [Oct 29, 2009]
    Probably a silly question and sorry to hijack the thread.....but does turning off the ESP affect the quattro?
    #6
  7. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition...Its all about the flow... Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    17,332
    Likes Received:
    1,952
    [Oct 29, 2009]
    ESP is on by default, pressing the button turns it off in the first instance and a light should illuminate on the dash.

    First thing to get done would be to use VAGCOM or equiv to see if you have any fault codes and go from there.

    It could be something as simple as the bulb in the cluster gone but as this bulb is only illuminated when switched off then I have my doubts...

    The Haldex system controlling the rear diff (quattro part) is unaffected by switching off ESP.

    <tuffty/>
    #7
  8. Essflee
    Offline

    Essflee Well-Known Member

    Joined:
    Mar 26, 2008
    Messages:
    2,080
    Likes Received:
    41
    [Oct 29, 2009]
    If anything it will allow the haldex to work as it should without having the power constantly took away...
    #8
  9. Dani_B19
    Offline

    Dani_B19 Audi-sports own special child.

    Joined:
    Nov 9, 2008
    Messages:
    7,340
    Likes Received:
    94
    [Oct 29, 2009]
    Like mine, no ESP :p
    #9
  10. Essflee
    Offline

    Essflee Well-Known Member

    Joined:
    Mar 26, 2008
    Messages:
    2,080
    Likes Received:
    41
    [Oct 29, 2009]
    And almost end up in a ditch...:whistle2:
    #10
  11. alijames
    Offline

    alijames Active Member

    Joined:
    Feb 10, 2008
    Messages:
    1,024
    Likes Received:
    0
    [Oct 29, 2009]
    The cynical side of me wonders if there is a fault in the ESP system and the person/dealer you bought the car off took the fuse out or disconnected the lamp to hide the fault.

    Get the car on VAG-COM to check.

    Cheers,
    #11
  12. Westy
    Offline

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,358
    Likes Received:
    1,006
    [Oct 29, 2009]
    The ESP shouldn't stop the haldex from working, it just stops you from getting seriously out of shape by cutting the power while the haldex keeps you going in a straight line.
    #12
  13. jq_quint
    Offline

    jq_quint Member

    Joined:
    Nov 1, 2009
    Messages:
    223
    Likes Received:
    0
    [Nov 15, 2009]
    Def get this checked, my last car (5 series) had same problem, seemed the unscrupulous dealer had blotted out the alarm on the dash to hide the problem..naughty naughty.... hopefully this isn't your problem though..
    #13
  14. bansheeboyo
    Offline

    bansheeboyo Member

    Joined:
    Dec 18, 2008
    Messages:
    201
    Likes Received:
    0
    [Nov 16, 2009]
    my a3 quattro has the same problem i think
    when i first got my car back in oct last year it was snowing ,
    being the imature young lad that i am 360's and handys was the way to go
    but my car was not good ,power kept cutting out .no esp switch in my car
    abs light kept cuming on.
    was out the other night up the mighty backroads car was sliding every where .what gives??
    not that im complaining:),well i might when i end up in a field
    #14

Share This Page