1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dodgy Heater

Discussion in 'A3/S3 Forum (8L Chassis)' started by scoobyra, Nov 30, 2010.

  1. scoobyra
    Offline

    scoobyra It's not f@cking ORANGE!!!!!

    Joined:
    Feb 21, 2008
    Messages:
    798
    Likes Received:
    1
    [Nov 30, 2010]
    The Black S3 appears to have a heater problem. It's not overly warm even on Hi and doesn't blow air out of the passenger side into the footwell. Anyone have any ideas?
    #1
  2. Ads

    Ads

    [Sep 22, 2014]

  3. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    729
    [Nov 30, 2010]
    Maybe the pollen filter needs changing...
    #2
  4. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Dec 1, 2010]
    Possible air lock in the matrix as well.
    #3
  5. jojo
    Online

    jojo S3 Drift King! Staff Member Moderator

    Joined:
    Sep 4, 2003
    Messages:
    26,237
    Likes Received:
    1,676
  6. finesse
    Offline

    finesse Active Member VCDS Map User

    Joined:
    Aug 15, 2006
    Messages:
    2,811
    Likes Received:
    10
    [Dec 1, 2010]
    seems like the new S3 is a big liability
    #5
  7. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,604
    Likes Received:
    276
    [Dec 1, 2010]
    I would have stripped the good bits out for your ORANGE one by now....LMAO


    Seriously its probably faulty flap motors, i would check vagcom and scan the HVAC
    #6
  8. scoobyra
    Offline

    scoobyra It's not f@cking ORANGE!!!!!

    Joined:
    Feb 21, 2008
    Messages:
    798
    Likes Received:
    1
    [Dec 2, 2010]
    Ver funny Joe! LOL

    At the price I paid for it, there's bound to be a few small niggles with it but I can live with that.

    Byz, it's going to take me a month of sundays to swap the bits over and it's so much fun to drive :)
    Good shout with VAG Com, I'll give it a try over the weekend
    #7
  9. AudiS3-Turbo
    Offline

    AudiS3-Turbo Member

    Joined:
    Mar 28, 2010
    Messages:
    589
    Likes Received:
    12
    [Dec 7, 2010]
    Im suffering a similar fault,but no air problems just heater not getting hot just warm ish.

    So far ive done the waterpump,thermostat etc.

    Used vcds to check the operation of the hot/cold flap etc and watched it while it was moving still no problems there,tonight ive removed the matrix pipes and flushed it but nothing came out just clear water but did notice the walls of the heater hoses coated in crud from years of use,if they are in the pipes then they are in teh matrix.

    So ive come to the conclusion that the matrix is just not as efficient as it was when new,so do i rip the dash out....? dont know its not bad enough fro me to do at the mo,but im going to try that rad flush to see if it can dissolve any nastys in the matrix and then replace the coolant.

    If no joy then ive got to do the matrix......bugger
    #8
  10. Emmo
    Offline

    Emmo Member

    Joined:
    Apr 7, 2007
    Messages:
    197
    Likes Received:
    2
    [Dec 7, 2010]
    flush the heater matrix..just remove the pipes and flush forwards and backwards with water or coolant flush.
    Attach ruber hoses to both ends of the matrix in the engine bay and flush using a hosepipe.
    This solved my heating problems.
    Flushing it helped removed the years of **** built up in the matrix.
    #9
  11. guinness
    Offline

    guinness New Member

    Joined:
    Apr 19, 2010
    Messages:
    7
    Likes Received:
    0
    [Dec 17, 2010]
    Hi guys, I'm ONLY getting cold air outta my vents. I guess I should first look at the hot/cold air flap before the heater matrix.

    I'm newish to my '01 S3 - can someone help point me out to where's the best way to look at/get to this flap?

    Also - where is the heater matrix? I guess I need to be looking at that next.

    My S3 also takes a while to get to 90 degrees celsius. I get on the highway right away and at just under 10 degrees outside, it hovers at 60-70 until I get off the highway and idle at the traffic lights. Then it gets to 90 and stays there.

    Thanks!!!

    #10
  12. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    729
    [Dec 17, 2010]
    See if you can hear the flaps moving, from hot to cold....
    It should get to 90 fairly quick with no hovering around 60-70
    #11

Share This Page